aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2014-02-04 05:31:32 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2014-02-04 05:31:32 +0000
commit6b80e5077de34eb80536fbbc488106e317de9a93 (patch)
treea1d4aaceebf82a28d97708e881cbd1cd05291ae6
parentdc04b95449bdf97848488f82381aa1df976695de (diff)
downloadports-6b80e5077de34eb80536fbbc488106e317de9a93.tar.gz
ports-6b80e5077de34eb80536fbbc488106e317de9a93.zip
Notes
-rw-r--r--net-im/finch/Makefile9
-rw-r--r--net-im/libpurple/Makefile43
-rw-r--r--net-im/libpurple/distinfo4
-rw-r--r--net-im/libpurple/files/patch-libpurple-media-backend-fs2.h18
-rw-r--r--net-im/libpurple/files/patch-libpurple-protocols-irc-Makefile.am11
-rw-r--r--net-im/libpurple/files/patch-libpurple-protocols-irc-Makefile.in21
-rw-r--r--net-im/libpurple/files/patch-pidgin_plugins_cap_cap.c11
-rw-r--r--net-im/libpurple/pkg-plist10
-rw-r--r--net-im/pidgin/Makefile13
9 files changed, 43 insertions, 97 deletions
diff --git a/net-im/finch/Makefile b/net-im/finch/Makefile
index 33fdf558f194..13bd7c58c5b9 100644
--- a/net-im/finch/Makefile
+++ b/net-im/finch/Makefile
@@ -3,12 +3,12 @@
# $MCom: ports-stable/net-im/gaim-consoleui-devel/Makefile,v 1.2 2006/10/29 18:55:28 marcus Exp $
PORTNAME= finch
-PORTREVISION= 1
+PORTREVISION= 0
MAINTAINER= marcus@FreeBSD.org
COMMENT= Finch multi-protocol messaging client (Console UI)
-LIB_DEPENDS= purple.10:${PORTSDIR}/net-im/libpurple
+LIB_DEPENDS= libpurple.so:${PORTSDIR}/net-im/libpurple
MASTERDIR= ${.CURDIR}/../libpurple
BUILD_WRKSRC= ${WRKSRC}/finch
@@ -24,10 +24,7 @@ CONFIGURE_ARGS= --disable-gtkui \
--disable-nm \
--with-dynamic_prpls=${PRPL_MODULES:S/,$//}
-MAN1= finch.1
-
-NO_STAGE= yes
post-install:
- ${INSTALL_MAN} ${WRKSRC}/doc/finch.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/doc/finch.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
.include "${MASTERDIR}/Makefile"
diff --git a/net-im/libpurple/Makefile b/net-im/libpurple/Makefile
index f3e15c2933aa..c44f015ef188 100644
--- a/net-im/libpurple/Makefile
+++ b/net-im/libpurple/Makefile
@@ -3,8 +3,8 @@
# $MCom: ports/net-im/libpurple/Makefile,v 1.32 2010/05/10 04:21:19 marcus Exp $
PORTNAME?= libpurple
-PORTVERSION= 2.10.7
-PORTREVISION?= 2
+PORTVERSION= 2.10.8
+PORTREVISION?= 0
CATEGORIES?= net-im
MASTER_SITES= SF/pidgin/Pidgin/${PORTVERSION}
DISTNAME= pidgin-${PORTVERSION}
@@ -73,13 +73,21 @@ OPTIONS_DEFINE+= GTKSPELL CAP
OPTIONS_DEFAULT+= GTKSPELL CAP
GTKSPELL_DESC= Spell checking support
CAP_DESC= Contact Availability Prediction plugin
+PLIST_SUB+= GTKUI=""
+.else
+PLIST_SUB+= GTKUI="@comment not installed: "
+.endif
+
+.if defined(WITH_CONSOLEUI)
+PLIST_SUB+= CONSOLEUI=""
+.else
+PLIST_SUB+= CONSOLEUI="@comment not installed: "
.endif
OPTIONSFILE= ${PORT_DBDIR}/${UNIQUENAME}/options
CONFIGURE_ARGS+=--disable-doxygen
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MTCLTK}
@@ -118,7 +126,7 @@ CONFIGURE_ARGS+=--disable-gstreamer
.endif
.if ${PORT_OPTIONS:MVV} && ${PORT_OPTIONS:MGSTREAMER}
-LIB_DEPENDS+= gstfarsight-0.10.0:${PORTSDIR}/net-im/farsight2
+LIB_DEPENDS+= libgstfarsight-0.10.so:${PORTSDIR}/net-im/farsight2
USE_GSTREAMER+= v4l2
PLIST_SUB+= VV=""
.else
@@ -127,13 +135,13 @@ PLIST_SUB+= VV="@comment "
.endif
.if ${PORT_OPTIONS:MIDN}
-LIB_DEPENDS+= idn.17:${PORTSDIR}/dns/libidn
+LIB_DEPENDS+= libidn.so:${PORTSDIR}/dns/libidn
.else
CONFIGURE_ARGS+=--disable-idn
.endif
.if ${PORT_OPTIONS:MCAP}
-LIB_DEPENDS+= sqlite3.8:${PORTSDIR}/databases/sqlite3
+LIB_DEPENDS+= libsqlite3.so:${PORTSDIR}/databases/sqlite3
CONFIGURE_ARGS+=--enable-cap
PLIST_SUB+= CAP=""
.else
@@ -142,7 +150,7 @@ PLIST_SUB+= CAP="@comment not installed: "
.endif
.if ${PORT_OPTIONS:MGNUTLS}
-LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
+LIB_DEPENDS+= libgnutls.so:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+= --enable-gnutls=yes
PLIST_SUB+= GNUTLS=""
.else
@@ -151,7 +159,7 @@ PLIST_SUB+= GNUTLS="@comment "
.endif
.if ${PORT_OPTIONS:MNSS}
-LIB_DEPENDS+= nss3:${PORTSDIR}/security/nss
+LIB_DEPENDS+= libnss3.so:${PORTSDIR}/security/nss
CONFIGURE_ARGS+= --enable-nss=yes \
--with-nspr-includes=${LOCALBASE}/include/nspr \
--with-nspr-libs=${LOCALBASE}/lib \
@@ -164,12 +172,12 @@ PLIST_SUB+= NSS="@comment "
.endif
.if ${PORT_OPTIONS:MSASL}
-LIB_DEPENDS+= sasl2:${PORTSDIR}/security/cyrus-sasl2
+LIB_DEPENDS+= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
CONFIGURE_ARGS+= --enable-cyrus-sasl
.endif
.if ${PORT_OPTIONS:MBONJOUR}
-LIB_DEPENDS+= avahi-client.3:${PORTSDIR}/net/avahi-app
+LIB_DEPENDS+= libavahi-client.so:${PORTSDIR}/net/avahi-app
PLIST_SUB+= BONJOUR=""
PRPL_MODULES:= bonjour,${PRPL_MODULES}
.else
@@ -178,13 +186,13 @@ PLIST_SUB+= BONJOUR="@comment not installed: "
.endif
.if ${PORT_OPTIONS:MGTKSPELL}
-LIB_DEPENDS+= gtkspell.0:${PORTSDIR}/textproc/gtkspell
+LIB_DEPENDS+= libgtkspell.so:${PORTSDIR}/textproc/gtkspell
.else
CONFIGURE_ARGS+= --disable-gtkspell
.endif
.if ${PORT_OPTIONS:MDBUS}
-LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS+= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
.if !defined(PIDGIN_SLAVE)
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/dbus/__init__.py:${PORTSDIR}/devel/py-dbus
.endif
@@ -200,15 +208,18 @@ USES+= perl5
CONFIGURE_ARGS+= --with-perl-lib=site
PLIST_SUB+= PERL:=""
.if !defined(PIDGIN_SLAVE)
-MAN3+= Purple.3
+PLIST_SUB+= PERLMAN:=""
+.else
+PLIST_SUB+= PERLMAN:="@comment not installed: "
.endif
.else
CONFIGURE_ARGS+= --disable-perl
-PLIST_SUB+= PERL:="@comment not installed: "
+PLIST_SUB+= PERL:="@comment not installed: " \
+ PERLMAN:="@comment not installed: "
.endif
.if ${PORT_OPTIONS:MSAMETIME}
-LIB_DEPENDS+= meanwhile.1:${PORTSDIR}/net-im/meanwhile
+LIB_DEPENDS+= libmeanwhile.so:${PORTSDIR}/net-im/meanwhile
PLIST_SUB+= SAMETIME=""
PRPL_MODULES:= sametime,${PRPL_MODULES}
.else
@@ -217,7 +228,7 @@ CONFIGURE_ARGS+=--disable-meanwhile
.endif
.if ${PORT_OPTIONS:MSILC}
-LIB_DEPENDS+= silcclient-1.1:${PORTSDIR}/devel/silc-toolkit
+LIB_DEPENDS+= libsilcclient-1.so:${PORTSDIR}/devel/silc-toolkit
CONFIGURE_ARGS+= --with-silc-includes=${LOCALBASE}/include/silc \
--with-silc-libs=${LOCALBASE}/lib
PLIST_SUB+= SILC=""
diff --git a/net-im/libpurple/distinfo b/net-im/libpurple/distinfo
index d7e97998ab1e..e8a11bcf5b91 100644
--- a/net-im/libpurple/distinfo
+++ b/net-im/libpurple/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pidgin-2.10.7.tar.bz2) = eba32994eca20d1cf24a4261b059b2de71a1ec2dd0926e904074b0db49f7f192
-SIZE (pidgin-2.10.7.tar.bz2) = 10069279
+SHA256 (pidgin-2.10.8.tar.bz2) = b633367e3588ff3e615d68e812302dfdbe32e73693cbe42a0d827b7aed7a8227
+SIZE (pidgin-2.10.8.tar.bz2) = 10050465
diff --git a/net-im/libpurple/files/patch-libpurple-media-backend-fs2.h b/net-im/libpurple/files/patch-libpurple-media-backend-fs2.h
deleted file mode 100644
index 3ddf151f3a4a..000000000000
--- a/net-im/libpurple/files/patch-libpurple-media-backend-fs2.h
+++ /dev/null
@@ -1,18 +0,0 @@
---- libpurple/media/backend-fs2.h.orig 2010-05-22 16:51:01.677902000 +0800
-+++ libpurple/media/backend-fs2.h 2010-05-23 16:07:07.000000000 +0800
-@@ -59,6 +59,7 @@
- * Temporary function in order to be able to test while
- * integrating with PurpleMedia
- */
-+#ifdef USE_GSTREAMER
- #include <gst/gst.h>
- GstElement *purple_media_backend_fs2_get_src(
- PurpleMediaBackendFs2 *self,
-@@ -70,6 +71,7 @@
- const gchar *sess_id, double level);
- void purple_media_backend_fs2_set_output_volume(PurpleMediaBackendFs2 *self,
- const gchar *sess_id, const gchar *who, double level);
-+#endif
- /* end tmp */
-
- G_END_DECLS
diff --git a/net-im/libpurple/files/patch-libpurple-protocols-irc-Makefile.am b/net-im/libpurple/files/patch-libpurple-protocols-irc-Makefile.am
deleted file mode 100644
index bd62967dd5e2..000000000000
--- a/net-im/libpurple/files/patch-libpurple-protocols-irc-Makefile.am
+++ /dev/null
@@ -1,11 +0,0 @@
---- libpurple/protocols/irc/Makefile.am.orig 2013-02-11 03:16:52.000000000 -0600
-+++ libpurple/protocols/irc/Makefile.am 2013-02-15 15:18:32.950591016 -0600
-@@ -27,7 +27,7 @@
- st =
- pkg_LTLIBRARIES = libirc.la
- libirc_la_SOURCES = $(IRCSOURCES)
--libirc_la_LIBADD = $(GLIB_LIBS)
-+libirc_la_LIBADD = $(GLIB_LIBS) $(SASL_LIBS)
-
- endif
-
diff --git a/net-im/libpurple/files/patch-libpurple-protocols-irc-Makefile.in b/net-im/libpurple/files/patch-libpurple-protocols-irc-Makefile.in
deleted file mode 100644
index e147504a4a68..000000000000
--- a/net-im/libpurple/files/patch-libpurple-protocols-irc-Makefile.in
+++ /dev/null
@@ -1,21 +0,0 @@
---- libpurple/protocols/irc/Makefile.in.orig 2013-02-11 03:17:20.000000000 -0600
-+++ libpurple/protocols/irc/Makefile.in 2013-02-15 15:18:43.256590687 -0600
-@@ -92,7 +92,8 @@
- am__installdirs = "$(DESTDIR)$(pkgdir)"
- LTLIBRARIES = $(noinst_LTLIBRARIES) $(pkg_LTLIBRARIES)
- am__DEPENDENCIES_1 =
--@STATIC_IRC_FALSE@libirc_la_DEPENDENCIES = $(am__DEPENDENCIES_1)
-+@STATIC_IRC_FALSE@libirc_la_DEPENDENCIES = $(am__DEPENDENCIES_1) \
-+@STATIC_IRC_FALSE@ $(am__DEPENDENCIES_1)
- am__libirc_la_SOURCES_DIST = cmds.c dcc_send.c irc.c irc.h msgs.c \
- parse.c
- am__objects_1 = libirc_la-cmds.lo libirc_la-dcc_send.lo \
-@@ -415,7 +416,7 @@
- @STATIC_IRC_TRUE@libirc_la_SOURCES = $(IRCSOURCES)
- @STATIC_IRC_TRUE@libirc_la_CFLAGS = $(AM_CFLAGS)
- @STATIC_IRC_FALSE@pkg_LTLIBRARIES = libirc.la
--@STATIC_IRC_FALSE@libirc_la_LIBADD = $(GLIB_LIBS)
-+@STATIC_IRC_FALSE@libirc_la_LIBADD = $(GLIB_LIBS) $(SASL_LIBS)
- AM_CPPFLAGS = \
- -I$(top_srcdir)/libpurple \
- -I$(top_builddir)/libpurple \
diff --git a/net-im/libpurple/files/patch-pidgin_plugins_cap_cap.c b/net-im/libpurple/files/patch-pidgin_plugins_cap_cap.c
deleted file mode 100644
index 3d37956cc567..000000000000
--- a/net-im/libpurple/files/patch-pidgin_plugins_cap_cap.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- pidgin/plugins/cap/cap.c.orig 2013-03-24 20:34:29.882262000 +0000
-+++ pidgin/plugins/cap/cap.c 2013-03-24 20:34:39.576121000 +0000
-@@ -43,7 +43,7 @@ static double generate_prediction_for(Pu
- int threshold = purple_prefs_get_int("/plugins/gtk/cap/threshold");
- int min_minute = (current_minute - threshold) % 1440;
- int max_minute = (current_minute + threshold) % 1440;
-- char *sql, sta_id = NULL;
-+ char *sql, *sta_id = NULL;
- sqlite3_stmt *stmt = NULL;
- const char *tail = NULL;
- int rc;
diff --git a/net-im/libpurple/pkg-plist b/net-im/libpurple/pkg-plist
index 5b85d8afbbed..2e168f697f58 100644
--- a/net-im/libpurple/pkg-plist
+++ b/net-im/libpurple/pkg-plist
@@ -190,10 +190,14 @@ lib/libpurple.la
lib/libpurple.so
lib/libpurple.so.10
libdata/pkgconfig/purple.pc
+%%CONSOLEUI%%man/man1/finch.1.gz
+%%GTKUI%%man/man1/pidgin.1.gz
+%%PERLMAN:%%man/man3/Purple.3.gz
share/aclocal/purple.m4
share/locale/af/LC_MESSAGES/pidgin.mo
share/locale/am/LC_MESSAGES/pidgin.mo
share/locale/ar/LC_MESSAGES/pidgin.mo
+share/locale/ast/LC_MESSAGES/pidgin.mo
share/locale/az/LC_MESSAGES/pidgin.mo
share/locale/be@latin/LC_MESSAGES/pidgin.mo
share/locale/bg/LC_MESSAGES/pidgin.mo
@@ -282,17 +286,16 @@ share/purple/ca-certs/CAcert_Class3.pem
share/purple/ca-certs/CAcert_Root.pem
share/purple/ca-certs/Deutsche_Telekom_Root_CA_2.pem
share/purple/ca-certs/DigiCertHighAssuranceCA-3.pem
+share/purple/ca-certs/DigiCertHighAssuranceEVRootCA.pem
+share/purple/ca-certs/Entrust.net_2048.pem
share/purple/ca-certs/Entrust.net_Secure_Server_CA.pem
share/purple/ca-certs/Equifax_Secure_CA.pem
share/purple/ca-certs/Equifax_Secure_Global_eBusiness_CA-1.pem
share/purple/ca-certs/GTE_CyberTrust_Global_Root.pem
share/purple/ca-certs/Go_Daddy_Class_2_CA.pem
-share/purple/ca-certs/Microsoft_Internet_Authority.pem
share/purple/ca-certs/Microsoft_Internet_Authority_2010.pem
-share/purple/ca-certs/Microsoft_Secure_Server_Authority.pem
share/purple/ca-certs/Microsoft_Secure_Server_Authority_2010.pem
share/purple/ca-certs/StartCom_Certification_Authority.pem
-share/purple/ca-certs/StartCom_Free_SSL_CA.pem
share/purple/ca-certs/Thawte_Premium_Server_CA.pem
share/purple/ca-certs/Thawte_Primary_Root_CA.pem
share/purple/ca-certs/ValiCert_Class_2_VA.pem
@@ -302,7 +305,6 @@ share/purple/ca-certs/VeriSign_Class_3_Public_Primary_Certification_Authority_-_
share/purple/ca-certs/VeriSign_Class_3_Public_Primary_Certification_Authority_-_G5_2.pem
share/purple/ca-certs/VeriSign_International_Server_Class_3_CA.pem
share/purple/ca-certs/Verisign_Class3_Primary_CA.pem
-share/purple/ca-certs/Verisign_RSA_Secure_Server_CA.pem
share/sounds/purple/alert.wav
share/sounds/purple/login.wav
share/sounds/purple/logout.wav
diff --git a/net-im/pidgin/Makefile b/net-im/pidgin/Makefile
index 346db945dcd8..f63d92dc985e 100644
--- a/net-im/pidgin/Makefile
+++ b/net-im/pidgin/Makefile
@@ -3,13 +3,13 @@
# $MCom: ports/net-im/pidgin/Makefile,v 1.17 2007/09/17 19:53:06 marcus Exp $
PORTNAME= pidgin
-PORTREVISION= 1
+PORTREVISION= 0
MAINTAINER= marcus@FreeBSD.org
COMMENT= Pidgin multi-protocol messaging client (GTK+ UI)
-LIB_DEPENDS= startup-notification-1.0:${PORTSDIR}/x11/startup-notification \
- purple.10:${PORTSDIR}/net-im/libpurple
+LIB_DEPENDS= libstartup-notification-1.so:${PORTSDIR}/x11/startup-notification \
+ libpurple.so:${PORTSDIR}/net-im/libpurple
MASTERDIR= ${.CURDIR}/../libpurple
BUILD_WRKSRC= ${WRKSRC}/pidgin
@@ -30,16 +30,13 @@ CONFIGURE_ARGS= --disable-consoleui \
--enable-screensaver \
--with-dynamic_prpls=${PRPL_MODULES:S/,$//}
-MAN1= pidgin.1
-
-NO_STAGE= yes
post-build:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
Makefile ${MAKE_ARGS} pidgin.desktop
post-install:
${INSTALL_DATA} ${WRKSRC}/pidgin.desktop \
- ${PREFIX}/share/applications/pidgin.desktop
- ${INSTALL_MAN} ${WRKSRC}/doc/pidgin.1 ${MAN1PREFIX}/man/man1
+ ${STAGEDIR}${PREFIX}/share/applications/pidgin.desktop
+ ${INSTALL_MAN} ${WRKSRC}/doc/pidgin.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
.include "${MASTERDIR}/Makefile"