aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-03-14 08:33:43 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-03-14 08:33:43 +0000
commit6d459688afc1d4fc518e32a114d3c4fca96210e2 (patch)
tree77f69d0cf20c8f37a2effeb4ca2e5ab1b05c88e6
parent3d6d601abfd2eefe17b0e9cf5bc2e92683f522a0 (diff)
downloadports-6d459688afc1d4fc518e32a114d3c4fca96210e2.tar.gz
ports-6d459688afc1d4fc518e32a114d3c4fca96210e2.zip
Notes
-rw-r--r--games/plonx/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/games/plonx/Makefile b/games/plonx/Makefile
index 0316e775f17f..1936703af6b0 100644
--- a/games/plonx/Makefile
+++ b/games/plonx/Makefile
@@ -14,16 +14,15 @@ PORTDOCS= README
LDFLAGS+= -lncurses
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
do-build:
${CC} ${CFLAGS} ${LDFLAGS} -o ${WRKSRC}/${PORTNAME} \
${WRKSRC}/${PORTNAME}.c
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>