aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-08-07 04:46:58 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-08-07 04:46:58 +0000
commit6e1a2f845a905a3950429053893a52fcf2b43d5a (patch)
tree5f566b16351f03abbc9276e09d01b27fb43e0771
parent5983d1b71c1786136fcbd1fb6599be9f02bd4939 (diff)
downloadports-6e1a2f845a905a3950429053893a52fcf2b43d5a.tar.gz
ports-6e1a2f845a905a3950429053893a52fcf2b43d5a.zip
Notes
-rw-r--r--www/mod_auth_pgsql/Makefile19
-rw-r--r--www/mod_auth_pgsql/pkg-plist8
-rw-r--r--www/mod_auth_pwcheck/Makefile9
-rw-r--r--www/mod_auth_pwcheck/pkg-plist4
4 files changed, 12 insertions, 28 deletions
diff --git a/www/mod_auth_pgsql/Makefile b/www/mod_auth_pgsql/Makefile
index cfad072dea22..fbe5e8d91e0c 100644
--- a/www/mod_auth_pgsql/Makefile
+++ b/www/mod_auth_pgsql/Makefile
@@ -16,10 +16,6 @@ COMMENT= Allows users to use PostgreSQL databases for user authentication
BUILD_DEPENDS= ${APXS}:${PORTSDIR}/${APACHE_PORT}
RUN_DEPENDS= ${LOCALBASE}/sbin/${AP_TARGET}:${PORTSDIR}/${APACHE_PORT}
-BROKEN= Incomplete pkg-plist
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2005-09-22
-
USE_PGSQL= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/a//}
@@ -42,26 +38,21 @@ AP_INCLUDE?= ${PREFIX}/include/apache
AP_LIBEXEC?= ${PREFIX}/libexec/apache
.endif
-AUTH_PGSQL_DOCS= apache/manual/mod/mod_auth_pgsql
-
-PLIST_SUB+= AUTH_PGSQL_DOCS="${AUTH_PGSQL_DOCS}"
-
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --with-pgsql=${PREFIX} \
--with-apxs=${APXS}
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/${AUTH_PGSQL_DOCS}
+ @${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README \
- ${PREFIX}/share/doc/${AUTH_PGSQL_DOCS}/
+ ${DOCSDIR}
${TR} -d \\015 < ${WRKSRC}/mod_auth_pgsql.html \
- > ${PREFIX}/share/doc/${AUTH_PGSQL_DOCS}/index.html
+ > ${DOCSDIR}/index.html
${CHMOD} ${SHAREMODE} \
- ${PREFIX}/share/doc/${AUTH_PGSQL_DOCS}/index.html
+ ${DOCSDIR}/index.html
${CHOWN} ${SHAREOWN}:${SHAREGRP} \
- ${PREFIX}/share/doc/${AUTH_PGSQL_DOCS}/index.html
- ${LN} -sf ${AUTH_PGSQL_DOCS} ${PREFIX}/share/doc/
+ ${DOCSDIR}/index.html
.endif
${CAT} ${PKGMESSAGE}
diff --git a/www/mod_auth_pgsql/pkg-plist b/www/mod_auth_pgsql/pkg-plist
index cebde9580495..da8c9599e813 100644
--- a/www/mod_auth_pgsql/pkg-plist
+++ b/www/mod_auth_pgsql/pkg-plist
@@ -1,8 +1,6 @@
libexec/apache/mod_auth_pgsql.so
@exec %D/sbin/apxs -e -a -n auth_pgsql %f
@unexec %D/sbin/apxs -e -A -n auth_pgsql %f
-%%PORTDOCS%%share/doc/%%AUTH_PGSQL_DOCS%%/README
-%%PORTDOCS%%share/doc/%%AUTH_PGSQL_DOCS%%/index.html
-%%PORTDOCS%%@exec (cd %D/share/doc && ln -sf %%AUTH_PGSQL_DOCS%% mod_auth_pgsql)
-%%PORTDOCS%%@unexec rm -f %D/share/doc/mod_auth_pgsql
-%%PORTDOCS%%@dirrm share/doc/%%AUTH_PGSQL_DOCS%%
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/www/mod_auth_pwcheck/Makefile b/www/mod_auth_pwcheck/Makefile
index bc8c383c861b..347289556e72 100644
--- a/www/mod_auth_pwcheck/Makefile
+++ b/www/mod_auth_pwcheck/Makefile
@@ -18,12 +18,9 @@ BUILD_DEPENDS= ${APXS}:${PORTSDIR}/${APACHE_PORT}
RUN_DEPENDS= ${LOCALBASE}/sbin/${AP_TARGET}:${PORTSDIR}/${APACHE_PORT} \
${LOCALBASE}/sbin/pwcheck:${PORTSDIR}/security/cyrus-sasl
-BROKEN= Incomplete pkg-plist
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2005-09-22
-
WRKSRC= ${WRKDIR}/${PORTNAME}
APACHE_PORT?= ${AP_CATEGORY}/${AP_PORT}
+MAKE_ARGS+= DOC_DIR="${DOCSDIR}"
.include <bsd.port.pre.mk>
@@ -43,9 +40,7 @@ AP_CATEGORY= www
.endif
AP_PORT= apache13${AP_MOD_SSL_SUFFIX}
-AUTH_PWCHECK_DOCS= share/doc/apache/manual/mod/mod_auth_pwcheck
-PLIST_SUB= AUTH_PWCHECK_DOCS="${AUTH_PWCHECK_DOCS}" \
- AP_LIBEXEC="${AP_LIBEXEC}" \
+PLIST_SUB= AP_LIBEXEC="${AP_LIBEXEC}" \
AP_SYSCONF="${AP_SYSCONF}" \
APXS="${APXS}"
diff --git a/www/mod_auth_pwcheck/pkg-plist b/www/mod_auth_pwcheck/pkg-plist
index 5b80e7e92e63..bfccea483e5e 100644
--- a/www/mod_auth_pwcheck/pkg-plist
+++ b/www/mod_auth_pwcheck/pkg-plist
@@ -1,5 +1,5 @@
%%AP_LIBEXEC%%/mod_auth_pwcheck.so
-%%AUTH_PWCHECK_DOCS%%/index.html
+%%DOCSDIR%%/index.html
@unexec %%APXS%% -e -A -n auth_pwcheck mod_auth_pwcheck.so
@unexec /bin/rm %%AP_SYSCONF%%/httpd.conf.bak
-@dirrm %%AUTH_PWCHECK_DOCS%%
+@dirrm %%DOCSDIR%%