aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2015-01-22 12:18:00 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2015-01-22 12:18:00 +0000
commit7c8e3e37648afa84fa0cefaa2dfecd85973f78bb (patch)
treed99e951752a922f4cec56c5f460a7348a3a37e5b
parentf4adc4a3caffca818f2aff04a683b402e762d9cc (diff)
downloadports-7c8e3e37648afa84fa0cefaa2dfecd85973f78bb.tar.gz
ports-7c8e3e37648afa84fa0cefaa2dfecd85973f78bb.zip
Notes
-rw-r--r--Mk/bsd.options.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 949cf28a7cbf..1290d72c3bf2 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -99,6 +99,8 @@
# USE_FOO+= bar
# If you need more than one option, you can do
# FOO=bar,baz and you'll get USE_FOO=bar baz
+# ${opt}_USE_OFF= FOO=bar When option is disabled, it will enable
+# USE_FOO+= bar
#
# For each of:
# ALL_TARGET CATEGORIES CFLAGS CONFIGURE_ENV CONFLICTS CONFLICTS_BUILD
@@ -460,6 +462,12 @@ ${deptype}_DEPENDS+= ${${opt}_${deptype}_DEPENDS}
. endif
. endfor
. else
+. if defined(${opt}_USE_OFF)
+. for option in ${${opt}_USE_OFF}
+_u= ${option:C/=.*//g}
+USE_${_u:tu}+= ${option:C/.*=//g:C/,/ /g}
+. endfor
+. endif
. if defined(${opt}_CONFIGURE_ENABLE)
. for iopt in ${${opt}_CONFIGURE_ENABLE}
CONFIGURE_ARGS+= --disable-${iopt:C/=.*//}