aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-11-23 23:04:57 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-11-23 23:04:57 +0000
commit7cbeacae408a7791c2644259774bb0c5847c0982 (patch)
tree10c125c3c0aa62edeb1960cb38a014b471f701a5
parent26fe3ecc4bf1605d547d30c7f0be9442836d8350 (diff)
downloadports-7cbeacae408a7791c2644259774bb0c5847c0982.tar.gz
ports-7cbeacae408a7791c2644259774bb0c5847c0982.zip
Notes
-rw-r--r--mail/gnome-gmail-notifier/Makefile10
-rw-r--r--mail/gnome-gmail-notifier/files/patch-src_main.c19
2 files changed, 23 insertions, 6 deletions
diff --git a/mail/gnome-gmail-notifier/Makefile b/mail/gnome-gmail-notifier/Makefile
index 9a99029f921c..5e651f8f217a 100644
--- a/mail/gnome-gmail-notifier/Makefile
+++ b/mail/gnome-gmail-notifier/Makefile
@@ -2,16 +2,16 @@
PORTNAME= gnome-gmail-notifier
PORTVERSION= 0.10.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= mail deskutils
MASTER_SITES= GOOGLE_CODE
MAINTAINER= ports@FreeBSD.org
COMMENT= Gmail Inbox Monitor for the GNOME2 desktop
-LIB_DEPENDS= notify.4:${PORTSDIR}/devel/libnotify \
- soup-2.4:${PORTSDIR}/devel/libsoup \
- gnome-keyring.0:${PORTSDIR}/security/gnome-keyring
+LIB_DEPENDS= libnotify.so:${PORTSDIR}/devel/libnotify \
+ libsoup-2.4.so:${PORTSDIR}/devel/libsoup \
+ libgnome-keyring.so:${PORTSDIR}/security/libgnome-keyring
GNU_CONFIGURE= yes
USE_BZIP2= yes
@@ -20,10 +20,8 @@ USE_GNOME= glib20 gtk20 gconf2 libxml2 librsvg2
USE_GSTREAMER= good
LDFLAGS+= -L${LOCALBASE}/lib -lintl
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|@DATADIRNAME@|share|' ${WRKSRC}/po/Makefile.in.in
@${REINPLACE_CMD} -e 's|<glib/gthread.h>|<glib.h>|g' ${WRKSRC}/src/main.h
-
.include <bsd.port.mk>
diff --git a/mail/gnome-gmail-notifier/files/patch-src_main.c b/mail/gnome-gmail-notifier/files/patch-src_main.c
new file mode 100644
index 000000000000..6ee2fe4f0922
--- /dev/null
+++ b/mail/gnome-gmail-notifier/files/patch-src_main.c
@@ -0,0 +1,19 @@
+--- src/main.c.orig 2013-11-23 23:59:43.000000000 +0100
++++ src/main.c 2013-11-24 00:00:28.000000000 +0100
+@@ -58,6 +58,7 @@
+
+ /* start gdk threads. */
+ gdk_threads_init ();
++ gdk_threads_enter();
+
+ /* lock and start gtk. */
+ gtk_init (&argc, &argv);
+@@ -71,6 +72,8 @@
+ /* punt control to the manager. */
+ ggn_manager_main (manager, argc, argv);
+
++ gdk_threads_leave();
++
+ /* exit the application. */
+ return 0;
+ }