aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-12-21 08:59:42 +0000
committerClement Laforet <clement@FreeBSD.org>2004-12-21 08:59:42 +0000
commit7ef18bc03149b2fd5fc002e2e5a219c3796ee2e8 (patch)
tree14e5daf0321e5bcec6a69cf36c14c650a67788ed
parent01b976f45a05e3b5dd2a265a53effbf87560d087 (diff)
downloadports-7ef18bc03149b2fd5fc002e2e5a219c3796ee2e8.tar.gz
ports-7ef18bc03149b2fd5fc002e2e5a219c3796ee2e8.zip
Notes
-rw-r--r--mail/anubis/Makefile6
-rw-r--r--mail/anubis/files/patch-configure28
-rw-r--r--mail/claws-mail/Makefile7
-rw-r--r--mail/elmo-devel/Makefile4
-rw-r--r--mail/elmo/Makefile4
-rw-r--r--mail/sylpheed-claws/Makefile7
-rw-r--r--mail/sylpheed-gtk2/Makefile7
-rw-r--r--mail/sylpheed/Makefile7
-rw-r--r--mail/sylpheed2-devel/Makefile7
-rw-r--r--mail/sylpheed2/Makefile7
-rw-r--r--mail/sylpheed3/Makefile7
-rw-r--r--net-im/ayttm/Makefile7
-rw-r--r--net/ayttm/Makefile7
-rw-r--r--security/cryptplug/Makefile9
-rw-r--r--security/gpgme03/Makefile14
-rw-r--r--security/gpgme03/files/patch-configure.ac11
-rw-r--r--security/gpgme03/files/patch-doc:Makefile.in20
-rw-r--r--security/gpgme03/files/patch-doc:gpgme.info11
-rw-r--r--security/gpgme03/files/patch-gpgme:Makefile.in47
-rw-r--r--security/gpgme03/pkg-plist13
-rw-r--r--security/ruby-gpgme/Makefile3
-rw-r--r--security/ruby-gpgme/files/patch-extconf.rb9
-rw-r--r--security/ruby-gpgme/files/patch-gpgme_n.c11
-rw-r--r--security/seahorse/Makefile7
24 files changed, 213 insertions, 47 deletions
diff --git a/mail/anubis/Makefile b/mail/anubis/Makefile
index a77bd07be293..2a7f71e77d8a 100644
--- a/mail/anubis/Makefile
+++ b/mail/anubis/Makefile
@@ -31,7 +31,8 @@ USE_REINPLACE= yes
USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= MAKEINFO="makeinfo --no-split" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV= MAKEINFO="makeinfo --no-split" LDFLAGS="${LDFLAGS}" \
+ CFLAGS="${CFLAGS}" CPPFLAGS="${CFLAGS}"
LDFLAGS+= -L${LOCALBASE}/lib
.if defined(WITHOUT_NLS)
@@ -57,7 +58,8 @@ CONFIGURE_ARGS+= --without-gnutls
.if defined(WITHOUT_GPGME)
CONFIGURE_ARGS+= --without-gpgme
.else
-LIB_DEPENDS+= gpgme:${PORTSDIR}/security/gpgme03
+LIB_DEPENDS+= gpgme03.9:${PORTSDIR}/security/gpgme03
+CFLAGS+= -I${LOCALBASE}/include/gpgme03
.endif
# PCRE
diff --git a/mail/anubis/files/patch-configure b/mail/anubis/files/patch-configure
new file mode 100644
index 000000000000..641761441f7b
--- /dev/null
+++ b/mail/anubis/files/patch-configure
@@ -0,0 +1,28 @@
+--- configure.orig Mon Dec 20 20:32:43 2004
++++ configure Mon Dec 20 20:34:13 2004
+@@ -8603,13 +8603,13 @@
+
+ else
+
+-echo "$as_me:$LINENO: checking for main in -lgpgme" >&5
+-echo $ECHO_N "checking for main in -lgpgme... $ECHO_C" >&6
++echo "$as_me:$LINENO: checking for main in -lgpgme03" >&5
++echo $ECHO_N "checking for main in -lgpgme03... $ECHO_C" >&6
+ if test "${ac_cv_lib_gpgme_main+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lgpgme $LIBS"
++LIBS="-lgpgme03 $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line $LINENO "configure"
+ /* confdefs.h. */
+@@ -8656,7 +8656,7 @@
+ #define HAVE_LIBGPGME 1
+ _ACEOF
+
+- LIBS="-lgpgme $LIBS"
++ LIBS="-lgpgme03 $LIBS"
+
+ else
+ with_gpgme=no
diff --git a/mail/claws-mail/Makefile b/mail/claws-mail/Makefile
index 1370c4e301eb..560a7b03cc53 100644
--- a/mail/claws-mail/Makefile
+++ b/mail/claws-mail/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sylpheed-claws
PORTVERSION= 0.9.13
-PORTREVISION= 1
+PORTREVISION= 3
CATEGORIES= mail news ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sylpheed-claws
@@ -123,7 +123,7 @@ PLIST_SUB+= SA_PLUG="@comment "
.endif
.if defined(WITH_GPGME) || defined(WITH_ALL)
PLIST_SUB+= GPGME=""
-LIB_DEPENDS+= gpgme.9:${PORTSDIR}/security/gpgme03
+LIB_DEPENDS+= gpgme03.9:${PORTSDIR}/security/gpgme03
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
.else
PLIST_SUB+= GPGME="@comment "
@@ -170,7 +170,8 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e \
- 's|-lresolv||g; s|-lpisock\"|-liconv &|g' ${WRKSRC}/configure
+ 's|-lresolv||g; s|-lpisock\"|-liconv &|g ;\
+ s|gpgme-config|gpgme03-config|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" \
${WRKSRC}/tools/README.sylprint ${WRKSRC}/tools/sylprint.pl
@${REINPLACE_CMD} -e "s|po intl src|po src|" ${WRKSRC}/Makefile.in
diff --git a/mail/elmo-devel/Makefile b/mail/elmo-devel/Makefile
index a0ed3a9d0ad8..c77049a25d9e 100644
--- a/mail/elmo-devel/Makefile
+++ b/mail/elmo-devel/Makefile
@@ -33,8 +33,8 @@ MAN1= elmo.1 elmoconf.pl.1
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libgpgme.so) || defined(WITH_GPGME)
-LIB_DEPENDS+= gpgme:${PORTSDIR}/security/gpgme03
+.if exists(${LOCALBASE}/lib/libgpgme03.so) || defined(WITH_GPGME)
+LIB_DEPENDS+= gpgme03:${PORTSDIR}/security/gpgme03
.else
pre-everything::
@${ECHO_CMD}
diff --git a/mail/elmo/Makefile b/mail/elmo/Makefile
index 6f031105617f..27b9c0dc5660 100644
--- a/mail/elmo/Makefile
+++ b/mail/elmo/Makefile
@@ -29,8 +29,8 @@ MAN1= elmo.1 elmoconf.pl.1
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libgpgme.so) || defined(WITH_GPGME)
-LIB_DEPENDS+= gpgme:${PORTSDIR}/security/gpgme03
+.if exists(${LOCALBASE}/lib/libgpgme03.so) || defined(WITH_GPGME)
+LIB_DEPENDS+= gpgme03:${PORTSDIR}/security/gpgme03
.else
pre-everything::
@${ECHO_CMD}
diff --git a/mail/sylpheed-claws/Makefile b/mail/sylpheed-claws/Makefile
index 1370c4e301eb..560a7b03cc53 100644
--- a/mail/sylpheed-claws/Makefile
+++ b/mail/sylpheed-claws/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sylpheed-claws
PORTVERSION= 0.9.13
-PORTREVISION= 1
+PORTREVISION= 3
CATEGORIES= mail news ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sylpheed-claws
@@ -123,7 +123,7 @@ PLIST_SUB+= SA_PLUG="@comment "
.endif
.if defined(WITH_GPGME) || defined(WITH_ALL)
PLIST_SUB+= GPGME=""
-LIB_DEPENDS+= gpgme.9:${PORTSDIR}/security/gpgme03
+LIB_DEPENDS+= gpgme03.9:${PORTSDIR}/security/gpgme03
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
.else
PLIST_SUB+= GPGME="@comment "
@@ -170,7 +170,8 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e \
- 's|-lresolv||g; s|-lpisock\"|-liconv &|g' ${WRKSRC}/configure
+ 's|-lresolv||g; s|-lpisock\"|-liconv &|g ;\
+ s|gpgme-config|gpgme03-config|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" \
${WRKSRC}/tools/README.sylprint ${WRKSRC}/tools/sylprint.pl
@${REINPLACE_CMD} -e "s|po intl src|po src|" ${WRKSRC}/Makefile.in
diff --git a/mail/sylpheed-gtk2/Makefile b/mail/sylpheed-gtk2/Makefile
index bc4e570d497b..db27473acfec 100644
--- a/mail/sylpheed-gtk2/Makefile
+++ b/mail/sylpheed-gtk2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sylpheed-gtk2
PORTVERSION= 0.9.99.20041024
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -44,7 +44,7 @@ CONFIGURE_ARGS+= --enable-ssl
.endif
.if defined(WITH_GPGME)
-LIB_DEPENDS+= gpgme.9:${PORTSDIR}/security/gpgme03
+LIB_DEPENDS+= gpgme03.9:${PORTSDIR}/security/gpgme03
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
CONFIGURE_ARGS+= --enable-gpgme
.endif
@@ -71,7 +71,8 @@ post-patch:
's|-lpthread|${PTHREAD_LIBS:S/"//g}|g; \
s|-lresolv||g; s|-lpisock\"|-liconv &|g; \
s|^manualdir=.*|manualdir="${DOCSDIR}/manual"|g; \
- s|^faqdir=.*|faqdir="${DOCSDIR}/faq"|g' \
+ s|^faqdir=.*|faqdir="${DOCSDIR}/faq"|g ;\
+ s|gpgme-config|gpgme03-config|g' \
${WRKSRC}/${CONFIGURE_SCRIPT}
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e 's|^SUBDIRS = ac po src manual faq$$|SUBDIRS = ac po src|g' \
diff --git a/mail/sylpheed/Makefile b/mail/sylpheed/Makefile
index 5ba45e3a1663..283d945f5b35 100644
--- a/mail/sylpheed/Makefile
+++ b/mail/sylpheed/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sylpheed
PORTVERSION= 1.0.0.r.1
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_LOCAL:S/$/:mime/} \
http://sylpheed.good-day.net/sylpheed/:source \
@@ -55,7 +55,7 @@ CONFIGURE_ARGS+=--disable-imlib
CONFIGURE_ARGS+=--disable-gdk-pixbuf
.endif
.if defined(WITH_GPGME)
-LIB_DEPENDS+= gpgme.9:${PORTSDIR}/security/gpgme03
+LIB_DEPENDS+= gpgme03.9:${PORTSDIR}/security/gpgme03
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
CONFIGURE_ARGS+=--enable-gpgme
.else
@@ -106,7 +106,8 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g; \
- s|-lresolv||g; s|-lpisock\"|-liconv &|g' ${WRKSRC}/configure
+ s|-lresolv||g; s|-lpisock\"|-liconv &|g; \
+ s|gpgme-config|gpgme03-config|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|mime\.types|sylpheed-mime\.types|g' \
${WRKSRC}/src/procmime.c
diff --git a/mail/sylpheed2-devel/Makefile b/mail/sylpheed2-devel/Makefile
index 5ba45e3a1663..283d945f5b35 100644
--- a/mail/sylpheed2-devel/Makefile
+++ b/mail/sylpheed2-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sylpheed
PORTVERSION= 1.0.0.r.1
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_LOCAL:S/$/:mime/} \
http://sylpheed.good-day.net/sylpheed/:source \
@@ -55,7 +55,7 @@ CONFIGURE_ARGS+=--disable-imlib
CONFIGURE_ARGS+=--disable-gdk-pixbuf
.endif
.if defined(WITH_GPGME)
-LIB_DEPENDS+= gpgme.9:${PORTSDIR}/security/gpgme03
+LIB_DEPENDS+= gpgme03.9:${PORTSDIR}/security/gpgme03
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
CONFIGURE_ARGS+=--enable-gpgme
.else
@@ -106,7 +106,8 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g; \
- s|-lresolv||g; s|-lpisock\"|-liconv &|g' ${WRKSRC}/configure
+ s|-lresolv||g; s|-lpisock\"|-liconv &|g; \
+ s|gpgme-config|gpgme03-config|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|mime\.types|sylpheed-mime\.types|g' \
${WRKSRC}/src/procmime.c
diff --git a/mail/sylpheed2/Makefile b/mail/sylpheed2/Makefile
index 5ba45e3a1663..283d945f5b35 100644
--- a/mail/sylpheed2/Makefile
+++ b/mail/sylpheed2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sylpheed
PORTVERSION= 1.0.0.r.1
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_LOCAL:S/$/:mime/} \
http://sylpheed.good-day.net/sylpheed/:source \
@@ -55,7 +55,7 @@ CONFIGURE_ARGS+=--disable-imlib
CONFIGURE_ARGS+=--disable-gdk-pixbuf
.endif
.if defined(WITH_GPGME)
-LIB_DEPENDS+= gpgme.9:${PORTSDIR}/security/gpgme03
+LIB_DEPENDS+= gpgme03.9:${PORTSDIR}/security/gpgme03
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
CONFIGURE_ARGS+=--enable-gpgme
.else
@@ -106,7 +106,8 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g; \
- s|-lresolv||g; s|-lpisock\"|-liconv &|g' ${WRKSRC}/configure
+ s|-lresolv||g; s|-lpisock\"|-liconv &|g; \
+ s|gpgme-config|gpgme03-config|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|mime\.types|sylpheed-mime\.types|g' \
${WRKSRC}/src/procmime.c
diff --git a/mail/sylpheed3/Makefile b/mail/sylpheed3/Makefile
index 5ba45e3a1663..283d945f5b35 100644
--- a/mail/sylpheed3/Makefile
+++ b/mail/sylpheed3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sylpheed
PORTVERSION= 1.0.0.r.1
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_LOCAL:S/$/:mime/} \
http://sylpheed.good-day.net/sylpheed/:source \
@@ -55,7 +55,7 @@ CONFIGURE_ARGS+=--disable-imlib
CONFIGURE_ARGS+=--disable-gdk-pixbuf
.endif
.if defined(WITH_GPGME)
-LIB_DEPENDS+= gpgme.9:${PORTSDIR}/security/gpgme03
+LIB_DEPENDS+= gpgme03.9:${PORTSDIR}/security/gpgme03
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
CONFIGURE_ARGS+=--enable-gpgme
.else
@@ -106,7 +106,8 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g; \
- s|-lresolv||g; s|-lpisock\"|-liconv &|g' ${WRKSRC}/configure
+ s|-lresolv||g; s|-lpisock\"|-liconv &|g; \
+ s|gpgme-config|gpgme03-config|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|mime\.types|sylpheed-mime\.types|g' \
${WRKSRC}/src/procmime.c
diff --git a/net-im/ayttm/Makefile b/net-im/ayttm/Makefile
index 0124534bd915..0740cc687f68 100644
--- a/net-im/ayttm/Makefile
+++ b/net-im/ayttm/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ayttm
PORTVERSION= 0.4.6.17
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,7 +18,7 @@ COMMENT= A "chat" program that combines AIM, ICQ, and Yahoo! Chat into one
LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile \
jasper.4:${PORTSDIR}/graphics/jasper \
- gpgme.9:${PORTSDIR}/security/gpgme03 \
+ gpgme03.9:${PORTSDIR}/security/gpgme03 \
pspell.16:${PORTSDIR}/textproc/aspell
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
@@ -79,7 +79,8 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g; \
- s|-pthread|${PTHREAD_CFLAGS:S/"//g}|g' ${WRKSRC}/configure
+ s|-pthread|${PTHREAD_CFLAGS:S/"//g}|g; \
+ s|gpgme-config|gpgme03-config|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|= pixmaps|=|g ; \
s|^Utilities|#Utilities|g ; \
s|^gnome|#gnome|g' ${WRKSRC}/Makefile.in
diff --git a/net/ayttm/Makefile b/net/ayttm/Makefile
index 0124534bd915..0740cc687f68 100644
--- a/net/ayttm/Makefile
+++ b/net/ayttm/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ayttm
PORTVERSION= 0.4.6.17
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,7 +18,7 @@ COMMENT= A "chat" program that combines AIM, ICQ, and Yahoo! Chat into one
LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile \
jasper.4:${PORTSDIR}/graphics/jasper \
- gpgme.9:${PORTSDIR}/security/gpgme03 \
+ gpgme03.9:${PORTSDIR}/security/gpgme03 \
pspell.16:${PORTSDIR}/textproc/aspell
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
@@ -79,7 +79,8 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g; \
- s|-pthread|${PTHREAD_CFLAGS:S/"//g}|g' ${WRKSRC}/configure
+ s|-pthread|${PTHREAD_CFLAGS:S/"//g}|g; \
+ s|gpgme-config|gpgme03-config|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|= pixmaps|=|g ; \
s|^Utilities|#Utilities|g ; \
s|^gnome|#gnome|g' ${WRKSRC}/Makefile.in
diff --git a/security/cryptplug/Makefile b/security/cryptplug/Makefile
index 1f235ab6650c..da978a9a5bfa 100644
--- a/security/cryptplug/Makefile
+++ b/security/cryptplug/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cryptplug
PORTVERSION= 0.3.16
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= alpha/cryptplug
@@ -15,11 +15,16 @@ MASTER_SITE_SUBDIR= alpha/cryptplug
MAINTAINER= lofi@freebsd.org
COMMENT= A collection of plug-ins to cryptographic engines
-BUILD_DEPENDS= ${LOCALBASE}/lib/libgpgme.so.9:${PORTSDIR}/security/gpgme03 \
+BUILD_DEPENDS= ${LOCALBASE}/lib/libgpgme03.so.9:${PORTSDIR}/security/gpgme03 \
gpg-agent:${PORTSDIR}/security/gnupg-devel
USE_INC_LIBTOOL_VER=13
USE_GMAKE= yes
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} 's/gpgme-config/gpgme03-config/g' \
+ ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/security/gpgme03/Makefile b/security/gpgme03/Makefile
index e6780f6d4fe1..8a7aa1b4512d 100644
--- a/security/gpgme03/Makefile
+++ b/security/gpgme03/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gpgme
PORTVERSION= 0.3.16
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= gpgme
@@ -24,9 +24,13 @@ LATEST_LINK= gpgme03
USE_INC_LIBTOOL_VER=13
USE_GMAKE= yes
+USE_AUTOCONF_VER= 259
INSTALLS_SHLIB= yes
+USE_REINPLACE= YES
-INFO= gpgme
+INFO= gpgme03
+
+CONFIGURE_ARGS+= --includedir=${PREFIX}/include/gpgme03
.include <bsd.port.pre.mk>
@@ -40,4 +44,10 @@ BUILD_DEPENDS+= gpgsm:${PORTSDIR}/security/gnupg-devel
CONFIGURE_ARGS+= --without-gpgsm
.endif
+post-patch:
+.for i in tests tests/gpg tests/gpgsm
+ @${REINPLACE_CMD} -e 's/libgpgme.la/libgpgme03.la/' \
+ ${WRKSRC}/${i}/Makefile.in
+.endfor
+
.include <bsd.port.post.mk>
diff --git a/security/gpgme03/files/patch-configure.ac b/security/gpgme03/files/patch-configure.ac
new file mode 100644
index 000000000000..03d04b7627ba
--- /dev/null
+++ b/security/gpgme03/files/patch-configure.ac
@@ -0,0 +1,11 @@
+--- configure.ac.orig Mon Dec 20 10:46:39 2004
++++ configure.ac Mon Dec 20 10:47:30 2004
+@@ -246,7 +246,7 @@
+ GNUPG_FIX_HDR_VERSION(gpgme/gpgme.h, GPGME_VERSION)
+
+ dnl Substitution used for gpgme-config
+-GPGME_CONFIG_LIBS="-lgpgme"
++GPGME_CONFIG_LIBS="-lgpgme03"
+ GPGME_CONFIG_CFLAGS=""
+ AC_SUBST(GPGME_CONFIG_LIBS)
+ AC_SUBST(GPGME_CONFIG_CFLAGS)
diff --git a/security/gpgme03/files/patch-doc:Makefile.in b/security/gpgme03/files/patch-doc:Makefile.in
new file mode 100644
index 000000000000..4b00e60db05a
--- /dev/null
+++ b/security/gpgme03/files/patch-doc:Makefile.in
@@ -0,0 +1,20 @@
+--- doc/Makefile.in.orig Wed Nov 19 09:55:09 2003
++++ doc/Makefile.in Mon Dec 20 12:32:30 2004
+@@ -398,7 +398,7 @@
+ for ifile in $$d/$$file $$d/$$file-[0-9] $$d/$$file-[0-9][0-9] \
+ $$d/$$file_i[0-9] $$d/$$file_i[0-9][0-9] ; do \
+ if test -f $$ifile; then \
+- relfile=`echo "$$ifile" | sed 's|^.*/||'`; \
++ relfile=`echo "$$ifile" | sed 's|^.*/||;s|gpgme|gpgme03|'`; \
+ echo " $(INSTALL_DATA) $$ifile $(DESTDIR)$(infodir)/$$relfile"; \
+ $(INSTALL_DATA) $$ifile $(DESTDIR)$(infodir)/$$relfile; \
+ else : ; fi; \
+@@ -409,7 +409,7 @@
+ install-info --version | grep -i -v debian) >/dev/null 2>&1; then \
+ list='$(INFO_DEPS)'; \
+ for file in $$list; do \
+- relfile=`echo "$$file" | sed 's|^.*/||'`; \
++ relfile=`echo "$$file" | sed 's|^.*/||;s|gpgme|gpgme03|'`; \
+ echo " install-info --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/$$relfile";\
+ install-info --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/$$relfile || :;\
+ done; \
diff --git a/security/gpgme03/files/patch-doc:gpgme.info b/security/gpgme03/files/patch-doc:gpgme.info
new file mode 100644
index 000000000000..795d2d9e34ed
--- /dev/null
+++ b/security/gpgme03/files/patch-doc:gpgme.info
@@ -0,0 +1,11 @@
+--- doc/gpgme.info.orig Mon Dec 20 12:37:07 2004
++++ doc/gpgme.info Mon Dec 20 12:37:25 2004
+@@ -2,7 +2,7 @@
+
+ INFO-DIR-SECTION GNU Libraries
+ START-INFO-DIR-ENTRY
+-* GPGME: (gpgme). Adding support for cryptography to your program.
++* GPGME: (gpgme03). Adding support for cryptography to your program.
+ END-INFO-DIR-ENTRY
+
+ This file documents the GPGME library.
diff --git a/security/gpgme03/files/patch-gpgme:Makefile.in b/security/gpgme03/files/patch-gpgme:Makefile.in
new file mode 100644
index 000000000000..ecbd66f74dbb
--- /dev/null
+++ b/security/gpgme03/files/patch-gpgme:Makefile.in
@@ -0,0 +1,47 @@
+--- gpgme/Makefile.in.orig Wed Nov 19 09:55:10 2003
++++ gpgme/Makefile.in Mon Dec 20 14:34:26 2004
+@@ -175,7 +175,7 @@
+ m4datadir = $(datadir)/aclocal
+ m4data_DATA = gpgme.m4
+ include_HEADERS = gpgme.h
+-lib_LTLIBRARIES = libgpgme.la
++lib_LTLIBRARIES = libgpgme03.la
+
+ libgpgme_la_LDFLAGS = -version-info \
+ @LIBGPGME_LT_CURRENT@:@LIBGPGME_LT_REVISION@:@LIBGPGME_LT_AGE@
+@@ -277,7 +277,7 @@
+ $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ CCLD = $(CC)
+ LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+- $(AM_LDFLAGS) $(LDFLAGS) -o $@
++ $(AM_LDFLAGS) $(LDFLAGS) -o libgpgme03.la
+ DIST_SOURCES = $(am__libgpgme_la_SOURCES_DIST)
+ DATA = $(m4data_DATA)
+
+@@ -327,7 +327,7 @@
+ echo "rm -f \"$${dir}/so_locations\""; \
+ rm -f "$${dir}/so_locations"; \
+ done
+-libgpgme.la: $(libgpgme_la_OBJECTS) $(libgpgme_la_DEPENDENCIES)
++libgpgme03.la: $(libgpgme_la_OBJECTS) $(libgpgme_la_DEPENDENCIES)
+ $(LINK) -rpath $(libdir) $(libgpgme_la_LDFLAGS) $(libgpgme_la_OBJECTS) $(libgpgme_la_LIBADD) $(LIBS)
+ binSCRIPT_INSTALL = $(INSTALL_SCRIPT)
+ install-binSCRIPTS: $(bin_SCRIPTS)
+@@ -336,7 +336,7 @@
+ @list='$(bin_SCRIPTS)'; for p in $$list; do \
+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+ if test -f $$d$$p; then \
+- f=`echo "$$p" | sed 's|^.*/||;$(transform)'`; \
++ f=`echo "$$p" | sed 's|^.*/||;s|gpgme|gpgme03|'`; \
+ echo " $(binSCRIPT_INSTALL) $$d$$p $(DESTDIR)$(bindir)/$$f"; \
+ $(binSCRIPT_INSTALL) $$d$$p $(DESTDIR)$(bindir)/$$f; \
+ else :; fi; \
+@@ -450,7 +450,7 @@
+ $(mkinstalldirs) $(DESTDIR)$(m4datadir)
+ @list='$(m4data_DATA)'; for p in $$list; do \
+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+- f="`echo $$p | sed -e 's|^.*/||'`"; \
++ f="`echo $$p | sed -e 's|^.*/||;s/gpgme/gpgme03/'`"; \
+ echo " $(m4dataDATA_INSTALL) $$d$$p $(DESTDIR)$(m4datadir)/$$f"; \
+ $(m4dataDATA_INSTALL) $$d$$p $(DESTDIR)$(m4datadir)/$$f; \
+ done
diff --git a/security/gpgme03/pkg-plist b/security/gpgme03/pkg-plist
index 0a003a2416f1..3d5a5693062a 100644
--- a/security/gpgme03/pkg-plist
+++ b/security/gpgme03/pkg-plist
@@ -1,6 +1,7 @@
-bin/gpgme-config
-include/gpgme.h
-lib/libgpgme.a
-lib/libgpgme.so
-lib/libgpgme.so.9
-share/aclocal/gpgme.m4
+bin/gpgme03-config
+include/gpgme03/gpgme.h
+lib/libgpgme03.a
+lib/libgpgme03.so
+lib/libgpgme03.so.9
+share/aclocal/gpgme03.m4
+@dirrm include/gpgme03
diff --git a/security/ruby-gpgme/Makefile b/security/ruby-gpgme/Makefile
index 9f62f62626b4..61f9bcfb623a 100644
--- a/security/ruby-gpgme/Makefile
+++ b/security/ruby-gpgme/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gpgme
PORTVERSION= 0.2
+PORTREVISION= 1
CATEGORIES= security ruby
MASTER_SITES= http://deisui.org/~ueno/ruby/ruby-gpgme/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -16,7 +17,7 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
COMMENT= A Ruby interface to GnuPG Made Easy (GPGME)
-LIB_DEPENDS= gpgme.9:${PORTSDIR}/security/gpgme03
+LIB_DEPENDS= gpgme03.9:${PORTSDIR}/security/gpgme03
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
diff --git a/security/ruby-gpgme/files/patch-extconf.rb b/security/ruby-gpgme/files/patch-extconf.rb
new file mode 100644
index 000000000000..cb44912b92f3
--- /dev/null
+++ b/security/ruby-gpgme/files/patch-extconf.rb
@@ -0,0 +1,9 @@
+--- extconf.rb.orig Mon Dec 20 21:35:54 2004
++++ extconf.rb Mon Dec 20 21:36:21 2004
+@@ -1,5 +1,5 @@
+ require 'mkmf'
+
+-if have_library('gpgme', 'gpgme_check_version') and have_header('gpgme.h')
++if have_library('gpgme03', 'gpgme_check_version') and have_header('gpgme03/gpgme.h')
+ create_makefile ('gpgme_n')
+ end
diff --git a/security/ruby-gpgme/files/patch-gpgme_n.c b/security/ruby-gpgme/files/patch-gpgme_n.c
new file mode 100644
index 000000000000..43b3f82a055e
--- /dev/null
+++ b/security/ruby-gpgme/files/patch-gpgme_n.c
@@ -0,0 +1,11 @@
+--- gpgme_n.c.orig Mon Dec 20 21:38:14 2004
++++ gpgme_n.c Mon Sep 29 21:35:59 2003
+@@ -34,7 +34,7 @@
+ this purpose. */
+
+ #include "ruby.h"
+-#include "gpgme.h"
++#include "gpgme03/gpgme.h"
+
+ /* StringValuePtr is not available in 1.6. */
+ #ifndef StringValuePtr
diff --git a/security/seahorse/Makefile b/security/seahorse/Makefile
index 389d958c9ea7..4b34da640056 100644
--- a/security/seahorse/Makefile
+++ b/security/seahorse/Makefile
@@ -7,7 +7,7 @@
PORTNAME= seahorse
PORTVERSION= 0.7.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR=sources/${PORTNAME}/0.7
@@ -18,7 +18,7 @@ COMMENT= A front end for GnuPG
BUILD_DEPENDS= gpg:${PORTSDIR}/security/gnupg
RUN_DEPENDS= ${BUILD_DEPENDS}
-LIB_DEPENDS= gpgme.9:${PORTSDIR}/security/gpgme03
+LIB_DEPENDS= gpgme03.9:${PORTSDIR}/security/gpgme03
USE_BZIP2= yes
USE_X_PREFIX= yes
@@ -31,7 +31,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ s|DATADIRNAME=lib|DATADIRNAME=share|g; \
+ s|gpgme-config|gpgme03-config|' ${WRKSRC}/configure
@${CP} ${WRKSRC}/data/seahorse.schemas.in ${WRKSRC}/data/seahorse.schemas
.include <bsd.port.mk>