aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2014-10-20 16:01:36 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2014-10-20 16:01:36 +0000
commit7fd0d93a89aedf3ae8004c878caa5e2ff358e78b (patch)
treedf90bdc4ea953eeb96939d9ef9e929e773acde2b
parent6f355990c14761e23b14e4698210bd39d4763070 (diff)
downloadports-7fd0d93a89aedf3ae8004c878caa5e2ff358e78b.tar.gz
ports-7fd0d93a89aedf3ae8004c878caa5e2ff358e78b.zip
Notes
-rw-r--r--x11-wm/xfce4-wm/Makefile1
-rw-r--r--x11-wm/xfce4-wm/files/patch-src__client.c47
-rw-r--r--x11-wm/xfce4-wm/pkg-plist32
3 files changed, 48 insertions, 32 deletions
diff --git a/x11-wm/xfce4-wm/Makefile b/x11-wm/xfce4-wm/Makefile
index 883fb5ac1374..170e65c00d9e 100644
--- a/x11-wm/xfce4-wm/Makefile
+++ b/x11-wm/xfce4-wm/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xfce4-wm
PORTVERSION= 4.10.1
+PORTREVISION= 1
CATEGORIES= x11-wm xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR= src/xfce/xfwm4/${PORTVERSION:R}
diff --git a/x11-wm/xfce4-wm/files/patch-src__client.c b/x11-wm/xfce4-wm/files/patch-src__client.c
new file mode 100644
index 000000000000..9a8fa2c9cbfa
--- /dev/null
+++ b/x11-wm/xfce4-wm/files/patch-src__client.c
@@ -0,0 +1,47 @@
+Obtained from:
+- Fullscreen mode doesn't work correctly for Chromium (bug #8563)
+- Panels don't hide when full screening VLC, which is maximized (bug #10622)
+
+--- src/client.c.orig 2013-05-05 15:58:42 UTC
++++ src/client.c
+@@ -981,8 +981,13 @@
+ wc.width = c->width;
+ wc.height = c->height;
+
++ if (FLAG_TEST (c->flags, CLIENT_FLAG_FULLSCREEN))
++ {
++ clientUpdateFullscreenSize (c);
++ }
++
+ /* If client is maximized, we need to update its coordonates and size as well */
+- if (FLAG_TEST (c->flags, CLIENT_FLAG_MAXIMIZED))
++ else if (FLAG_TEST (c->flags, CLIENT_FLAG_MAXIMIZED))
+ {
+ GdkRectangle rect;
+ myScreenFindMonitorAtPoint (screen_info,
+@@ -3538,8 +3543,13 @@
+ continue;
+ }
+
++ if (FLAG_TEST (c->flags, CLIENT_FLAG_FULLSCREEN))
++ {
++ clientUpdateFullscreenSize (c);
++ }
++
+ /* Recompute size and position of maximized windows */
+- if (FLAG_TEST (c->flags, CLIENT_FLAG_MAXIMIZED))
++ else if (FLAG_TEST (c->flags, CLIENT_FLAG_MAXIMIZED))
+ {
+ maximization_flags = c->flags & CLIENT_FLAG_MAXIMIZED;
+
+@@ -3553,10 +3563,6 @@
+ wc.height = c->height;
+ clientConfigure (c, &wc, CWX | CWY | CWWidth | CWHeight, CFG_NOTIFY);
+ }
+- else if (FLAG_TEST (c->flags, CLIENT_FLAG_FULLSCREEN))
+- {
+- clientUpdateFullscreenSize (c);
+- }
+ else
+ {
+ configure_flags = CFG_CONSTRAINED | CFG_REQUEST;
diff --git a/x11-wm/xfce4-wm/pkg-plist b/x11-wm/xfce4-wm/pkg-plist
index 43caa820e428..988447569596 100644
--- a/x11-wm/xfce4-wm/pkg-plist
+++ b/x11-wm/xfce4-wm/pkg-plist
@@ -566,35 +566,3 @@ share/themes/Moheli/xfwm4/top-right-active.xpm
share/themes/Moheli/xfwm4/top-right-inactive.png
share/themes/Moheli/xfwm4/top-right-inactive.xpm
%%DATADIR%%/defaults
-@dirrm %%DATADIR%%
-@dirrm share/themes/Moheli/xfwm4
-@dirrm share/themes/Moheli
-@dirrm share/themes/Kokodi/xfwm4
-@dirrm share/themes/Kokodi
-@dirrm share/themes/Default/xfwm4
-@dirrmtry share/themes/Default
-@dirrm share/themes/Daloa/xfwm4
-@dirrm share/themes/Daloa
-@dirrmtry share/themes
-%%NLS%%@dirrmtry share/locale/ur_PK/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/ur_PK
-%%NLS%%@dirrmtry share/locale/ur/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/ur
-%%NLS%%@dirrmtry share/locale/ug/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/ug
-%%NLS%%@dirrmtry share/locale/te/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/te
-%%NLS%%@dirrmtry share/locale/si/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/si
-%%NLS%%@dirrmtry share/locale/mr/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/mr
-%%NLS%%@dirrmtry share/locale/kk/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/kk
-%%NLS%%@dirrmtry share/locale/dz/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/dz
-%%NLS%%@dirrmtry share/locale/bn_IN/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/bn_IN
-%%NLS%%@dirrmtry share/locale/ast/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/ast
-@dirrm lib/xfce4/xfwm4
-@dirrmtry lib/xfce4