aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-06-10 14:34:26 +0000
committerChris Rees <crees@FreeBSD.org>2012-06-10 14:34:26 +0000
commit8016c8f204197a26bc974ed7057e69026f16d317 (patch)
tree37a10c0e9a424223fc7393a310ce62a6a04cc1e9
parent32dee91f789ee3ed13a304e5517c1078dbf37443 (diff)
Notes
-rw-r--r--audio/musicpd/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index eaf4feeca689..cdc8215a7f7c 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -222,6 +222,16 @@ LIB_DEPENDS+= cue:${PORTSDIR}/textproc/libcue
CONFIGURE_ARGS+=--disable-cue
.endif
+.if ${MPDCONF} != musicpd.conf
+pre-everything::
+ @${ECHO_MSG} "Looks as though you're using a non-default value for MPDCONF."
+ @${ECHO_MSG} "This is deprecated, and some time in the near future the only value permissible"
+ @${ECHO_MSG} "for MPDCONF will be the default; musicpd.conf."
+ @${ECHO_MSG} -n "Continuing in "
+ @for s in 5 4 3 2 1 ; do ${ECHO_MSG} -n "$$s... " && sleep 1 ; done
+ @${ECHO_MSG} ""
+.endif
+
post-patch:
# Replace ~/ with MPDDIR and make musicpd run as mpd by default
@${REINPLACE_CMD} -e 's,^#\([^"]*"\)~/,\1${MPDDIR}/,g' \