aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-03-01 16:41:25 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-03-01 16:41:25 +0000
commit90b214dfd18eda4f5a32eb5cef0c40d9b1cf6e63 (patch)
tree622e2cd458a4b4ec643b44824d3a79707e858a30
parent0c37fde55430ec37734e8aaebe109d8bbf8cb864 (diff)
downloadports-90b214dfd18eda4f5a32eb5cef0c40d9b1cf6e63.tar.gz
ports-90b214dfd18eda4f5a32eb5cef0c40d9b1cf6e63.zip
Notes
-rw-r--r--math/pspp/Makefile20
-rw-r--r--math/pspp/pkg-plist1
2 files changed, 18 insertions, 3 deletions
diff --git a/math/pspp/Makefile b/math/pspp/Makefile
index 3f3158df17fd..efc5ecaeb85c 100644
--- a/math/pspp/Makefile
+++ b/math/pspp/Makefile
@@ -3,10 +3,11 @@
PORTNAME= pspp
PORTVERSION= 0.8.4
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= GNU
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= cpm@fbsd.es
COMMENT= Program for statistical analysis of sampled data
LICENSE= GPLv3
@@ -21,6 +22,7 @@ USE_PERL5= build
GNU_CONFIGURE= yes
MAKE_ARGS= MAKEINFO="${LOCALBASE}/bin/makeinfo" \
XMLLINT="${LOCALBASE}/bin/xmllint"
+INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -28,6 +30,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB= VERSION="${PORTVERSION}"
+PORTDOCS= AUTHORS ChangeLog NEWS ONEWS README THANKS TODO
INFO= pspp pspp-dev
OPTIONS_DEFINE= DOCS GUI NLS PGSQL
@@ -38,10 +41,10 @@ GUI_RUN_DEPENDS= yelp:${PORTSDIR}/x11/yelp
GUI_USES= desktop-file-utils
GUI_USE= gnome=gtksourceview2,libglade2
GUI_CONFIGURE_WITH= cairo gui gui-tools
-GUI_INSTALL_TARGET= install-strip install-icons install-ext-icons
-GUI_INSTALL_TARGET_OFF= install-strip
+GUI_INSTALL_TARGET= install-icons install-ext-icons
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
+NLS_MAKE_ARGS_OFF= POFILES=""
PGSQL_USES= pgsql
PGSQL_CONFIGURE_WITH= libpq
@@ -55,4 +58,15 @@ post-patch:
@${REINPLACE_CMD} -e \
's|: $$(INSTALL_DATA_HOOKS)|:|' ${WRKSRC}/Makefile.in
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/pspp-mode.el \
+ ${STAGEDIR}${PREFIX}/share/emacs/site-lisp
+.if ${PORT_OPTIONS:MGUI}
+ ${RM} -r ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/mimetypes
+.endif
+.if ${PORT_OPTIONS:MDOCS}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} \
+ "${PORTDOCS}" ${STAGEDIR}${DOCSDIR})
+.endif
+
.include <bsd.port.mk>
diff --git a/math/pspp/pkg-plist b/math/pspp/pkg-plist
index e9355ce6236a..6c4daa00be15 100644
--- a/math/pspp/pkg-plist
+++ b/math/pspp/pkg-plist
@@ -17,6 +17,7 @@ man/man1/pspp-dump-sav.1.gz
%%GUI%%share/appdata/pspp.appdata.xml
%%GUI%%share/applications/pspp.desktop
%%PORTDOCS%%%%DOCSDIR%%/pspp.xml
+share/emacs/site-lisp/pspp-mode.el
%%GUI%%share/glade3/catalogs/psppire.xml
%%GUI%%share/glade3/pixmaps/16x16/psppire-acr.png
%%GUI%%share/glade3/pixmaps/16x16/psppire-dialog.png