aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2006-11-27 16:49:49 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2006-11-27 16:49:49 +0000
commit9b0532b613e0ba7112aa9776b035a594614b2024 (patch)
tree6719713782b7433195ce53662f4a5f90b7649977
parent64c864fb4fba5a1c49230c62da02ccc5910340db (diff)
Notes
-rw-r--r--misc/xfce4-iconbox/Makefile4
-rw-r--r--sysutils/xfce4-mcs-plugins/Makefile4
-rw-r--r--sysutils/xfce4-utils/Makefile4
-rw-r--r--x11-wm/xfce4-panel/Makefile4
-rw-r--r--x11-wm/xfce4-session/Makefile4
5 files changed, 11 insertions, 9 deletions
diff --git a/misc/xfce4-iconbox/Makefile b/misc/xfce4-iconbox/Makefile
index 17abd6451583..c4df2b634ce4 100644
--- a/misc/xfce4-iconbox/Makefile
+++ b/misc/xfce4-iconbox/Makefile
@@ -27,8 +27,8 @@ USE_GNOME= gtk20
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include \
- CPPFLAGS=-I${LOCALBASE}/include \
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -L${X11BASE}/lib" \
+ CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS=-L${LOCALBASE}/lib
.include <bsd.port.mk>
diff --git a/sysutils/xfce4-mcs-plugins/Makefile b/sysutils/xfce4-mcs-plugins/Makefile
index cf22c1383bc4..d50718280974 100644
--- a/sysutils/xfce4-mcs-plugins/Makefile
+++ b/sysutils/xfce4-mcs-plugins/Makefile
@@ -28,8 +28,8 @@ USE_GNOME= gtk20
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include \
- CPPFLAGS=-I${LOCALBASE}/include \
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -L${X11BASE}/lib" \
+ CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS=-L${LOCALBASE}/lib
.include <bsd.port.mk>
diff --git a/sysutils/xfce4-utils/Makefile b/sysutils/xfce4-utils/Makefile
index 729365eddd81..a86a82d1ede8 100644
--- a/sysutils/xfce4-utils/Makefile
+++ b/sysutils/xfce4-utils/Makefile
@@ -29,8 +29,8 @@ USE_GNOME= gtk20
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include \
- CPPFLAGS=-I${LOCALBASE}/include \
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -L${X11BASE}/lib" \
+ CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS=-L${LOCALBASE}/lib
.include <bsd.port.mk>
diff --git a/x11-wm/xfce4-panel/Makefile b/x11-wm/xfce4-panel/Makefile
index d9a72de184ec..305d22aa7196 100644
--- a/x11-wm/xfce4-panel/Makefile
+++ b/x11-wm/xfce4-panel/Makefile
@@ -29,8 +29,8 @@ USE_GNOME= gtk20 gnomehack
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include \
- CPPFLAGS=-I${LOCALBASE}/include \
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -L${X11BASE}/lib" \
+ CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS=-L${LOCALBASE}/lib
.include <bsd.port.mk>
diff --git a/x11-wm/xfce4-session/Makefile b/x11-wm/xfce4-session/Makefile
index 950c63e9d6fd..6b5ca6b94258 100644
--- a/x11-wm/xfce4-session/Makefile
+++ b/x11-wm/xfce4-session/Makefile
@@ -31,7 +31,9 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include \
+ -L${LOCALBASE}/lib -I${X11BASE}/include \
+ -L${X11BASE}/lib"
MAN1= xfce4-session.1 xfce4-session-logout.1