aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-03-24 13:35:08 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-03-24 13:35:08 +0000
commit9f90efc6105109f8419a1cefcae2c877dda072dd (patch)
treeed922cc6da70bc70afc84129a0e15a0674a99b2f
parentf74498d2b43e21e2e35ea6a857fed7dd09c0b2c2 (diff)
Notes
-rw-r--r--security/zenmap/Makefile7
-rw-r--r--security/zenmap/files/zenmap-root.in2
2 files changed, 5 insertions, 4 deletions
diff --git a/security/zenmap/Makefile b/security/zenmap/Makefile
index 7a1869b14fb2..d2a432899f2f 100644
--- a/security/zenmap/Makefile
+++ b/security/zenmap/Makefile
@@ -22,8 +22,8 @@ RUN_DEPENDS= ${LOCALBASE}/bin/nmap:${PORTSDIR}/security/nmap \
WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}
-USE_BZIP2= yes
-USES= desktop-file-utils
+USES= dos2unix tar:bzip2
+DOS2UNIX_GLOB= *.xml
USE_GNOME= pygtk2
USE_PYTHON= yes
USE_PYDISTUTILS= yes
@@ -77,7 +77,8 @@ post-build:
post-install:
${INSTALL_SCRIPT} ${WRKDIR}/zenmap-root ${STAGEDIR}${PREFIX}/bin/
@(cd ${STAGEDIR}${DATADIR} && ${CHMOD} 754 su-to-zenmap.sh)
- ${INSTALL_MAN} ${WRKSRC}/../docs/zenmap.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/
+ ${INSTALL_MAN} ${WRKSRC}/../docs/zenmap.1 \
+ ${STAGEDIR}${MAN1PREFIX}/man/man1/
@(cd ${WRKSRC}/../ndiff \
&& ${PYTHON_CMD} setup.py install --prefix=${STAGEDIR}${PREFIX})
${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
diff --git a/security/zenmap/files/zenmap-root.in b/security/zenmap/files/zenmap-root.in
index bc43290df99c..799b4a809946 100644
--- a/security/zenmap/files/zenmap-root.in
+++ b/security/zenmap/files/zenmap-root.in
@@ -3,6 +3,6 @@
# $FreeBSD$
#
-cd "%%DATADIR%%" ; exec su-to-zenmap.sh zenmap
+cd "%%DATADIR%%" && exec su-to-zenmap.sh zenmap