aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2021-12-09 18:40:20 +0000
committerCy Schubert <cy@FreeBSD.org>2021-12-10 04:40:04 +0000
commita67d313aca6cb2af1eb90945557c8a7ea3facdcf (patch)
tree800925ca617746116b7971cfcf2f6fe5934239c6
parentffa043014eed80b9930c0ca8e4a78383dd7a56ce (diff)
downloadports-a67d313aca6cb2af1eb90945557c8a7ea3facdcf.tar.gz
ports-a67d313aca6cb2af1eb90945557c8a7ea3facdcf.zip
lang/mono5.10: Invoke CPU_COUNT properly
3a278c7add6265e6d545f3014d7f6a6e9c222fa7 did not include a patch to configure.ac that allowed it to properly detect CPU_COUNT. Fixes: 3a278c7add6265e6d545f3014d7f6a6e9c222fa7 (cherry picked from commit 0435eab9f0396fceaa33339240604e740b00a858)
-rw-r--r--lang/mono5.10/files/patch-configure.ac64
1 files changed, 60 insertions, 4 deletions
diff --git a/lang/mono5.10/files/patch-configure.ac b/lang/mono5.10/files/patch-configure.ac
index 280b4da2ddb1..6c0365d0e3a5 100644
--- a/lang/mono5.10/files/patch-configure.ac
+++ b/lang/mono5.10/files/patch-configure.ac
@@ -1,6 +1,41 @@
---- configure.ac.orig 2018-04-18 10:51:42.000000000 +0300
-+++ configure.ac 2018-06-24 02:38:19.860780000 +0300
-@@ -3271,6 +3271,8 @@
+--- configure.ac.orig 2018-08-24 08:19:14.000000000 -0700
++++ configure.ac 2021-12-09 10:35:50.670421000 -0800
+@@ -201,6 +201,12 @@
+ libdl=
+ libgc_threads=pthreads
+ use_sigposix=yes
++ case "$host" in
++ aarch64-*)
++ support_boehm=no
++ with_gc=sgen
++ ;;
++ esac
+ has_dtrace=yes
+ with_sgen_default_concurrent=yes
+ ;;
+@@ -1668,7 +1674,8 @@
+ dnl *** won't always indicate the interface sched_affinity has. ***
+ dnl ****************************************************************
+ AC_MSG_CHECKING(for sched_setaffinity from glibc < 2.3.4)
+- AC_TRY_COMPILE([#include <sched.h>], [
++ AC_TRY_COMPILE([#define _WITH_CPU_SET_T
++#include <sched.h>], [
+ int mask = 1;
+ sched_setaffinity(0, &mask);
+ return 0;
+@@ -1680,8 +1687,9 @@
+ # We have the new, three-parameter version
+ AC_MSG_RESULT(no)
+ ])
+- AC_TRY_COMPILE([#include <sched.h>], [
+- CPU_COUNT((void *) 0);
++ AC_TRY_COMPILE([#define _WITH_CPU_SET_T
++#include <sched.h>], [
++ CPU_COUNT((cpuset_t *) 0);
+ ], [
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(GLIBC_HAS_CPU_COUNT, 1, [GLIBC has CPU_COUNT macro in sched.h])
+@@ -3298,6 +3306,8 @@
BTLS_PLATFORM=i386
;;
openbsd*|freebsd*|kfreebsd-gnu*)
@@ -9,7 +44,7 @@
;;
esac
;;
-@@ -3295,6 +3297,8 @@
+@@ -3322,6 +3332,8 @@
boehm_supported=false
;;
openbsd*|freebsd*|kfreebsd-gnu*)
@@ -18,3 +53,24 @@
;;
mingw*)
;;
+@@ -3355,11 +3367,10 @@
+ INTL="intl"
+ ;;
+ macppc-*-openbsd* | powerpc*-*-linux* | powerpc-*-openbsd* | \
+- powerpc-*-sysv* | powerpc-*-darwin* | powerpc-*-netbsd* | powerpc-*-freebsd* )
++ powerpc-*-sysv* | powerpc-*-darwin* | powerpc-*-netbsd* | powerpc*-*-freebsd* )
+ if test "x$ac_cv_sizeof_void_p" = "x8"; then
+ TARGET=POWERPC64;
+ CPPFLAGS="$CPPFLAGS -D__mono_ppc__ -D__mono_ppc64__"
+- CFLAGS="$CFLAGS -mminimal-toc"
+ else
+ TARGET=POWERPC;
+ CPPFLAGS="$CPPFLAGS -D__mono_ppc__"
+@@ -4425,6 +4436,7 @@
+ ;;
+ aarch64)
+ btls_arch=aarch64
++ btls_cflags="-march=armv8-a+crypto"
+ ;;
+ android-armv5)
+ BTLS_CMAKE_ARGS="-DANDROID_ABI=\"armeabi\" -DANDROID_NATIVE_API_LEVEL=14"