aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-01-01 01:36:26 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-01-01 01:41:48 +0000
commita6c0f28298a6561b7810ff73c75f79e52a4a60e4 (patch)
treec0e6253cf8782545e64cc87c740f572244ec01af
parent5a071065b26587abe5bfa06d7ee8feecaba5c483 (diff)
downloadports-a6c0f28298a6561b7810ff73c75f79e52a4a60e4.tar.gz
ports-a6c0f28298a6561b7810ff73c75f79e52a4a60e4.zip
emulators/yuzu: unbreak fetch after 8042b641840f
Failover between mirrors doesn't work if file exists but is different. => Attempting to fetch https://api.yuzu-emu.org/gamedb/?dummy=/yuzu/compatibility_list.json [...] => SHA256 Checksum mismatch for yuzu/compatibility_list.json. [...] ===> Giving up on fetching files: yuzu/compatibility_list.json Reported by: pkg-fallout (cherry picked from commit beb378a9cf7dc275aaa15d74465ff944b2cf49c3)
-rw-r--r--emulators/yuzu/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/emulators/yuzu/Makefile b/emulators/yuzu/Makefile
index d2c5ac2d6343..0d7e7b3bb516 100644
--- a/emulators/yuzu/Makefile
+++ b/emulators/yuzu/Makefile
@@ -2,8 +2,11 @@ PORTNAME= yuzu
PORTVERSION= s20211231
PORTREVISION?= 0
CATEGORIES= emulators
-MASTER_SITES= https://api.yuzu-emu.org/gamedb/?dummy=/:gamedb \
- LOCAL/jbeich:gamedb
+.if make(makesum)
+MASTER_SITES= https://api.yuzu-emu.org/gamedb/?dummy=/:gamedb
+.else
+MASTER_SITES= LOCAL/jbeich:gamedb
+.endif
DISTFILES= ${PORTNAME}/compatibility_list.json:gamedb
EXTRACT_ONLY= ${DISTFILES:N*\:gamedb:C/\:.*//}