aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-01-30 00:53:24 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-01-30 00:53:24 +0000
commitb424dad7e7c09a4b2c0c8a74895ac569ce22c6cb (patch)
treeca935fc8865c3ba6166ae534abae02faf81e9454
parentc1ba4a590904e98eac07b308b08861778a629f9b (diff)
downloadports-b424dad7e7c09a4b2c0c8a74895ac569ce22c6cb.tar.gz
ports-b424dad7e7c09a4b2c0c8a74895ac569ce22c6cb.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/ilbc/Makefile19
-rw-r--r--net/ilbc/distinfo3
-rw-r--r--net/ilbc/pkg-descr19
-rw-r--r--net/ilbc/pkg-plist7
5 files changed, 49 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 63b4b1616ea8..47bf305dfb18 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -218,6 +218,7 @@
SUBDIR += ifdepd
SUBDIR += ifstat
SUBDIR += ifstated
+ SUBDIR += ilbc
SUBDIR += imapproxy
SUBDIR += ip6_int
SUBDIR += ipa_ip6fw
diff --git a/net/ilbc/Makefile b/net/ilbc/Makefile
new file mode 100644
index 000000000000..6dabb25d846d
--- /dev/null
+++ b/net/ilbc/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: ilbc
+# Date created: 16 January 2006
+# Whom: Alex Miller <asm@asm.kiev.ua>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ilbc
+DISTVERSION= rfc3951
+CATEGORIES= net
+MASTER_SITES= http://simon.morlat.free.fr/download/1.2.x/source/
+
+MAINTAINER= asm@asm.kiev.ua
+COMMENT= Internet Low Bit Rate codec (RFC3951)
+
+USE_AUTOTOOLS= libtool:15
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/net/ilbc/distinfo b/net/ilbc/distinfo
new file mode 100644
index 000000000000..bec77dd16433
--- /dev/null
+++ b/net/ilbc/distinfo
@@ -0,0 +1,3 @@
+MD5 (ilbc-rfc3951.tar.gz) = c53bb4f1d7184789ab90d2d33571e78a
+SHA256 (ilbc-rfc3951.tar.gz) = 5aef41a94f1a752b07190b5d2880128af251d9559d28a004ebfff228695caa57
+SIZE (ilbc-rfc3951.tar.gz) = 330306
diff --git a/net/ilbc/pkg-descr b/net/ilbc/pkg-descr
new file mode 100644
index 000000000000..94cce10233d2
--- /dev/null
+++ b/net/ilbc/pkg-descr
@@ -0,0 +1,19 @@
+iLBC (internet Low Bitrate Codec)
+
+iLBC is a FREE speech codec suitable for robust voice communication
+over IP. The codec is designed for narrow band speech and results
+in a payload bit rate of 13.33 kbit/s with an encoding frame length
+of 30 ms and 15.20 kbps with an encoding length of 20 ms. The iLBC codec
+enables graceful speech quality degradation in the case of lost frames,
+which occurs in connection with lost or delayed IP packets.
+
+Features:
+
+ * Bitrate 13.33 kbps (399 bits, packetized in 50 bytes) for the frame
+ size of 30 ms and 15.2 kbps (303 bits, packetized in 38 bytes) for
+ the frame size of 20 ms
+ * Basic quality higher then G.729A, high robustness to packet loss
+ * Computational complexity in a range of G.729A
+ * Royalty Free Codec
+
+WWW: http://www.ilbcfreeware.org/
diff --git a/net/ilbc/pkg-plist b/net/ilbc/pkg-plist
new file mode 100644
index 000000000000..cf3067c55a07
--- /dev/null
+++ b/net/ilbc/pkg-plist
@@ -0,0 +1,7 @@
+include/ilbc/iLBC_decode.h
+include/ilbc/iLBC_encode.h
+include/ilbc/iLBC_define.h
+lib/libilbc.so.0
+lib/libilbc.so
+lib/libilbc.a
+@dirrm include/ilbc