aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2008-12-24 07:49:52 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2008-12-24 07:49:52 +0000
commitba89e9ecd8969ceec0018ccefd12f741ae106ba9 (patch)
tree6ecd19b60a139dcd1185c5cc77791893090bed67
parentf2c413e3db6dcdcb6b81e84b10fc4e1d152277bd (diff)
Notes
-rw-r--r--devel/gorm/Makefile25
-rw-r--r--devel/gorm/files/patch-GormNSWindow.m12
-rw-r--r--devel/gorm/files/patch-GormNibWrapperLoader.h12
-rw-r--r--devel/gorm/files/patch-GormPrivate.h13
-rw-r--r--sysutils/burn/files/patch-ExtProgressIndicator.m3
-rw-r--r--sysutils/burn/files/patch-WorkInProgress.m10
6 files changed, 74 insertions, 1 deletions
diff --git a/devel/gorm/Makefile b/devel/gorm/Makefile
index 9c9d32052ab8..e388a442d0ec 100644
--- a/devel/gorm/Makefile
+++ b/devel/gorm/Makefile
@@ -24,4 +24,29 @@ USE_GNUSTEP_LDCONFIG= ${GNUSTEP_SYSTEM_LIBRARIES}
DEFAULT_LIBVERSION= 1.1.0
+FIXME= GormCore/GormCustomView.m \
+ GormCore/GormDocument.m \
+ GormCore/GormFilePrefsManager.m \
+ GormCore/GormHelpInspector.m \
+ GormCore/GormPrivate.m \
+ Palettes/1Windows/WindowsPalette.m \
+ Plugins/Nib/GormNibWrapperBuilder.m
+
+FIXME2= Palettes/1Windows/GormNSPanel.m \
+ Palettes/1Windows/GormWindowSizeInspector.m \
+ Plugins/Gorm/GormGormWrapperBuilder.m \
+ Plugins/Nib/GormNibWrapperLoader.h \
+
+post-patch:
+.for i in ${FIXME}
+ ${REINPLACE_CMD} -e 's|GSNibTemplates|GSNibLoading|' \
+ -e 's|GSNibCompatibility|GSNibLoading|' \
+ ${WRKSRC}/${i}
+.endfor
+.for i in ${FIXME2}
+ ${REINPLACE_CMD} -e 's|GSNibTemplates|GSGormLoading|' \
+ -e 's|GSNibCompatibility|GSGormLoading|' \
+ ${WRKSRC}/${i}
+.endfor
+
.include <bsd.port.mk>
diff --git a/devel/gorm/files/patch-GormNSWindow.m b/devel/gorm/files/patch-GormNSWindow.m
new file mode 100644
index 000000000000..459ee8cc33c5
--- /dev/null
+++ b/devel/gorm/files/patch-GormNSWindow.m
@@ -0,0 +1,12 @@
+--- Palettes/1Windows/GormNSWindow.m.orig 2008-05-03 19:40:55.000000000 +0200
++++ Palettes/1Windows/GormNSWindow.m 2008-12-23 11:55:25.000000000 +0100
+@@ -23,7 +23,8 @@
+ */
+
+ #include <AppKit/AppKit.h>
+-#include <GNUstepGUI/GSNibTemplates.h>
++#include <GNUstepGUI/GSNibLoading.h>
++#include <GNUstepGUI/GSGormLoading.h>
+ #include <InterfaceBuilder/InterfaceBuilder.h>
+ #include "GormNSWindow.h"
+
diff --git a/devel/gorm/files/patch-GormNibWrapperLoader.h b/devel/gorm/files/patch-GormNibWrapperLoader.h
new file mode 100644
index 000000000000..15f8970224c9
--- /dev/null
+++ b/devel/gorm/files/patch-GormNibWrapperLoader.h
@@ -0,0 +1,12 @@
+--- Plugins/Nib/GormNibWrapperLoader.h.orig 2008-06-25 00:09:55.000000000 +0200
++++ Plugins/Nib/GormNibWrapperLoader.h 2008-12-23 16:40:32.000000000 +0100
+@@ -26,7 +26,8 @@
+ #define GORM_NIBWRAPPERLOADER
+
+ #include <GormCore/GormWrapperLoader.h>
+-#include <GNUstepGUI/GSNibCompatibility.h>
++#include <GNUstepGUI/GSNibLoading.h>
++#include <GNUstepGUI/GSGormLoading.h>
+
+ @interface GormNibWrapperLoader : GormWrapperLoader
+ {
diff --git a/devel/gorm/files/patch-GormPrivate.h b/devel/gorm/files/patch-GormPrivate.h
new file mode 100644
index 000000000000..712c08db0685
--- /dev/null
+++ b/devel/gorm/files/patch-GormPrivate.h
@@ -0,0 +1,13 @@
+--- GormCore/GormPrivate.h.orig 2007-11-06 00:44:36.000000000 +0100
++++ GormCore/GormPrivate.h 2008-12-23 09:27:03.000000000 +0100
+@@ -36,8 +36,8 @@
+ #include <GormCore/GormPalettesManager.h>
+ #include <GormCore/GormProtocol.h>
+ #include <GormCore/GormClassEditor.h>
+-#include <GNUstepGUI/GSNibTemplates.h>
+-#include <GNUstepGUI/GSNibCompatibility.h>
++#include <GNUstepGUI/GSNibLoading.h>
++#include <GNUstepGUI/GSGormLoading.h>
+
+ extern NSString *GormLinkPboardType;
+ extern NSString *GormToggleGuidelineNotification;
diff --git a/sysutils/burn/files/patch-ExtProgressIndicator.m b/sysutils/burn/files/patch-ExtProgressIndicator.m
index 518d3df0c8cd..f0a5141869b2 100644
--- a/sysutils/burn/files/patch-ExtProgressIndicator.m
+++ b/sysutils/burn/files/patch-ExtProgressIndicator.m
@@ -1,10 +1,11 @@
--- ExtProgressIndicator.m.orig 2005-05-12 17:58:49.000000000 +0200
+++ ExtProgressIndicator.m 2008-05-03 09:35:27.000000000 +0200
-@@ -21,6 +21,7 @@
+@@ -21,6 +21,8 @@
* Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
*/
+#include <AppKit/NSAttributedString.h>
++#include <GNUstepGUI/GSTheme.h>
#include <AppKit/NSColor.h>
#include <AppKit/NSParagraphStyle.h>
#include <Foundation/Foundation.h>
diff --git a/sysutils/burn/files/patch-WorkInProgress.m b/sysutils/burn/files/patch-WorkInProgress.m
new file mode 100644
index 000000000000..dd2fd0060652
--- /dev/null
+++ b/sysutils/burn/files/patch-WorkInProgress.m
@@ -0,0 +1,10 @@
+--- WorkInProgress.m.orig 2005-05-12 17:58:49.000000000 +0200
++++ WorkInProgress.m 2008-12-24 01:53:34.000000000 +0100
+@@ -23,6 +23,7 @@
+
+ #include <Foundation/Foundation.h>
+ #include <AppKit/AppKit.h>
++#include <GNUstepGUI/GSTheme.h>
+
+ #include "Functions.h"
+ #include "Constants.h"