aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-11 15:03:43 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-11 15:03:43 +0000
commitbf5289825b6c4ada9b0dabd64805a94088c80bd1 (patch)
treea9ef65f431bd72bb478abdf80b937dd8a76639e2
parent7c2d48296095a043f114e032b765c40105fd4f1f (diff)
downloadports-bf5289825b6c4ada9b0dabd64805a94088c80bd1.tar.gz
ports-bf5289825b6c4ada9b0dabd64805a94088c80bd1.zip
Notes
-rw-r--r--MOVED1
-rw-r--r--devel/Makefile1
-rw-r--r--devel/orbitcpp/Makefile24
-rw-r--r--devel/orbitcpp/distinfo2
-rw-r--r--devel/orbitcpp/files/patch-orbitcpp__orb-cpp__orbitcpp_simple_seq.h20
-rw-r--r--devel/orbitcpp/pkg-descr16
-rw-r--r--devel/orbitcpp/pkg-plist58
7 files changed, 1 insertions, 121 deletions
diff --git a/MOVED b/MOVED
index be380b67d77a..ab10dfb94e56 100644
--- a/MOVED
+++ b/MOVED
@@ -5961,3 +5961,4 @@ www/fhttpd||2014-04-11|Has expired: Unmaintained since 2000
graphics/xmorph||2014-04-11|Has expired: Unmaintained since 2000
editors/axe||2014-04-11|Has expired: Unmaintained since 2000
www/cgic||2014-04-11|Has expired: Unmaintained since 2000
+devel/orbitcpp||2014-04-11|Unused anymore, not libc++ friendly
diff --git a/devel/Makefile b/devel/Makefile
index fe7a28714241..823f0a467930 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1345,7 +1345,6 @@
SUBDIR += openvex
SUBDIR += openwince-include
SUBDIR += openzz
- SUBDIR += orbitcpp
SUBDIR += orc
SUBDIR += osc
SUBDIR += oserl
diff --git a/devel/orbitcpp/Makefile b/devel/orbitcpp/Makefile
deleted file mode 100644
index e9237d49e31e..000000000000
--- a/devel/orbitcpp/Makefile
+++ /dev/null
@@ -1,24 +0,0 @@
-# Created by: Thomas Hentschel <thomas at hentschel dot net>
-# $FreeBSD$
-
-PORTNAME= orbitcpp
-PORTVERSION= 1.3.9
-PORTREVISION= 4
-CATEGORIES= devel
-MASTER_SITES= GNOME
-
-MAINTAINER= gnome@FreeBSD.org
-COMMENT= C++ bindings for ORBit, a CORBA 2.2-compliant ORB
-
-USE_BZIP2= yes
-USE_GNOME= gnomehack ltverhack orbit2
-USES= pkgconfig
-GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtool
-
-NO_STAGE= yes
-post-patch:
- @${REINPLACE_CMD} -e 's|^\(SUBDIRS =.*\)test\(.*\)|\1\2|' ${WRKSRC}/Makefile.in
-
-.include <bsd.port.mk>
diff --git a/devel/orbitcpp/distinfo b/devel/orbitcpp/distinfo
deleted file mode 100644
index 10bf79210b66..000000000000
--- a/devel/orbitcpp/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (orbitcpp-1.3.9.tar.bz2) = 1d41c7d5c73e78ffaad5247036307eb74ff37e9b7d86b2072f25ffd447dd731c
-SIZE (orbitcpp-1.3.9.tar.bz2) = 297985
diff --git a/devel/orbitcpp/files/patch-orbitcpp__orb-cpp__orbitcpp_simple_seq.h b/devel/orbitcpp/files/patch-orbitcpp__orb-cpp__orbitcpp_simple_seq.h
deleted file mode 100644
index 302cb556c564..000000000000
--- a/devel/orbitcpp/files/patch-orbitcpp__orb-cpp__orbitcpp_simple_seq.h
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./orbitcpp/orb-cpp/orbitcpp_simple_seq.h.orig 2012-07-02 23:33:54.000000000 +0200
-+++ ./orbitcpp/orb-cpp/orbitcpp_simple_seq.h 2012-07-02 23:34:43.000000000 +0200
-@@ -70,7 +70,7 @@
- void _length_set_impl (size_t new_length) {
- if (new_length > this->_max)
- {
-- buffer_t buffer_tmp = allocbuf (new_length);
-+ buffer_t buffer_tmp = this->allocbuf (new_length);
- if (!buffer_tmp)
- throw CORBA::NO_MEMORY ();
-
-@@ -78,7 +78,7 @@
- buffer_tmp[i] = this->_buffer[i];
-
- if (this->_release)
-- freebuf (this->_buffer);
-+ this->freebuf (this->_buffer);
-
- this->_release = true;
- this->_buffer = buffer_tmp;
diff --git a/devel/orbitcpp/pkg-descr b/devel/orbitcpp/pkg-descr
deleted file mode 100644
index c264906833a4..000000000000
--- a/devel/orbitcpp/pkg-descr
+++ /dev/null
@@ -1,16 +0,0 @@
-Paraphrasing the website:
-
- ORBit-C++ provides C++ bindings for ORBit, an open source CORBA
- 2.2-compliant Object Request Broker.
-
- The primary objectives of ORBit-C++ are:
- - To provide a spec-compliant C++ CORBA mapping for ORBit.
- - To allow programmers to use and write ORBit objects and gnome components
- in C++ with little or no runtime overhead (compared to writing C ones)
- - To allow C programmers to use C++ objects without having to deal with any
- of that "horrible C++ syntax".
-
- In short, to C++ programmers, all ORBit objects look like C++ objects, and
- to C programmers, all ORBit objects should look like C objects.
-
-WWW: http://orbitcpp.sourceforge.net/
diff --git a/devel/orbitcpp/pkg-plist b/devel/orbitcpp/pkg-plist
deleted file mode 100644
index 239286ed3809..000000000000
--- a/devel/orbitcpp/pkg-plist
+++ /dev/null
@@ -1,58 +0,0 @@
-include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp_any.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp_compound_seq.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp_config.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp_constants.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp_exception.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp_exceptionlist.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp_object.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp_orb.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp_poa.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp_poaexceptionlist.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp_sequence.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp_simple_seq.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp_smartptr.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp_string_seq.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp_tools.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp_traits.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp_typecode.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp_types.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp_var_smartptr.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/smartpointers/arrayfixed_forany.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/smartpointers/arrayfixed_var.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/smartpointers/arrayvariable_forany.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/smartpointers/arrayvariable_out.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/smartpointers/arrayvariable_var.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/smartpointers/data_out.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/smartpointers/data_var.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/smartpointers/datavar_out.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/smartpointers/datavar_var.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/smartpointers/objectptr_out.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/smartpointers/objectptr_var.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/smartpointers/sequence_out.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/smartpointers/sequence_var.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/smartpointers/string_out.h
-include/orbitcpp-2.0/orbitcpp/orb-cpp/smartpointers/string_var.h
-include/orbitcpp-2.0/services/name/CosNaming-cpp-common.h
-include/orbitcpp-2.0/services/name/CosNaming-cpp-stubs.h
-include/orbitcpp-2.0/services/name/CosNaming.h
-lib/libORBit-2-cpp.a
-lib/libORBit-2-cpp.la
-lib/libORBit-2-cpp.so
-lib/libORBit-2-cpp.so.9
-lib/libORBitCosNaming-2-cpp.a
-lib/libORBitCosNaming-2-cpp.la
-lib/libORBitCosNaming-2-cpp.so
-lib/libORBitCosNaming-2-cpp.so.9
-lib/orbit-2.0/idl-backends/libORBit-idl-backend-cpp.a
-lib/orbit-2.0/idl-backends/libORBit-idl-backend-cpp.la
-lib/orbit-2.0/idl-backends/libORBit-idl-backend-cpp.so
-lib/orbit-2.0/idl-backends/libORBit-idl-backend-cpp.so.9
-libdata/pkgconfig/ORBit-2.0-cpp.pc
-libdata/pkgconfig/ORBit-CosNaming-2.0-cpp.pc
-@dirrm include/orbitcpp-2.0/services/name
-@dirrm include/orbitcpp-2.0/services
-@dirrm include/orbitcpp-2.0/orbitcpp/orb-cpp/smartpointers
-@dirrm include/orbitcpp-2.0/orbitcpp/orb-cpp
-@dirrm include/orbitcpp-2.0/orbitcpp
-@dirrm include/orbitcpp-2.0