aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-04-28 19:10:55 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-04-28 19:10:55 +0000
commitc42648a9f3da10d72e3d1b5f08f05f85f25f21a4 (patch)
treeafb94ee2adfd4bd4d5abace6e103a6c7d872385a
parent58db76b95afa454ef3c9e00e43536d5f847032bd (diff)
downloadports-c42648a9f3da10d72e3d1b5f08f05f85f25f21a4.tar.gz
ports-c42648a9f3da10d72e3d1b5f08f05f85f25f21a4.zip
Notes
-rw-r--r--math/labplot/Makefile11
-rw-r--r--math/labplot/distinfo6
-rw-r--r--math/labplot/files/patch-CMakeLists.txt56
-rw-r--r--math/labplot/files/patch-src_backend_gsl_parser.tab.c14
-rw-r--r--math/labplot/files/patch-src_backend_gsl_parser.y12
-rw-r--r--math/labplot/files/patch-src_backend_gsl_parser__parallel.y13
-rw-r--r--math/labplot/pkg-plist89
7 files changed, 120 insertions, 81 deletions
diff --git a/math/labplot/Makefile b/math/labplot/Makefile
index 08841894f025..ad2a62cd19a5 100644
--- a/math/labplot/Makefile
+++ b/math/labplot/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= labplot
-PORTVERSION= 2.3.0
+PORTVERSION= 2.4.0
DISTVERSIONSUFFIX=-kf5
CATEGORIES= math kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}
@@ -15,8 +15,11 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libgsl.so:math/gsl
-OPTIONS_DEFINE= FFTW3 HDF5 NETCDF
+OPTIONS_DEFINE= FITS FFTW3 HDF5 NETCDF
OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
+FITS_DESC= Flexible Image Transport System Data Format (FITS) Library
+FITS_CMAKE_BOOL= ENABLE_FITS
+FITS_LIB_DEPENDS= libcfitsio.so:astro/cfitsio
FFTW3_DESC= Build with FFTW support
FFTW3_CMAKE_BOOL= ENABLE_FFTW
FFTW3_LIB_DEPENDS= libfftw3.so:math/fftw3
@@ -30,8 +33,8 @@ NETCDF_LIB_DEPENDS= libnetcdf.so:science/netcdf
USES= cmake:outsource desktop-file-utils kde:5 shared-mime-info tar:xz
USE_KDE= archive auth bookmarks codecs completion config configwidgets \
coreaddons crash ecm guiaddons i18n iconthemes itemviews \
- jobwidgets kdelibs4support kio notifications parts service \
- solid sonnet textwidgets unitconversion widgetsaddons \
+ jobwidgets kdelibs4support kio newstuff notifications parts \
+ service solid sonnet textwidgets unitconversion widgetsaddons \
windowsystem xmlgui
USE_QT5= core dbus gui network printsupport svg widgets xml \
buildtools_build qmake_build
diff --git a/math/labplot/distinfo b/math/labplot/distinfo
index fcef19055d09..79d601f9f4f3 100644
--- a/math/labplot/distinfo
+++ b/math/labplot/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1490774921
-SHA256 (labplot-2.3.0-kf5.tar.xz) = a5a7d706de5f978430b359ada42f9227a2619f5fa9608d56af16c760b7626f33
-SIZE (labplot-2.3.0-kf5.tar.xz) = 4531156
+TIMESTAMP = 1492976438
+SHA256 (labplot-2.4.0-kf5.tar.xz) = 86198247ff0d274c85607cdb07a0c4ef19149e4f4bf6c9d2e6e8249134e26bb2
+SIZE (labplot-2.4.0-kf5.tar.xz) = 6038072
diff --git a/math/labplot/files/patch-CMakeLists.txt b/math/labplot/files/patch-CMakeLists.txt
deleted file mode 100644
index 0670e0beae62..000000000000
--- a/math/labplot/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,56 +0,0 @@
-Make the dependencies on FFTW3, HDF5 and NETCDF toggelable.
-
-This is a simlified backport of
- https://github.com/KDE/labplot/commit/3a3594f077fcc53d725878d3d2c5ef0b263463e4
-
---- CMakeLists.txt.orig 2017-04-04 13:07:03 UTC
-+++ CMakeLists.txt
-@@ -26,7 +26,13 @@ add_definitions(-fvisibility=default)
- cmake_policy(SET CMP0002 OLD)
- #cmake_policy(SET CMP0063 NEW)
-
-+### Options ######################################
-+option(ENABLE_FFTW "Build with FFTW support" "ON")
-+option(ENABLE_HDF5 "Build with HDF5 support" "ON")
-+option(ENABLE_NETCDF "Build with NetCDF support" "ON")
-+
- ### FFTW ######################################
-+IF (ENABLE_FFTW)
- FIND_LIBRARY(FFTW_LIBRARIES fftw3
- PATHS
- /usr/lib
-@@ -49,6 +55,7 @@ IF (FFTW_FOUND)
- ELSE (FFTW_FOUND)
- MESSAGE (STATUS "FFTW 3 Library not found.")
- ENDIF (FFTW_FOUND)
-+ENDIF (ENABLE_FFTW)
-
- ### GSL ######################################
- FIND_LIBRARY(GSL_LIBRARIES gsl
-@@ -112,6 +119,7 @@ ELSE (CANTOR_LIBS_FOUND)
- ENDIF (CANTOR_LIBS_FOUND)
-
- ### HDF5 #####################################
-+IF (ENABLE_HDF5)
- FIND_LIBRARY(HDF5_LIBRARY hdf5
- PATHS
- /usr/lib
-@@ -136,8 +144,10 @@ IF (HDF5_FOUND)
- ELSE (HDF5_FOUND)
- MESSAGE (STATUS "Hierarchical Data Format (HDF) 5 Library not found.")
- ENDIF (HDF5_FOUND)
-+ENDIF (ENABLE_HDF5)
-
- ### NETCDF #####################################
-+IF (ENABLE_NETCDF)
- FIND_LIBRARY(NETCDF_LIBRARY netcdf
- PATHS
- /usr/lib
-@@ -159,6 +169,7 @@ IF (NETCDF_FOUND)
- ELSE (NETCDF_FOUND)
- MESSAGE (STATUS "Network Common Data Format (NetCDF) Library not found.")
- ENDIF (NETCDF_FOUND)
-+ENDIF (ENABLE_NETCDF)
-
- add_subdirectory(icons)
- add_subdirectory(src)
diff --git a/math/labplot/files/patch-src_backend_gsl_parser.tab.c b/math/labplot/files/patch-src_backend_gsl_parser.tab.c
index 7ebbb31feb20..7650f2a7d36f 100644
--- a/math/labplot/files/patch-src_backend_gsl_parser.tab.c
+++ b/math/labplot/files/patch-src_backend_gsl_parser.tab.c
@@ -1,13 +1,13 @@
The function strtod_l is defined in xlocale.h .
---- src/backend/gsl/parser.tab.c.orig 2017-04-04 13:04:15 UTC
+--- src/backend/gsl/parser.tab.c.orig 2017-04-23 19:52:39 UTC
+++ src/backend/gsl/parser.tab.c
-@@ -65,7 +65,7 @@
- /* Line 371 of yacc.c */
- #line 3 "parser.y"
-
+@@ -67,7 +67,7 @@
+
+ #include <string.h>
+ #include <ctype.h>
-#include <locale.h>
+#include <xlocale.h>
#include "parser.h"
-
- /* Line 371 of yacc.c */
+ #include "constants.h"
+ #include "functions.h"
diff --git a/math/labplot/files/patch-src_backend_gsl_parser.y b/math/labplot/files/patch-src_backend_gsl_parser.y
index 9a36ec829b21..33a3ba41605b 100644
--- a/math/labplot/files/patch-src_backend_gsl_parser.y
+++ b/math/labplot/files/patch-src_backend_gsl_parser.y
@@ -1,13 +1,13 @@
The function strtod_l is defined in xlocale.h .
---- src/backend/gsl/parser.y.orig 2017-03-29 08:51:19 UTC
+--- src/backend/gsl/parser.y.orig 2017-04-02 07:47:32 UTC
+++ src/backend/gsl/parser.y
-@@ -1,7 +1,7 @@
- /* LabPlot : parser.y */
-
+@@ -30,7 +30,7 @@
%{
+ #include <string.h>
+ #include <ctype.h>
-#include <locale.h>
+#include <xlocale.h>
#include "parser.h"
- %}
-
+ #include "constants.h"
+ #include "functions.h"
diff --git a/math/labplot/files/patch-src_backend_gsl_parser__parallel.y b/math/labplot/files/patch-src_backend_gsl_parser__parallel.y
new file mode 100644
index 000000000000..7b3e0be0ba39
--- /dev/null
+++ b/math/labplot/files/patch-src_backend_gsl_parser__parallel.y
@@ -0,0 +1,13 @@
+The function strtod_l is defined in xlocale.h .
+
+--- src/backend/gsl/parser_parallel.y.orig 2017-04-23 19:52:52 UTC
++++ src/backend/gsl/parser_parallel.y
+@@ -34,7 +34,7 @@
+ #include <string.h>
+ #include <strings.h> /* bzero */
+ #include <ctype.h>
+-#include <locale.h>
++#include <xlocale.h>
+ #include "constants.h"
+ #include "functions.h"
+ #include "parser.h"
diff --git a/math/labplot/pkg-plist b/math/labplot/pkg-plist
index 69c88d6f7456..984b7ef913bf 100644
--- a/math/labplot/pkg-plist
+++ b/math/labplot/pkg-plist
@@ -1,9 +1,12 @@
bin/labplot2
-share/appdata/org.kde.labplot.appdata.xml
-share/applications/labplot2.desktop
+etc/xdg/labplot2_themes.knsrc
+share/applications/org.kde.labplot2.desktop
share/doc/HTML/en/labplot2/datapicker_active_curve_data_spreadsheet.png
share/doc/HTML/en/labplot2/datapicker_original_transformed_segments.png
share/doc/HTML/en/labplot2/datapicker_segments.png
+share/doc/HTML/en/labplot2/example-FFT_python-1024x532.png
+share/doc/HTML/en/labplot2/example-fourier_filter-1024x532.png
+share/doc/HTML/en/labplot2/example-maxima_2-1024x532.png
share/doc/HTML/en/labplot2/export_spreadsheet_dialog.png
share/doc/HTML/en/labplot2/export_worksheet_dialog.png
share/doc/HTML/en/labplot2/file_data_source.png
@@ -59,6 +62,8 @@ share/doc/HTML/uk/labplot2/import-dialog.png
share/doc/HTML/uk/labplot2/index.cache.bz2
share/doc/HTML/uk/labplot2/index.docbook
share/doc/HTML/uk/labplot2/labplot.png
+share/doc/HTML/uk/labplot2/matrix.png
+share/doc/HTML/uk/labplot2/matrix_function_values.png
share/doc/HTML/uk/labplot2/pe-context-menu.png
share/doc/HTML/uk/labplot2/project-explorer.png
share/doc/HTML/uk/labplot2/properties.png
@@ -85,6 +90,7 @@ share/doc/HTML/uk/labplot2/tutorial-xy-function6.png
share/doc/HTML/uk/labplot2/tutorial-xy-function7.png
share/doc/HTML/uk/labplot2/tutorial-xy-function8.png
share/doc/HTML/uk/labplot2/tutorial-xy-function9.png
+share/doc/HTML/uk/labplot2/workbook.png
share/doc/HTML/uk/labplot2/worksheet.png
share/icons/hicolor/128x128/apps/labplot2.png
share/icons/hicolor/22x22/apps/labplot2.png
@@ -148,37 +154,108 @@ share/kxmlgui5/labplot2/labplot2ui.rc
%%DATADIR%%/pics/colorchooser/colorchooser_hue.xpm
%%DATADIR%%/pics/colorchooser/colorchooser_saturation.xpm
%%DATADIR%%/pics/colorchooser/colorchooser_value.xpm
+%%DATADIR%%/pics/fit_models/alg_sigmoid.jpg
+%%DATADIR%%/pics/fit_models/atan.jpg
+%%DATADIR%%/pics/fit_models/cauchy_lorentz1.jpg
+%%DATADIR%%/pics/fit_models/cauchy_lorentz2.jpg
+%%DATADIR%%/pics/fit_models/cauchy_lorentz3.jpg
+%%DATADIR%%/pics/fit_models/cauchy_lorentz4.jpg
+%%DATADIR%%/pics/fit_models/erf.jpg
+%%DATADIR%%/pics/fit_models/exponential1.jpg
+%%DATADIR%%/pics/fit_models/exponential2.jpg
+%%DATADIR%%/pics/fit_models/exponential3.jpg
+%%DATADIR%%/pics/fit_models/exponential4.jpg
+%%DATADIR%%/pics/fit_models/fourier1.jpg
+%%DATADIR%%/pics/fit_models/fourier2.jpg
+%%DATADIR%%/pics/fit_models/fourier3.jpg
+%%DATADIR%%/pics/fit_models/fourier4.jpg
+%%DATADIR%%/pics/fit_models/gaussian1.jpg
+%%DATADIR%%/pics/fit_models/gaussian2.jpg
+%%DATADIR%%/pics/fit_models/gaussian3.jpg
+%%DATADIR%%/pics/fit_models/gaussian4.jpg
+%%DATADIR%%/pics/fit_models/gd.jpg
+%%DATADIR%%/pics/fit_models/gompertz.jpg
+%%DATADIR%%/pics/fit_models/hill.jpg
+%%DATADIR%%/pics/fit_models/inv_exponential1.jpg
+%%DATADIR%%/pics/fit_models/logistic1.jpg
+%%DATADIR%%/pics/fit_models/logistic2.jpg
+%%DATADIR%%/pics/fit_models/logistic3.jpg
+%%DATADIR%%/pics/fit_models/logistic4.jpg
+%%DATADIR%%/pics/fit_models/logistic_function.jpg
+%%DATADIR%%/pics/fit_models/polynom1.jpg
+%%DATADIR%%/pics/fit_models/polynom2.jpg
+%%DATADIR%%/pics/fit_models/polynom3.jpg
+%%DATADIR%%/pics/fit_models/polynom4.jpg
+%%DATADIR%%/pics/fit_models/power1.jpg
+%%DATADIR%%/pics/fit_models/power2.jpg
+%%DATADIR%%/pics/fit_models/sech1.jpg
+%%DATADIR%%/pics/fit_models/sech2.jpg
+%%DATADIR%%/pics/fit_models/sech3.jpg
+%%DATADIR%%/pics/fit_models/sech4.jpg
+%%DATADIR%%/pics/fit_models/tanh.jpg
%%DATADIR%%/pics/gsl_distributions/F.jpg
%%DATADIR%%/pics/gsl_distributions/bernoulli.jpg
%%DATADIR%%/pics/gsl_distributions/beta.jpg
%%DATADIR%%/pics/gsl_distributions/binomial.jpg
%%DATADIR%%/pics/gsl_distributions/binomial_negative.jpg
-%%DATADIR%%/pics/gsl_distributions/cauchy.jpg
+%%DATADIR%%/pics/gsl_distributions/cauchy_lorentz.jpg
%%DATADIR%%/pics/gsl_distributions/chi_squared.jpg
%%DATADIR%%/pics/gsl_distributions/exponential.jpg
%%DATADIR%%/pics/gsl_distributions/exponential_power.jpg
%%DATADIR%%/pics/gsl_distributions/flat.jpg
+%%DATADIR%%/pics/gsl_distributions/frechet.jpg
%%DATADIR%%/pics/gsl_distributions/gamma.jpg
%%DATADIR%%/pics/gsl_distributions/gaussian.jpg
+%%DATADIR%%/pics/gsl_distributions/gaussian_tail.jpg
%%DATADIR%%/pics/gsl_distributions/geometric.jpg
-%%DATADIR%%/pics/gsl_distributions/gumbel_type_1.jpg
-%%DATADIR%%/pics/gsl_distributions/gumbel_type_2.jpg
+%%DATADIR%%/pics/gsl_distributions/gumbel1.jpg
+%%DATADIR%%/pics/gsl_distributions/gumbel2.jpg
%%DATADIR%%/pics/gsl_distributions/hypergeometric.jpg
%%DATADIR%%/pics/gsl_distributions/landau.jpg
%%DATADIR%%/pics/gsl_distributions/laplace.jpg
+%%DATADIR%%/pics/gsl_distributions/levy.jpg
%%DATADIR%%/pics/gsl_distributions/levy_alpha_stable.jpg
%%DATADIR%%/pics/gsl_distributions/levy_skew_alpha_stable.jpg
%%DATADIR%%/pics/gsl_distributions/logarithmic.jpg
%%DATADIR%%/pics/gsl_distributions/logistic.jpg
%%DATADIR%%/pics/gsl_distributions/lognormal.jpg
+%%DATADIR%%/pics/gsl_distributions/maxwell_boltzmann.jpg
%%DATADIR%%/pics/gsl_distributions/pareto.jpg
%%DATADIR%%/pics/gsl_distributions/pascal.jpg
%%DATADIR%%/pics/gsl_distributions/poisson.jpg
%%DATADIR%%/pics/gsl_distributions/rayleigh.jpg
%%DATADIR%%/pics/gsl_distributions/rayleigh_tail.jpg
+%%DATADIR%%/pics/gsl_distributions/sech.jpg
%%DATADIR%%/pics/gsl_distributions/t.jpg
%%DATADIR%%/pics/gsl_distributions/weibull.jpg
%%DATADIR%%/splash.png
+%%DATADIR%%/themes/BlackOnLightYellow
+%%DATADIR%%/themes/BlackOnWhite
+%%DATADIR%%/themes/BlueOnBlack
+%%DATADIR%%/themes/Bright
+%%DATADIR%%/themes/Creme
+%%DATADIR%%/themes/Dark
+%%DATADIR%%/themes/DarkPastels
+%%DATADIR%%/themes/GreenOnBlack
+%%DATADIR%%/themes/GreyOnBlack
+%%DATADIR%%/themes/GreySlate
+%%DATADIR%%/themes/RedOnBlack
+%%DATADIR%%/themes/Solarized
+%%DATADIR%%/themes/SolarizedLight
+%%DATADIR%%/themes/screenshots/BlackOnLightYellow.png
+%%DATADIR%%/themes/screenshots/BlackOnWhite.png
+%%DATADIR%%/themes/screenshots/BlueOnBlack.png
+%%DATADIR%%/themes/screenshots/Bright.png
+%%DATADIR%%/themes/screenshots/Creme.png
+%%DATADIR%%/themes/screenshots/Dark.png
+%%DATADIR%%/themes/screenshots/DarkPastels.png
+%%DATADIR%%/themes/screenshots/GreenOnBlack.png
+%%DATADIR%%/themes/screenshots/GreyOnBlack.png
+%%DATADIR%%/themes/screenshots/GreySlate.png
+%%DATADIR%%/themes/screenshots/RedOnBlack.png
+%%DATADIR%%/themes/screenshots/Solarized.png
+%%DATADIR%%/themes/screenshots/SolarizedLight.png
+%%DATADIR%%/themes/screenshots/Unavailable.png
share/locale/ast/LC_MESSAGES/labplot2.mo
share/locale/bs/LC_MESSAGES/labplot2.mo
share/locale/ca/LC_MESSAGES/labplot2.mo
@@ -192,6 +269,7 @@ share/locale/fi/LC_MESSAGES/labplot2.mo
share/locale/fr/LC_MESSAGES/labplot2.mo
share/locale/gl/LC_MESSAGES/labplot2.mo
share/locale/hu/LC_MESSAGES/labplot2.mo
+share/locale/it/LC_MESSAGES/labplot2.mo
share/locale/ja/LC_MESSAGES/labplot2.mo
share/locale/lt/LC_MESSAGES/labplot2.mo
share/locale/nds/LC_MESSAGES/labplot2.mo
@@ -204,4 +282,5 @@ share/locale/sk/LC_MESSAGES/labplot2.mo
share/locale/sv/LC_MESSAGES/labplot2.mo
share/locale/uk/LC_MESSAGES/labplot2.mo
share/locale/zh_TW/LC_MESSAGES/labplot2.mo
+share/metainfo/org.kde.labplot2.appdata.xml
share/mime/packages/labplot2.xml