aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2012-11-13 14:25:00 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2012-11-13 14:25:00 +0000
commitce14deb4901e961e3218f1c24788b9f31ae3ac3d (patch)
treed4f27473eac1ac4ea75c99d9aa8466242132f3e0
parent82f3972d590b76f63b80b3da9b0e8043fa040032 (diff)
downloadports-ce14deb4901e961e3218f1c24788b9f31ae3ac3d.tar.gz
ports-ce14deb4901e961e3218f1c24788b9f31ae3ac3d.zip
Notes
-rw-r--r--x11/xxkb/Makefile55
-rw-r--r--x11/xxkb/pkg-descr24
-rw-r--r--x11/xxkb/pkg-plist5
3 files changed, 47 insertions, 37 deletions
diff --git a/x11/xxkb/Makefile b/x11/xxkb/Makefile
index b5b7ce99ddf8..971ef09f0f5d 100644
--- a/x11/xxkb/Makefile
+++ b/x11/xxkb/Makefile
@@ -1,40 +1,45 @@
-# New ports collection makefile for: xxkb
-# Date created: 5 Mar 2001
-# Whom: Alexander Matey <matey@cis.ohio-state.edu>
-#
+# Created by: Alexander Matey <matey@cis.ohio-state.edu>
# $FreeBSD$
-#
-PORTNAME= xxkb
-PORTVERSION= 1.11
-CATEGORIES= x11
-MASTER_SITES= SF
-DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+PORTNAME= xxkb
+PORTVERSION= 1.11
+CATEGORIES= x11
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
-MAINTAINER= alexander.pohoyda@gmx.net
-COMMENT= An XKB keyboard layout switcher and indicator
+MAINTAINER= alexander.pohoyda@gmx.net
+COMMENT= XKB keyboard layout indicator and switcher
-WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_XORG= xpm
-USE_IMAKE= yes
+LICENSE= ART10
-MAN1= xxkb.1
+BUILD_DEPENDS= iconv:${PORTSDIR}/converters/libiconv
-OPTIONS= LIBRSVG "With SVG(librsvg2) support" off
+USE_XORG= xpm
+USE_IMAKE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+MAN1= ${PORTNAME}.1
+PORTDOCS= README CHANGES.ru README.ru
+
+OPTIONS_DEFINE= LIBRSVG2 DOCS
.include <bsd.port.pre.mk>
-.if defined(WITH_LIBRSVG)
-LIB_DEPENDS+= rsvg-2.2:${PORTSDIR}/graphics/librsvg2
-XMKMF= xmkmf -a -DWITH_SVG_SUPPORT
+.if ${PORT_OPTIONS:MLIBRSVG2}
+LIB_DEPENDS= rsvg-2:${PORTSDIR}/graphics/librsvg2
+XMKMF= xmkmf -a -DWITH_SVG_SUPPORT
.endif
+post-build:
+# Convert Russian language docs from archaic KOI8-R to modern UTF-8
+.for f in CHANGES README
+ iconv -f koi8-r -t utf-8 ${WRKSRC}/${f}.koi8 > ${WRKSRC}/${f}.ru
+.endfor
+
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-. for file in LICENSE README CHANGES.koi8 README.koi8
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-. endfor
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
.include <bsd.port.post.mk>
diff --git a/x11/xxkb/pkg-descr b/x11/xxkb/pkg-descr
index 15dbb108871d..e96edad6d68e 100644
--- a/x11/xxkb/pkg-descr
+++ b/x11/xxkb/pkg-descr
@@ -1,9 +1,19 @@
-Xxkb is a simple XKB keyboard mapping switcher. It maintains an active
-keyboard mapping on a per-window basis. An optional small icon is
-displayed in each window to indicate the selected keyboard mapping. You
-can click this icon to switch between mappings in addition to being able
-to use the key combination specified in the XKB configuration.
+The xxkb program is a keyboard layout switcher and indicator. Unlike the
+programs that reload keyboard maps and use their own hot-keys, xxkb is a
+simple GUI for XKB (X keyboard extension) and just sends commands to and
+accepts events from XKB. That means that it will work with the existing
+configuration of X11 server without any modifications.
-Xxkb works with virtually any window manager.
+Additional features include:
-WWW: http://www.sourceforge.net/projects/xxkb/
+ - Remembers the current layout in each application and switches to it
+ on window focus change
+ - Can put its own icon on an application window titlebar
+ - Allows to designate two main layouts from multi-layout keymaps
+ - Alternative layouts can be set separately for each application and
+ can be changed during run-time
+ - Supports custom actions for certain windows (e.g. ignore, set initial
+ active layout on application startup)
+ - Can be docked as a docklet or placed in the system tray
+
+WWW: http://sourceforge.net/projects/xxkb/
diff --git a/x11/xxkb/pkg-plist b/x11/xxkb/pkg-plist
index abd40f6133d6..564b01f44bff 100644
--- a/x11/xxkb/pkg-plist
+++ b/x11/xxkb/pkg-plist
@@ -16,9 +16,4 @@ lib/X11/app-defaults/XXkb
%%DATADIR%%/su48.xpm
%%DATADIR%%/ua15.xpm
%%DATADIR%%/ua48.xpm
-%%PORTDOCS%%%%DOCSDIR%%/LICENSE
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/CHANGES.koi8
-%%PORTDOCS%%%%DOCSDIR%%/README.koi8
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%