aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2006-04-20 13:38:02 +0000
committerVasil Dimov <vd@FreeBSD.org>2006-04-20 13:38:02 +0000
commitd0b2087f769651a0f76eaf3deff70a2f36cec2c1 (patch)
tree0af8b42518a1ea717fdae0ac77a1a3e7eaa4ee19
parent36bd477b14cf33da95ad1de6ecdb130365fcd52a (diff)
Notes
-rw-r--r--graphics/xaralx/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/graphics/xaralx/Makefile b/graphics/xaralx/Makefile
index 80d979506ccb..e8609ef397f7 100644
--- a/graphics/xaralx/Makefile
+++ b/graphics/xaralx/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= XaraLX
-PORTVERSION= 0.4r798
+PORTVERSION?= 0.4r798
CATEGORIES= graphics
MASTER_SITES= http://downloads.xara.com/opensource/
-DISTFILES= ${PORTNAME}Src-${PORTVERSION}.tar.gz
+DISTFILES?= ${PORTNAME}Src-${PORTVERSION}.tar.gz
MAINTAINER= vd@FreeBSD.org
-COMMENT= A top-tier vector and general purpose graphics program
+COMMENT?= Top-tier vector/general purpose graphics program (recommended version)
#WXDEP= ${X11BASE}/libwx_baseu-2.6.so.0.3.1
WXDEP= wxgtk2-unicode>=2.6.3
@@ -26,7 +26,8 @@ LIB_DEPENDS= dlmalloc.2:${PORTSDIR}/devel/libdlmalloc
USE_AUTOTOOLS= autoconf:259:env aclocal:19:env automake:19:env
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --with-wx-config=wxgtk2u-2.6-config
+CONFIGURE_ARGS= --with-wx-config=wxgtk2u-2.6-config \
+ --program-suffix=${PKGNAMESUFFIX}
PKGCONFIGS=atk fontconfig gdk-2.0 pango
CONFIGURE_ENV= CPPFLAGS_APPEND="`pkg-config --cflags ${PKGCONFIGS}` \
-I${LOCALBASE}/include/atk-1.0/atk \
@@ -41,7 +42,7 @@ USE_GCC= 3.4+
BROKEN= does not configure due to the lack of CDraw libraries for sparc64
.endif
-PROG= XaraLX
+PROG= XaraLX${PKGNAMESUFFIX}
PLIST_FILES= bin/${PROG}