aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-23 10:23:53 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-23 10:23:53 +0000
commitd5da69710473d5ba18bc506a136e760259452a74 (patch)
tree51df89204d33173a463ecec3426fd4e0999b304f
parentc9815dfe574a41dd837c666bbf4e8c065353c1b2 (diff)
downloadports-d5da69710473d5ba18bc506a136e760259452a74.tar.gz
ports-d5da69710473d5ba18bc506a136e760259452a74.zip
Notes
-rw-r--r--finance/aqbanking/Makefile3
-rw-r--r--finance/kmymoney-kde4/Makefile3
-rw-r--r--finance/opentaxsolver/Makefile8
-rw-r--r--french/verbiste/Makefile3
-rw-r--r--ftp/pureadmin/Makefile2
-rw-r--r--ftp/wzdftpd/Makefile8
6 files changed, 8 insertions, 19 deletions
diff --git a/finance/aqbanking/Makefile b/finance/aqbanking/Makefile
index 636635ce3fc1..48cb239f7b88 100644
--- a/finance/aqbanking/Makefile
+++ b/finance/aqbanking/Makefile
@@ -23,9 +23,8 @@ PAYPAL_DESC= Build PayPal backend (separate license)
USE_GMAKE= yes
USE_GETTEXT= yes
-USE_PKGCONFIG= build
USE_AUTOTOOLS= libtool
-USES= pathfix
+USES= pathfix pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-release="yes"
diff --git a/finance/kmymoney-kde4/Makefile b/finance/kmymoney-kde4/Makefile
index 6d0c2c7906b2..9c1c56c510a3 100644
--- a/finance/kmymoney-kde4/Makefile
+++ b/finance/kmymoney-kde4/Makefile
@@ -24,8 +24,7 @@ OFX_DESC= Enable OFX plugin
QUOTES_DESC= Enable online price quotes
USE_BZIP2= yes
-USES= cmake
-USE_PKGCONFIG= build
+USES= cmake pkgconfig
USE_QT4= gui dbus network phonon sql svg xml \
qmake_build moc_build rcc_build uic_build
USE_KDE4= kdehier kdeprefix automoc4 kdelibs pimlibs sharedmime
diff --git a/finance/opentaxsolver/Makefile b/finance/opentaxsolver/Makefile
index b2cf9e958bff..e0c87fc7331f 100644
--- a/finance/opentaxsolver/Makefile
+++ b/finance/opentaxsolver/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: opentaxsolver
-# Date created: Sat Apr 08, 2006
-# Whom: John Hein (jhein@timing.com)
-#
+# Created by: John Hein (jhein@timing.com)
# $FreeBSD$
-#
PORTNAME= ${UPPORTNAME:L}
PORTVERSION= 9.01
@@ -24,7 +20,7 @@ UPPORTNAME= OpenTaxSolver
.if !defined(WITHOUT_X11)
USE_GL= yes
USE_XORG= xmu xext x11
-USE_PKGCONFIG= yes
+USES= pkgconfig
CPPFLAGS+= $$(pkg-config --cflags-only-I glu xext xmu)
LDFLAGS+= $$(pkg-config --libs-only-L glu xext xmu)
SUB_LIST+= X11=
diff --git a/french/verbiste/Makefile b/french/verbiste/Makefile
index e8eb6e373e70..52bc4975e17a 100644
--- a/french/verbiste/Makefile
+++ b/french/verbiste/Makefile
@@ -13,12 +13,11 @@ OPTIONS_DEFINE= GTK2 GNOME
LICENSE= GPLv2
-USES= pathfix
+USES= pathfix pkgconfig
USE_AUTOTOOLS= libtool
USE_GNOME= ltverhack libxml2
USE_ICONV= yes
USE_LDCONFIG= yes
-USE_PKGCONFIG= build
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/ftp/pureadmin/Makefile b/ftp/pureadmin/Makefile
index 89ec67a67b90..a0428502fa6a 100644
--- a/ftp/pureadmin/Makefile
+++ b/ftp/pureadmin/Makefile
@@ -10,8 +10,8 @@ MASTER_SITES= SF/purify/Default/${PORTVERSION}
MAINTAINER= c.petrik.sosa@gmail.com
COMMENT= Management utility for the PureFTPd
+USES= pkgconfig
USE_GNOME= gnomehack libglade2
-USE_PKGCONFIG= yes
USE_FAM= yes
USE_GETTEXT= yes
USE_GMAKE= yes
diff --git a/ftp/wzdftpd/Makefile b/ftp/wzdftpd/Makefile
index 3f8df3dd38b7..5853f222e345 100644
--- a/ftp/wzdftpd/Makefile
+++ b/ftp/wzdftpd/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: wzdftpd
-# Date created: 2003-10-22
-# Whom: Roman Bogorodskiy
-#
+# Created by: Roman Bogorodskiy
# $FreeBSD$
-#
PORTNAME= wzdftpd
PORTVERSION= 0.8.1
@@ -14,12 +10,12 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-sources/${PORTNAME}-0.8
MAINTAINER= ports@FreeBSD.org
COMMENT= Modular FTP server configurable online using SITE commands
+USES= pkgconfig
USE_AUTOTOOLS= libtool
USE_RC_SUBR= wzdftpd
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_PKGCONFIG= yes
USE_GNOME= ltverhack
CONFIGURE_ARGS+= --without-pam --disable-pgsql --disable-bonjour
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}