aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Walter <stefan@FreeBSD.org>2006-06-17 19:47:58 +0000
committerStefan Walter <stefan@FreeBSD.org>2006-06-17 19:47:58 +0000
commite9285d361c0d45ec615500e39d38e4993a5c6759 (patch)
treead27d646ec58243d0a474f2657de7b607b8a2a3b
parent0cb2b8a64d0d6363375d2f5add9de9b77106ae93 (diff)
downloadports-e9285d361c0d45ec615500e39d38e4993a5c6759.tar.gz
ports-e9285d361c0d45ec615500e39d38e4993a5c6759.zip
Notes
-rw-r--r--graphics/vigra/Makefile47
-rw-r--r--graphics/vigra/distinfo6
-rw-r--r--graphics/vigra/files/patch-Makefile.in34
-rw-r--r--graphics/vigra/pkg-descr1
-rw-r--r--graphics/vigra/pkg-plist25
5 files changed, 64 insertions, 49 deletions
diff --git a/graphics/vigra/Makefile b/graphics/vigra/Makefile
index bd4c2cd86cbb..24963eb52075 100644
--- a/graphics/vigra/Makefile
+++ b/graphics/vigra/Makefile
@@ -10,8 +10,7 @@
# The hugin port is a gui interface to interact with panorama tools.
PORTNAME= vigra
-PORTVERSION= 1.3.2
-PORTREVISION= 2
+PORTVERSION= 1.4.0
CATEGORIES= graphics
MASTER_SITES= http://kogs-www.informatik.uni-hamburg.de/~koethe/vigra/
DISTNAME= ${PORTNAME}${PORTVERSION}
@@ -19,21 +18,45 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= cartola@openit.com.br
COMMENT= VIGRA stands for "Vision with Generic Algorithms"
-LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff \
- png:${PORTSDIR}/graphics/png \
- jpeg:${PORTSDIR}/graphics/jpeg \
- fftw3:${PORTSDIR}/math/fftw3
-
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
- --with-tiff \
- --with-jpeg \
- --with-png \
- --with-zlib \
- --with-fftw \
--docdir=${PREFIX}/share/doc/vigra
USE_GMAKE= yes
INSTALLS_SHLIB= yes
+.if !defined(WITHOUT_VIGRA_TIFF)
+LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
+CONFIGURE_ARGS+= --with-tiff
+.else
+CONFIGURE_ARGS+= --without-tiff
+.endif
+
+.if !defined(WITHOUT_VIGRA_JPEG)
+LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg
+CONFIGURE_ARGS+= --with-jpeg
+.else
+CONFIGURE_ARGS+= --without-jpeg
+.endif
+
+.if !defined(WITHOUT_VIGRA_PNG)
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
+CONFIGURE_ARGS+= --with-png
+.else
+CONFIGURE_ARGS+= --without-png
+.endif
+
+.if !defined(WITHOUT_VIGRA_ZLIB)
+CONFIGURE_ARGS+= --with-zlib
+.else
+CONFIGURE_ARGS+= --without-zlib
+.endif
+
+.if !defined(WITHOUT_VIGRA_FFTW)
+LIB_DEPENDS+= fftw3:${PORTSDIR}/math/fftw3
+CONFIGURE_ARGS+= --with-fftw
+.else
+CONFIGURE_ARGS+= --without-fftw
+.endif
+
.include <bsd.port.mk>
diff --git a/graphics/vigra/distinfo b/graphics/vigra/distinfo
index 1c40bc68631d..43fa07cd33aa 100644
--- a/graphics/vigra/distinfo
+++ b/graphics/vigra/distinfo
@@ -1,3 +1,3 @@
-MD5 (vigra1.3.2.tar.gz) = 6a787f86df5e45be809ac97c86acddae
-SHA256 (vigra1.3.2.tar.gz) = 308d5b9531ae132812978f1fdf4ad0cf88f675b5c10aa1b5b94ba6ca70db325f
-SIZE (vigra1.3.2.tar.gz) = 3150473
+MD5 (vigra1.4.0.tar.gz) = ea91f2fb4212a21d708aced277e6e85a
+SHA256 (vigra1.4.0.tar.gz) = dc6445d2c0445e5536010b80bd811adda6741ed82b288fe831d5be9902457941
+SIZE (vigra1.4.0.tar.gz) = 12735186
diff --git a/graphics/vigra/files/patch-Makefile.in b/graphics/vigra/files/patch-Makefile.in
deleted file mode 100644
index 10cec478b500..000000000000
--- a/graphics/vigra/files/patch-Makefile.in
+++ /dev/null
@@ -1,34 +0,0 @@
---- Makefile.in.orig Wed Mar 9 09:53:07 2005
-+++ Makefile.in Wed Mar 9 09:53:45 2005
-@@ -10,26 +10,26 @@
- install-exec:
- @cd src ; $(MAKE) install ; cd ..
- $(INSTALL) -d $(bindir)
-- $(INSTALL) --mode=755 $(vigra_builddir)/config/vigra-config $(bindir)
-+ $(INSTALL) -m 755 $(vigra_builddir)/config/vigra-config $(bindir)
-
- install-includes:
- if test "$(includedir)" != "$(vigra_srcdir)/include" ; then \
- $(INSTALL) -d $(includedir)/vigra ; \
-- $(INSTALL) --mode=644 $(vigra_srcdir)/include/vigra/*.hxx $(includedir)/vigra ; \
-+ $(INSTALL) -m 644 $(vigra_srcdir)/include/vigra/*.hxx $(includedir)/vigra ; \
- fi
- install-headers: install-includes
-
- install-docs:
- $(INSTALL) -d $(docdir)
-- $(INSTALL) --mode=644 LICENSE $(docdir)
-+ $(INSTALL) -m 644 LICENSE $(docdir)
- if test "$(docdir)" != "$(vigra_srcdir)/doc/vigra" ; then \
-- $(INSTALL) --mode=644 \
-+ $(INSTALL) -m 644 \
- $(vigra_srcdir)/doc/vigra/*.html \
- $(vigra_srcdir)/doc/vigra/classvigra*.png $(vigra_srcdir)/doc/vigra/form*.png \
- $(vigra_srcdir)/doc/vigra/doxygen.png $(vigra_srcdir)/doc/vigra/doxygen.css \
- $(docdir) ; \
- $(INSTALL) -d $(docdir)/documents ; \
-- $(INSTALL) --mode=644 \
-+ $(INSTALL) -m 644 \
- $(vigra_srcdir)/doc/vigra/documents/*.ps \
- $(vigra_srcdir)/doc/vigra/documents/*.gif \
- $(docdir)/documents ; \
diff --git a/graphics/vigra/pkg-descr b/graphics/vigra/pkg-descr
index f2ee081f6a2d..1073afa02721 100644
--- a/graphics/vigra/pkg-descr
+++ b/graphics/vigra/pkg-descr
@@ -5,6 +5,7 @@ the C++ Standard Template Library, you can easily adapt any VIGRA
component to the needs of your application, without thereby giving up
execution speed.
+Author: Ullrich Koethe <koethe@informatik.uni-hamburg.de>
WWW: http://kogs-www.informatik.uni-hamburg.de/~koethe/vigra/
- Ported by Cartola
diff --git a/graphics/vigra/pkg-plist b/graphics/vigra/pkg-plist
index a0caa2d5951f..13ed1d182756 100644
--- a/graphics/vigra/pkg-plist
+++ b/graphics/vigra/pkg-plist
@@ -21,11 +21,13 @@ include/vigra/eigensystem.hxx
include/vigra/error.hxx
include/vigra/fftw.hxx
include/vigra/fftw3.hxx
+include/vigra/fixedpoint.hxx
include/vigra/flatmorphology.hxx
include/vigra/functorexpression.hxx
include/vigra/functortraits.hxx
include/vigra/gaborfilter.hxx
include/vigra/gaussians.hxx
+include/vigra/gradient_energy_tensor.hxx
include/vigra/imagecontainer.hxx
include/vigra/imageinfo.hxx
include/vigra/imageiterator.hxx
@@ -64,8 +66,10 @@ include/vigra/rfftw.hxx
include/vigra/rgbvalue.hxx
include/vigra/seededregiongrowing.hxx
include/vigra/separableconvolution.hxx
+include/vigra/sized_int.hxx
include/vigra/splineimageview.hxx
include/vigra/splines.hxx
+include/vigra/static_assert.hxx
include/vigra/stdconvolution.hxx
include/vigra/stdimage.hxx
include/vigra/stdimagefunctions.hxx
@@ -76,6 +80,7 @@ include/vigra/tinyvector.hxx
include/vigra/transformimage.hxx
include/vigra/tuple.hxx
include/vigra/utilities.hxx
+include/vigra/watersheds.hxx
lib/libvigraimpex.a
lib/libvigraimpex.la
lib/libvigraimpex.so
@@ -90,6 +95,7 @@ lib/libvigraimpex.so.2
%%DOCSDIR%%/ErrorReporting.html
%%DOCSDIR%%/Examples.html
%%DOCSDIR%%/FFTWComplexTraits.html
+%%DOCSDIR%%/FixedPointTraits.html
%%DOCSDIR%%/FourierTransformFFTW2.html
%%DOCSDIR%%/FunctorExpressions.html
%%DOCSDIR%%/ImageAnalysis.html
@@ -103,6 +109,7 @@ lib/libvigraimpex.so.2
%%DOCSDIR%%/MathFunctionality.html
%%DOCSDIR%%/MultiDimensionalArrays.html
%%DOCSDIR%%/MultiIteratorPage.html
+%%DOCSDIR%%/NormTraits.html
%%DOCSDIR%%/NumericPromotionTraits.html
%%DOCSDIR%%/NumericTraits.html
%%DOCSDIR%%/PixelTypes.html
@@ -110,6 +117,7 @@ lib/libvigraimpex.so.2
%%DOCSDIR%%/PromoteTraits.html
%%DOCSDIR%%/RGBValueTraits.html
%%DOCSDIR%%/RationalTraits.html
+%%DOCSDIR%%/SquareRootTraits.html
%%DOCSDIR%%/TinyVectorTraits.html
%%DOCSDIR%%/TupleTypes.html
%%DOCSDIR%%/Utilities.html
@@ -201,6 +209,8 @@ lib/libvigraimpex.so.2
%%DOCSDIR%%/classvigra_1_1FindMinMax.html
%%DOCSDIR%%/classvigra_1_1FindROISize-members.html
%%DOCSDIR%%/classvigra_1_1FindROISize.html
+%%DOCSDIR%%/classvigra_1_1FixedPoint-members.html
+%%DOCSDIR%%/classvigra_1_1FixedPoint.html
%%DOCSDIR%%/classvigra_1_1FourNeighborhood_1_1NeighborCode-members.html
%%DOCSDIR%%/classvigra_1_1FourNeighborhood_1_1NeighborCode.html
%%DOCSDIR%%/classvigra_1_1FunctorTraits-members.html
@@ -269,6 +279,7 @@ lib/libvigraimpex.so.2
%%DOCSDIR%%/classvigra_1_1NeighborOffsetCirculator.html
%%DOCSDIR%%/classvigra_1_1NeighborhoodCirculator-members.html
%%DOCSDIR%%/classvigra_1_1NeighborhoodCirculator.html
+%%DOCSDIR%%/classvigra_1_1NeighborhoodCirculator.png
%%DOCSDIR%%/classvigra_1_1Point2D-members.html
%%DOCSDIR%%/classvigra_1_1Point2D.html
%%DOCSDIR%%/classvigra_1_1Point2D.png
@@ -320,6 +331,9 @@ lib/libvigraimpex.so.2
%%DOCSDIR%%/classvigra_1_1RedAccessor.html
%%DOCSDIR%%/classvigra_1_1ReduceFunctor-members.html
%%DOCSDIR%%/classvigra_1_1ReduceFunctor.html
+%%DOCSDIR%%/classvigra_1_1RestrictedNeighborhoodCirculator-members.html
+%%DOCSDIR%%/classvigra_1_1RestrictedNeighborhoodCirculator.html
+%%DOCSDIR%%/classvigra_1_1RestrictedNeighborhoodCirculator.png
%%DOCSDIR%%/classvigra_1_1RowIterator-members.html
%%DOCSDIR%%/classvigra_1_1RowIterator.html
%%DOCSDIR%%/classvigra_1_1SeedRgDirectValueFunctor-members.html
@@ -332,6 +346,10 @@ lib/libvigraimpex.so.2
%%DOCSDIR%%/classvigra_1_1Size2D.png
%%DOCSDIR%%/classvigra_1_1SplineImageView-members.html
%%DOCSDIR%%/classvigra_1_1SplineImageView.html
+%%DOCSDIR%%/classvigra_1_1SplineImageView0-members.html
+%%DOCSDIR%%/classvigra_1_1SplineImageView0.html
+%%DOCSDIR%%/classvigra_1_1SplineImageView1-members.html
+%%DOCSDIR%%/classvigra_1_1SplineImageView1.html
%%DOCSDIR%%/classvigra_1_1StandardAccessor-members.html
%%DOCSDIR%%/classvigra_1_1StandardAccessor.html
%%DOCSDIR%%/classvigra_1_1StandardConstAccessor-members.html
@@ -424,6 +442,7 @@ lib/libvigraimpex.so.2
%%DOCSDIR%%/fftw3_8hxx-source.html
%%DOCSDIR%%/fftw_8hxx-source.html
%%DOCSDIR%%/files.html
+%%DOCSDIR%%/fixedpoint_8hxx-source.html
%%DOCSDIR%%/flatmorphology_8hxx-source.html
%%DOCSDIR%%/form_0.png
%%DOCSDIR%%/form_1.png
@@ -487,6 +506,7 @@ lib/libvigraimpex.so.2
%%DOCSDIR%%/functortraits_8hxx-source.html
%%DOCSDIR%%/gaborfilter_8hxx-source.html
%%DOCSDIR%%/gaussians_8hxx-source.html
+%%DOCSDIR%%/gradient__energy__tensor_8hxx-source.html
%%DOCSDIR%%/group__CombineAlgo.html
%%DOCSDIR%%/group__CombineFunctor.html
%%DOCSDIR%%/group__CommonConvolutionFilters.html
@@ -497,6 +517,8 @@ lib/libvigraimpex.so.2
%%DOCSDIR%%/group__EdgeDetection.html
%%DOCSDIR%%/group__FFTWComplexAccessors.html
%%DOCSDIR%%/group__FFTWComplexOperators.html
+%%DOCSDIR%%/group__FixedPointOperations.html
+%%DOCSDIR%%/group__FixedSizeInt.html
%%DOCSDIR%%/group__FourierTransform.html
%%DOCSDIR%%/group__Functors.html
%%DOCSDIR%%/group__GaborFilter.html
@@ -593,9 +615,11 @@ lib/libvigraimpex.so.2
%%DOCSDIR%%/rgbvalue_8hxx-source.html
%%DOCSDIR%%/seededregiongrowing_8hxx-source.html
%%DOCSDIR%%/separableconvolution_8hxx-source.html
+%%DOCSDIR%%/sized__int_8hxx-source.html
%%DOCSDIR%%/smooth_8cxx-example.html
%%DOCSDIR%%/splineimageview_8hxx-source.html
%%DOCSDIR%%/splines_8hxx-source.html
+%%DOCSDIR%%/static__assert_8hxx-source.html
%%DOCSDIR%%/stdconvolution_8hxx-source.html
%%DOCSDIR%%/stdimage_8hxx-source.html
%%DOCSDIR%%/stdimagefunctions_8hxx-source.html
@@ -613,6 +637,7 @@ lib/libvigraimpex.so.2
%%DOCSDIR%%/utilities_8hxx-source.html
%%DOCSDIR%%/voronoi_8cxx-example.html
%%DOCSDIR%%/watershed_8cxx-example.html
+%%DOCSDIR%%/watersheds_8hxx-source.html
@dirrm %%DOCSDIR%%/documents
@dirrm %%DOCSDIR%%
@dirrm include/vigra