aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-11-02 12:05:56 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-11-02 12:05:56 +0000
commitfc952e6355ab202e51a36e65dbe0d67a9dc49bf8 (patch)
tree58e66ded4860472ff6e9acb334369704c85f1748
parent1cecb4a491e09e04ad926dbc897faf72e39824e3 (diff)
downloadports-fc952e6355ab202e51a36e65dbe0d67a9dc49bf8.tar.gz
ports-fc952e6355ab202e51a36e65dbe0d67a9dc49bf8.zip
Notes
-rw-r--r--deskutils/osmo/Makefile39
-rw-r--r--deskutils/osmo/distinfo4
-rw-r--r--deskutils/osmo/files/patch-src__backup.c17
-rw-r--r--deskutils/osmo/files/patch-src__check_events.c48
-rw-r--r--deskutils/osmo/pkg-plist7
5 files changed, 43 insertions, 72 deletions
diff --git a/deskutils/osmo/Makefile b/deskutils/osmo/Makefile
index 57d24fda7f9a..21e47bd37e75 100644
--- a/deskutils/osmo/Makefile
+++ b/deskutils/osmo/Makefile
@@ -2,42 +2,37 @@
# $FreeBSD$
PORTNAME= osmo
-PORTVERSION= 0.2.10
-PORTREVISION= 7
+PORTVERSION= 0.2.12
CATEGORIES= deskutils
-MASTER_SITES= SF/${PORTNAME}-pim/${PORTNAME}-pim/${PORTNAME}-${PORTVERSION}/
+MASTER_SITES= SF/${PORTNAME}-pim/${PORTNAME}-pim/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Personal organizer
-LIB_DEPENDS= libxml2.so:${PORTSDIR}/textproc/libxml2 \
+LICENSE= GPLv2 # (or later)
+
+LIB_DEPENDS= libical.so:${PORTSDIR}/devel/libical \
libnotify.so:${PORTSDIR}/devel/libnotify \
- libical.so:${PORTSDIR}/devel/libical \
- libtar.so:${PORTSDIR}/devel/libtar \
libgringotts.so:${PORTSDIR}/security/libgringotts \
- libgtkhtml-2.so:${PORTSDIR}/www/libgtkhtml
+ libgtkspell.so:${PORTSDIR}/textproc/gtkspell \
+ libwebkitgtk-1.0.so:${PORTSDIR}/www/webkit-gtk2
-USE_GNOME= gtk20
USES= gettext gmake pkgconfig
-INSTALLS_ICONS= yes
-
+USE_GNOME= gtk20 libxml2
+USE_SQLITE= yes
GNU_CONFIGURE= yes
-LDFLAGS+= -L${LOCALBASE}/lib -lintl
-CFLAGS+= -I${LOCALBASE}/include/libical
-
-POFILES= bg ca cs da de el en_GB es fi fr hu it ja lt nl pl pt \
- ru sv tr uk zh_CN
+CONFIGURE_ENV= LIBARCHIVE_CFLAGS=" " LIBARCHIVE_LIBS="-larchive"
+INSTALLS_ICONS= yes
-MSGFMT= ${LOCALBASE}/bin/msgfmt
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
-post-patch:
- @${REINPLACE_CMD} -e 's|-DGTK_DISABLE_DEPRECATED||g' \
- ${WRKSRC}/src/Makefile.in
+POFILES= bg ca cs da de el en_GB es fi fr gl gl_ES hu it ja lt nl \
+ pl pt pt_BR ro ru sv te tr uk ur ur_PK zh_CN
-pre-install:
-# workaround to problem in po makefile
+post-build:
.for p in ${POFILES}
- ${MSGFMT} -c ${WRKSRC}/po/$p.po -o ${WRKSRC}/po/$p.mo
+ (cd ${WRKSRC}/po && ${LOCALBASE}/bin/msgfmt -c ${p}.po -o ${p}.mo)
.endfor
.include <bsd.port.mk>
diff --git a/deskutils/osmo/distinfo b/deskutils/osmo/distinfo
index dcfe8c1a06d3..b840515ea974 100644
--- a/deskutils/osmo/distinfo
+++ b/deskutils/osmo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (osmo-0.2.10.tar.gz) = 4e911c52ac64a088f8a812b354084e7adedd1b54cb0435995a2cdc1d194d0845
-SIZE (osmo-0.2.10.tar.gz) = 851833
+SHA256 (osmo-0.2.12.tar.gz) = 93bda51614f92e4193840451612e792219f7d8c90d78bdc7ea6d6c14a2be6b78
+SIZE (osmo-0.2.12.tar.gz) = 907452
diff --git a/deskutils/osmo/files/patch-src__backup.c b/deskutils/osmo/files/patch-src__backup.c
new file mode 100644
index 000000000000..e9cce70a0757
--- /dev/null
+++ b/deskutils/osmo/files/patch-src__backup.c
@@ -0,0 +1,17 @@
+--- src/backup.c.orig 2014-10-19 00:26:19.000000000 +0900
++++ src/backup.c 2014-10-19 00:32:50.000000000 +0900
+@@ -41,6 +41,14 @@
+ #include <archive.h>
+ #include <archive_entry.h>
+
++#ifdef __FreeBSD__
++#include <sys/param.h>
++#if __FreeBSD_version <= 1000008 /* r232154: bump for libarchive update */
++#define archive_read_support_filter_all(x) \
++ archive_read_support_compression_all(x)
++#endif
++#endif
++
+ /*------------------------------------------------------------------------------*/
+
+ int
diff --git a/deskutils/osmo/files/patch-src__check_events.c b/deskutils/osmo/files/patch-src__check_events.c
deleted file mode 100644
index 24f53e87349d..000000000000
--- a/deskutils/osmo/files/patch-src__check_events.c
+++ /dev/null
@@ -1,48 +0,0 @@
---- src/check_events.c.orig 2011-08-12 15:17:59.000000000 +0200
-+++ src/check_events.c 2011-08-12 15:20:36.000000000 +0200
-@@ -454,9 +454,9 @@
- a->date = 0;
-
- if (textdesc != NULL)
-- a->notify = notify_notification_new (item->summary, textdesc, GTK_STOCK_DIALOG_WARNING, NULL);
-+ a->notify = notify_notification_new (item->summary, textdesc, GTK_STOCK_DIALOG_WARNING);
- else
-- a->notify = notify_notification_new (item->summary, text, GTK_STOCK_DIALOG_WARNING, NULL);
-+ a->notify = notify_notification_new (item->summary, text, GTK_STOCK_DIALOG_WARNING);
-
- g_free (textdesc);
- g_free (text);
-@@ -483,9 +483,7 @@
- #endif /* HAVE_LIBNOTIFY */
-
- if (gtk_status_icon_get_visible (appGUI->osmo_trayicon)) {
--#ifdef HAVE_LIBNOTIFY
-- notify_notification_attach_to_status_icon (a->notify, appGUI->osmo_trayicon);
--#endif /* HAVE_LIBNOTIFY */
-+
- gtk_status_icon_set_from_stock (appGUI->osmo_trayicon, OSMO_STOCK_SYSTRAY_TASK);
-
- if (config.blink_on_events) {
-@@ -532,9 +530,9 @@
- a->time = -1;
- a->date = 0;
- if (textdesc != NULL)
-- a->notify = notify_notification_new (_("Alarm warning!"), textdesc, GTK_STOCK_DIALOG_INFO, NULL);
-+ a->notify = notify_notification_new (_("Alarm warning!"), textdesc, GTK_STOCK_DIALOG_INFO);
- else
-- a->notify = notify_notification_new (_("Alarm warning!"), text, GTK_STOCK_DIALOG_INFO, NULL);
-+ a->notify = notify_notification_new (_("Alarm warning!"), text, GTK_STOCK_DIALOG_INFO);
-
- notify_notification_set_timeout (a->notify, NOTIFY_EXPIRES_NEVER);
- notify_notification_set_urgency (a->notify, NOTIFY_URGENCY_NORMAL);
-@@ -545,9 +543,7 @@
- #endif /* HAVE_LIBNOTIFY */
-
- if (gtk_status_icon_get_visible (appGUI->osmo_trayicon)) {
--#ifdef HAVE_LIBNOTIFY
-- notify_notification_attach_to_status_icon (a->notify, appGUI->osmo_trayicon);
--#endif /* HAVE_LIBNOTIFY */
-+
- gtk_status_icon_set_from_stock (appGUI->osmo_trayicon, OSMO_STOCK_SYSTRAY_TASK);
-
- if (config.blink_on_events) {
diff --git a/deskutils/osmo/pkg-plist b/deskutils/osmo/pkg-plist
index f47814a5fe23..1314905a23a8 100644
--- a/deskutils/osmo/pkg-plist
+++ b/deskutils/osmo/pkg-plist
@@ -17,6 +17,8 @@ share/locale/en_GB/LC_MESSAGES/osmo.mo
share/locale/es/LC_MESSAGES/osmo.mo
share/locale/fi/LC_MESSAGES/osmo.mo
share/locale/fr/LC_MESSAGES/osmo.mo
+share/locale/gl/LC_MESSAGES/osmo.mo
+share/locale/gl_ES/LC_MESSAGES/osmo.mo
share/locale/hu/LC_MESSAGES/osmo.mo
share/locale/it/LC_MESSAGES/osmo.mo
share/locale/ja/LC_MESSAGES/osmo.mo
@@ -24,10 +26,15 @@ share/locale/lt/LC_MESSAGES/osmo.mo
share/locale/nl/LC_MESSAGES/osmo.mo
share/locale/pl/LC_MESSAGES/osmo.mo
share/locale/pt/LC_MESSAGES/osmo.mo
+share/locale/pt_BR/LC_MESSAGES/osmo.mo
+share/locale/ro/LC_MESSAGES/osmo.mo
share/locale/ru/LC_MESSAGES/osmo.mo
share/locale/sv/LC_MESSAGES/osmo.mo
+share/locale/te/LC_MESSAGES/osmo.mo
share/locale/tr/LC_MESSAGES/osmo.mo
share/locale/uk/LC_MESSAGES/osmo.mo
+share/locale/ur/LC_MESSAGES/osmo.mo
+share/locale/ur_PK/LC_MESSAGES/osmo.mo
share/locale/zh_CN/LC_MESSAGES/osmo.mo
share/pixmaps/osmo.png
share/sounds/osmo/alarm.wav