aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2013-11-23 01:21:00 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2013-11-23 01:21:00 +0000
commit19fa1f15264591ad26089f82329fff8c9c5e9fe2 (patch)
treee6d4b6cf7de3a536d37bd1763ecaeef0b4a80b11
parent3bca824aa4320f79519d9ef5069b1e2d2f64f2a2 (diff)
downloadports-19fa1f15264591ad26089f82329fff8c9c5e9fe2.tar.gz
ports-19fa1f15264591ad26089f82329fff8c9c5e9fe2.zip
Notes
-rw-r--r--MOVED1
-rw-r--r--Mk/bsd.gcc.mk7
-rw-r--r--lang/Makefile1
-rw-r--r--lang/gcc42/Makefile104
-rw-r--r--lang/gcc42/distinfo6
-rw-r--r--lang/gcc42/files/java-patch-hier13
-rw-r--r--lang/gcc42/files/patch-libcpp10
-rw-r--r--lang/gcc42/pkg-descr6
-rw-r--r--lang/gcc42/pkg-plist13
9 files changed, 3 insertions, 158 deletions
diff --git a/MOVED b/MOVED
index c12dce0ebe7b..af49b571f1fe 100644
--- a/MOVED
+++ b/MOVED
@@ -5249,3 +5249,4 @@ devel/netbsd-pkgsrc-mk-files||2013-11-20|Has expired: Imported for devel/mk-conf
net/ptpd|net/ptpd2|2013-11-20|Protocol and software no longer supported
audio/gstreamer1-plugins-celt||2013-11-20|Removed, audio/gstreamer1-plugins-opus can be used as replacement
math/p5-MatrixReal|math/p5-Math-MatrixReal|2013-11-22|Rename to match upstream naming
+lang/gcc42|lang/gcc46|2013-11-23|Superseded by GCC 4.6 or later
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index 50ea0ff8a48d..0e973900c242 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -48,13 +48,12 @@ GCC_Include_MAINTAINER= gerald@FreeBSD.org
# All GCC versions supported by the ports framework. Keep them in
# ascending order and in sync with the table below.
-GCCVERSIONS= 030402 040200 040400 040600 040700 040800 040900
+GCCVERSIONS= 030402 040400 040600 040700 040800 040900
# The first field if the OSVERSION in which it appeared in the base.
# The second field is the OSVERSION in which it disappeared from the base.
# The third field is the version as USE_GCC would use.
GCCVERSION_030402= 502126 700042 3.4
-GCCVERSION_040200= 700042 9999999 4.2
GCCVERSION_040400= 0 0 4.4
GCCVERSION_040600= 0 0 4.6
GCCVERSION_040700= 0 0 4.7
@@ -156,7 +155,7 @@ IGNORE= Unknown version of GCC specified (USE_GCC=${USE_GCC})
.endif
# If the GCC package defined in USE_GCC does not exist, but a later
-# version is allowed (for example 4.2+), see if there is a later.
+# version is allowed (for example 4.7+), see if there is a later.
# First check if the base installed version is good enough, otherwise
# get the first available version.
#
@@ -236,11 +235,9 @@ CPP:= cpp
BUILD_DEPENDS+= ${_GCC_PORT_DEPENDS}:${PORTSDIR}/lang/${_GCC_PORT}
. if ${_USE_GCC} != 3.4
RUN_DEPENDS+= ${_GCC_PORT_DEPENDS}:${PORTSDIR}/lang/${_GCC_PORT}
-. if ${_USE_GCC} != 4.2
# Later GCC ports already depend on binutils; make sure whatever we
# build leverages this as well.
USE_BINUTILS= yes
-. endif
. endif
.endif
.endif # defined(_USE_GCC) && !defined(FORCE_BASE_CC_FOR_TESTING)
diff --git a/lang/Makefile b/lang/Makefile
index 7b5cf83922a7..2002846246ce 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -91,7 +91,6 @@
SUBDIR += gcc-aux
SUBDIR += gcc-ecj45
SUBDIR += gcc34
- SUBDIR += gcc42
SUBDIR += gcc44
SUBDIR += gcc46
SUBDIR += gcc47
diff --git a/lang/gcc42/Makefile b/lang/gcc42/Makefile
deleted file mode 100644
index cdc99ac6a1e6..000000000000
--- a/lang/gcc42/Makefile
+++ /dev/null
@@ -1,104 +0,0 @@
-# Created by: Gerald Pfeifer <gerald@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= gcc
-PORTVERSION= 4.2.5.20090325
-PORTREVISION= 5
-CATEGORIES= lang
-MASTER_SITES= ${MASTER_SITE_GCC}
-MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
-DISTFILES= gcc-core-${VERSIONSTRING}${EXTRACT_SUFX} \
- gcc-g++-${VERSIONSTRING}${EXTRACT_SUFX} \
- gcc-objc-${VERSIONSTRING}${EXTRACT_SUFX}
-
-MAINTAINER= gerald@FreeBSD.org
-COMMENT= GNU Compiler Collection 4.2
-
-LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp \
- mpfr:${PORTSDIR}/math/mpfr
-
-DEPRECATED= Superseded by GCC 4.6
-
-VERSIONSTRING= ${PORTVERSION:C/([0-9]+\.[0-9]+).*\.([0-9]+)/\1-\2/}
-SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
-LATEST_LINK= gcc${SUFFIX}${PKGNAMESUFFIX}
-NOT_FOR_ARCHS= arm powerpc
-USES= bison gmake iconv perl5
-USE_BZIP2= yes
-USE_CSTD= gnu89
-USE_PERL5= build
-SSP_UNSAFE= yes
-
-PATCH_WRKSRC= ${SRCDIR}
-CONFIGURE_SCRIPT= ../${SRCDIR:S/${WRKDIR}\///}/configure
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64"
-CONFIGURE_TARGET= x86_64-portbld-${OPSYS:L}${OSREL}
-.else
-CONFIGURE_TARGET= ${ARCH}-portbld-${OPSYS:L}${OSREL}
-.endif
-
-SRCDIR= ${WRKDIR}/gcc-${VERSIONSTRING}
-WRKSRC= ${WRKDIR}/build
-TARGLIB= ${PREFIX}/lib/gcc${SUFFIX}
-LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--disable-bootstrap \
- --disable-nls \
- --libdir=${TARGLIB} \
- --libexecdir=${LIBEXEC} \
- --program-suffix=${SUFFIX} \
- --with-as=/usr/bin/as \
- --with-gmp=${LOCALBASE} \
- --with-gxx-include-dir=${TARGLIB}/include/c++/ \
- --with-ld=/usr/bin/ld \
- ${ICONV_CONFIGURE_ARG} \
- --with-pkgversion="FreeBSD Ports Collection" \
- --with-system-zlib
-MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
-USE_LDCONFIG= ${TARGLIB}
-PLIST_SUB= GCC_VER=${PORTVERSION:C/(.+)\.[0-9]+/\1/} \
- GNU_HOST=${CONFIGURE_TARGET} \
- SUFFIX=${SUFFIX}
-MAN1= cpp${SUFFIX}.1 \
- g++${SUFFIX}.1 \
- gcc${SUFFIX}.1 \
- gcov${SUFFIX}.1
-INFO= gcc${SUFFIX}/cpp \
- gcc${SUFFIX}/cppinternals \
- gcc${SUFFIX}/gcc \
- gcc${SUFFIX}/gccinstall \
- gcc${SUFFIX}/gccint \
- gcc${SUFFIX}/libgomp
-
-pre-everything::
- @${ECHO_MSG} "Making GCC ${PORTVERSION} for ${OPSYS} ${OSREL} target=${CONFIGURE_TARGET}"
-
-post-patch:
- @${REINPLACE_CMD} -e 's|\(#define VERSUFFIX.*\)"|\1 [FreeBSD Ports Collection]"|' \
- ${SRCDIR}/gcc/version.c
-
-pre-configure:
- cd ${SRCDIR} ; contrib/gcc_update --touch
- @${RM} -f ${SRCDIR}/gcc/*/*.info*
- @${MKDIR} ${CONFIGURE_WRKSRC}
-
-post-install:
- ${RM} -f ${PREFIX}/man/man7/fsf-funding.7 \
- ${PREFIX}/man/man7/gfdl.7 ${PREFIX}/man/man7/gpl.7
- ${RM} -f ${TARGLIB}/*.la
- # Add target libraries and include files to packaging list.
- ${RM} -f ${WRKDIR}/PLIST.lib
-.for d in ${TARGLIB:S/^${PREFIX}\///} ${LIBEXEC:S/^${PREFIX}\///}
- cd ${PREFIX} ; if [ -d $d ]; then \
- ${FIND} $d -type f -o -type l >>${WRKDIR}/PLIST.lib ;\
- ${FIND} $d -type d | ${SORT} -r \
- | ${SED} -e 's/^/@dirrm /g' >>${WRKDIR}/PLIST.lib ;\
- fi
-.endfor
- cd ${WRKDIR} ; ${SED} -i -e "/PLIST.lib/ r PLIST.lib" ${TMPPLIST}
-
-.include <bsd.port.post.mk>
diff --git a/lang/gcc42/distinfo b/lang/gcc42/distinfo
deleted file mode 100644
index 1a65adec9387..000000000000
--- a/lang/gcc42/distinfo
+++ /dev/null
@@ -1,6 +0,0 @@
-SHA256 (gcc-core-4.2-20090325.tar.bz2) = f5789fd0d54d1d1f388fdac814a43ee87bd1e2f6ab904412767e2cf2dad712ea
-SIZE (gcc-core-4.2-20090325.tar.bz2) = 16062670
-SHA256 (gcc-g++-4.2-20090325.tar.bz2) = abe6f2f91a5f27b03948cb3cc2d6672540bae0f8c89055a054c0043ba57f7bb1
-SIZE (gcc-g++-4.2-20090325.tar.bz2) = 4826743
-SHA256 (gcc-objc-4.2-20090325.tar.bz2) = ed7489522fbfb9ed6be9a028e3fe73018d406e206f4dd9d79b892c4b04bd3366
-SIZE (gcc-objc-4.2-20090325.tar.bz2) = 196233
diff --git a/lang/gcc42/files/java-patch-hier b/lang/gcc42/files/java-patch-hier
deleted file mode 100644
index edb122b087b8..000000000000
--- a/lang/gcc42/files/java-patch-hier
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: libjava/Makefile.in
-===================================================================
---- libjava/Makefile.in (revision 117734)
-+++ libjava/Makefile.in (working copy)
-@@ -712,7 +712,7 @@
- $(am__append_2) $(am__append_3)
- toolexecmainlib_DATA = libgcj.spec
- dbexec_LTLIBRARIES = libjvm.la
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(prefix)/libdata/pkgconfig
- jardir = $(datadir)/java
- jar_DATA = libgcj-$(gcc_version).jar libgcj-tools-$(gcc_version).jar
- @JAVA_HOME_SET_FALSE@JAVA_HOME_DIR = $(prefix)
diff --git a/lang/gcc42/files/patch-libcpp b/lang/gcc42/files/patch-libcpp
deleted file mode 100644
index 80ed1a7f246d..000000000000
--- a/lang/gcc42/files/patch-libcpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- libcpp/internal.h 2012-07-30 09:24:59.000000000 +0000
-+++ libcpp/internal.h 2013-09-04 00:41:26.000000000 +0000
-@@ -27,6 +27,7 @@
- #include "cpp-id-data.h"
-
- #if HAVE_ICONV
-+#define __bool_true_false_are_defined
- #include <iconv.h>
- #else
- #define HAVE_ICONV 0
diff --git a/lang/gcc42/pkg-descr b/lang/gcc42/pkg-descr
deleted file mode 100644
index 7f923a336784..000000000000
--- a/lang/gcc42/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-GCC, the GNU Compiler Collection, supports a number of languages. This
-port installs the C and C++ front ends as gcc42 and g++42, respectively.
-
-WWW: http://gcc.gnu.org/
-
-Gerald Pfeifer <gerald@FreeBSD.org>
diff --git a/lang/gcc42/pkg-plist b/lang/gcc42/pkg-plist
deleted file mode 100644
index 04d43ba5b8b3..000000000000
--- a/lang/gcc42/pkg-plist
+++ /dev/null
@@ -1,13 +0,0 @@
-@comment $FreeBSD$
-bin/%%GNU_HOST%%-c++%%SUFFIX%%
-bin/%%GNU_HOST%%-g++%%SUFFIX%%
-bin/%%GNU_HOST%%-gcc%%SUFFIX%%
-bin/%%GNU_HOST%%-gcc-%%GCC_VER%%
-bin/c++%%SUFFIX%%
-bin/cpp%%SUFFIX%%
-bin/g++%%SUFFIX%%
-bin/gcc%%SUFFIX%%
-bin/gccbug%%SUFFIX%%
-bin/gcov%%SUFFIX%%
-info/gcc%%SUFFIX%%/dir
-@comment Insert PLIST.lib here