aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2018-09-27 21:40:07 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2018-09-27 21:40:07 +0000
commit1b9ab6ef3767354b95af2944413c05978bb20cac (patch)
treeb7471602cab40ec13e8eaef352c6dd40a87def2b
parent6a504aa868fbe6d736161051f2e202e688646e06 (diff)
downloadports-1b9ab6ef3767354b95af2944413c05978bb20cac.tar.gz
ports-1b9ab6ef3767354b95af2944413c05978bb20cac.zip
Notes
-rw-r--r--www/unit-go/Makefile10
-rw-r--r--www/unit-go/pkg-plist113
2 files changed, 103 insertions, 20 deletions
diff --git a/www/unit-go/Makefile b/www/unit-go/Makefile
index 0388c327f512..8fca9d7955d2 100644
--- a/www/unit-go/Makefile
+++ b/www/unit-go/Makefile
@@ -9,23 +9,23 @@ USES= go
PLIST_FILES= # reset to empty
PLIST_DIRS= # reset to empty
-PLIST= ${.CURDIR}/pkg-plist
+PLIST= ${.CURDIR}/pkg-plist
USE_RC_SUBR?= # reset to empty
MASTERDIR= ${.CURDIR}/../unit
CGO_CFLAGS+= -I${WRKSRC}/src -I${WRKSRC}/build
+GO_PKGNAME= nginx/unit
post-extract:
- ${MKDIR} ${GO_WRKSRC:H}
- ${LN} -sf ${WRKSRC}/src/go/unit ${GO_WRKSRC}
+ @true # override master's
post-configure:
- cd ${WRKSRC} && env ${GO_ENV} ./configure go
+ cd ${WRKSRC} && ${SETENV} ${GO_ENV} ./configure go --go-path=${WRKDIR}
pre-build:
- cd ${WRKSRC} && make go
+ cd ${WRKSRC} && ${MAKE} go-install
post-install:
@true # override master's
diff --git a/www/unit-go/pkg-plist b/www/unit-go/pkg-plist
index 01ad0be05ddb..421d0f8f68ff 100644
--- a/www/unit-go/pkg-plist
+++ b/www/unit-go/pkg-plist
@@ -1,19 +1,102 @@
-%%GO_LIBDIR%%/unit.a
+%%GO_LIBDIR%%/nginx/unit.a
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ldflags-lrt.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_go_array.c
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_go_array.h
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_go_lib.c
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_go_lib.h
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_go_log.h
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_go_mutex.h
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_go_port_memory.c
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_go_port_memory.h
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_go_port.c
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_go_port.h
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_go_process.c
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_go_process.h
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_go_run_ctx.c
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_go_run_ctx.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_application.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_array.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_atomic.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_auto_config.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_buf_filter.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_buf_pool.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_buf.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_cache.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_cert.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_cgo_lib.c
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_cgo_lib.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_clang.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_conf.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_conn.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_djb_hash.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_dyld.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_errno.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_event_engine.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_fastcgi_source.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_fd_event.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_fiber.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_file_event.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_file_name.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_file.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_hash.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_http_parse.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_http_source.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_http.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_job_file.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_job_resolve.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_job.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_list.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_listen_socket.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_log_moderation.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_log.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_lvlhsh.c
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_lvlhsh.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_main_process.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_main.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_malloc.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_mem_map.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_mem_pool_cleanup.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_mem_zone.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_mp.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_murmur_hash.c
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_murmur_hash.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_parse.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_port_hash.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_port_memory_int.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_port_memory.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_port_rpc.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_port.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_process_type.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_process.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_queue.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_random.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_rbtree.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_recvbuf.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_router.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_runtime.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_semaphore.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_sendbuf.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_service.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_signal.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_sockaddr.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_socket.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_sort.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_source.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_spinlock.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_sprintf.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_stream_source.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_string.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_test_build.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_thread_id.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_thread_log.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_thread_pool.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_thread_time.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_thread.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_time.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_timer.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_tls.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_types.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_unicode_lowcase.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_unicode_macosx_lowcase.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_unit_field.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_unit_request.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_unit_response.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_unit_sptr.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_unit_typedefs.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_unit.c
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_unit.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_unix.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_upstream_source.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_upstream.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_utf8.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_vector.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nxt_work_queue.h
%%GO_SRCDIR%%/%%GO_PKGNAME%%/port.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/request.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/response.go