aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-23 09:58:02 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-23 09:58:02 +0000
commit1ce7b4b57c90605d8d24249d286e9c0a694556e0 (patch)
tree2b0c09673a6a4453a33fcaa148ccdde9e0d3c302
parent6948b6bd580041d705a6bf5558548c73880beffe (diff)
downloadports-1ce7b4b57c90605d8d24249d286e9c0a694556e0.tar.gz
ports-1ce7b4b57c90605d8d24249d286e9c0a694556e0.zip
Notes
-rw-r--r--Mk/bsd.gstreamer.mk4
-rw-r--r--audio/Makefile1
-rw-r--r--audio/gstreamer-plugins-opus/Makefile12
-rw-r--r--multimedia/gstreamer-plugins/Makefile.common7
4 files changed, 23 insertions, 1 deletions
diff --git a/Mk/bsd.gstreamer.mk b/Mk/bsd.gstreamer.mk
index 49bb7842a13f..30d09548fab5 100644
--- a/Mk/bsd.gstreamer.mk
+++ b/Mk/bsd.gstreamer.mk
@@ -58,7 +58,7 @@ _USE_GSTREAMER10_ALL= a52dec aalib amrnb amrwbdec annodex bz2 cairo \
ffmpeg flac flite gconf gio gl gme gnomevfs gnonlin \
gsm hal jack jpeg ladspa lame libcaca libmms \
libpng libvisual mm mp3 mpeg2enc mpeg2dec musepack \
- nas neon ogg opencv pango pulse python resindvd schroedinger \
+ nas neon ogg opencv opus pango pulse python resindvd schroedinger \
sdl shout2 sidplay sndfile spc soundtouch soup \
speex taglib theora twolame v4l2 vorbis vdpau \
vp8 wavpack x264 xvid
@@ -136,6 +136,8 @@ neon_DEPENDS= www/gstreamer-plugins-neon
ogg_DEPENDS= audio/gstreamer-plugins-ogg
+opus_DEPENDS= audio/gstreamer-plugins-opus
+
polyp_DEPENDS= audio/gstreamer-plugins-polyp
pulse_DEPENDS= audio/gstreamer-plugins-pulse
diff --git a/audio/Makefile b/audio/Makefile
index 2c6b1105f619..97924bab5c02 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -278,6 +278,7 @@
SUBDIR += gstreamer-plugins-mp3
SUBDIR += gstreamer-plugins-musepack
SUBDIR += gstreamer-plugins-nas
+ SUBDIR += gstreamer-plugins-opus
SUBDIR += gstreamer-plugins-ogg
SUBDIR += gstreamer-plugins-pulse
SUBDIR += gstreamer-plugins-shout2
diff --git a/audio/gstreamer-plugins-opus/Makefile b/audio/gstreamer-plugins-opus/Makefile
new file mode 100644
index 000000000000..0f1b8f1bc72b
--- /dev/null
+++ b/audio/gstreamer-plugins-opus/Makefile
@@ -0,0 +1,12 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+CATEGORIES= audio
+
+COMMENT= Gstreamer Opus audio encoder/decoder plugin
+
+GST_PLUGIN= opus
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
+
+.include "${MASTERDIR}/Makefile"
diff --git a/multimedia/gstreamer-plugins/Makefile.common b/multimedia/gstreamer-plugins/Makefile.common
index a11f1c040d3f..0e4bc979b5f2 100644
--- a/multimedia/gstreamer-plugins/Makefile.common
+++ b/multimedia/gstreamer-plugins/Makefile.common
@@ -50,6 +50,7 @@ BAD_GST_ALL_PLUGINS+= \
neon \
ofa \
opencv \
+ opus \
resindvd \
rsvg \
schro \
@@ -432,6 +433,12 @@ gst_opencv_PLIST_FILES= ${GST_LIB_DIR}/libgstopencv.la \
${GST_LIB_DIR}/libgstopencv.so
gst_opencv_DIST= bad
+# opus
+gst_opus_LIB_DEPENDS+= opus:${PORTSDIR}/audio/opus
+gst_opus_PLIST_FILES= ${GST_LIB_DIR}/libgstopus.la \
+ ${GST_LIB_DIR}/libgstopus.so
+gst_opus_DIST= bad
+
# pango
gst_pango_USE_GNOME+= pango
gst_pango_PLIST_FILES= ${GST_LIB_DIR}/libgstpango.la \