aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Li <vishwin@FreeBSD.org>2021-08-04 23:21:43 +0000
committerCharlie Li <vishwin@FreeBSD.org>2021-08-05 13:53:06 +0000
commit281f1a9ecf55b0c06a3b0778768874b7e4810f50 (patch)
treeba3cb3a0c69bfde8ab4f3c95569fac2490544073
parenta80af4f5e21c9baba8e63eb9fdf79d2c818b4fbc (diff)
downloadports-281f1a9ecf55b0c06a3b0778768874b7e4810f50.tar.gz
ports-281f1a9ecf55b0c06a3b0778768874b7e4810f50.zip
-rw-r--r--deskutils/gucharmap/Makefile41
-rw-r--r--deskutils/gucharmap/distinfo6
-rw-r--r--deskutils/gucharmap/files/patch-gucharmap_gucharmap-unicode-info.h14
-rw-r--r--deskutils/gucharmap/pkg-plist160
4 files changed, 118 insertions, 103 deletions
diff --git a/deskutils/gucharmap/Makefile b/deskutils/gucharmap/Makefile
index 872552d12b8d..3e7b22b93767 100644
--- a/deskutils/gucharmap/Makefile
+++ b/deskutils/gucharmap/Makefile
@@ -1,11 +1,10 @@
# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
PORTNAME= gucharmap
-PORTVERSION= 11.0.1
-PORTREVISION= 1
+PORTVERSION= 13.0.8
CATEGORIES= deskutils gnome
#MASTER_SITES= GNOME
-DIST_SUBDIR= gnome3
+DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
COMMENT= Unicode/ISO10646 character map and font viewer
@@ -15,29 +14,31 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= itstool:textproc/itstool \
UCD>=0:textproc/UCD \
- gtkdocize:textproc/gtk-doc \
- ${LOCALBASE}/share/aclocal/yelp.m4:textproc/yelp-tools
-LIB_DEPENDS+= libfreetype.so:print/freetype2
-
-PORTSCOUT= limitw:1,even
-
-USES= autoreconf:build desktop-file-utils gettext gmake gnome \
- libtool localbase pathfix pkgconfig tar:xz
-USE_GNOME= cairo gdkpixbuf2 gtk30 intltool introspection:build
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-unicode-data=${LOCALBASE}/share/unicode/ucd/
+ ${LOCALBASE}/share/aclocal/yelp.m4:textproc/yelp-tools \
+ vala>=0.16:lang/vala
+LIB_DEPENDS= libfreetype.so:print/freetype2
+
+USES= desktop-file-utils gettext-tools gnome localbase meson perl5 pkgconfig \
+ python:build tar:xz
+USE_GNOME= cairo glib20 gtk30 introspection:build
+USE_PERL5= build
+BINARY_ALIAS= python3=${PYTHON_CMD}
USE_LDCONFIG= yes
-INSTALL_TARGET= install-strip
+MESON_ARGS= -Ducd_path=${LOCALBASE}/share/unicode/ucd/
USE_GITLAB= yes
GL_SITE= https://gitlab.gnome.org
GL_ACCOUNT= GNOME
-GL_COMMIT= 061cf7c0ba4ce62d2ce5743313a71cb272a5f82e
+GL_COMMIT= cdbc989f552833ea4ac0f8fefd095ebf6d61333e
+
+GLIB_SCHEMAS= org.gnome.Charmap.gschema.xml
+
+PORTSCOUT= limitw:1,even
-GLIB_SCHEMAS= org.gnome.Charmap.enums.xml \
- org.gnome.Charmap.gschema.xml
+OPTIONS_DEFINE= DOCS
+OPTIONS_SUB= yes
-pre-configure:
- cd ${WRKSRC} && NOCONFIGURE=1 ./autogen.sh
+DOCS_BUILD_DEPENDS= gtkdocize:textproc/gtk-doc
+DOCS_MESON_TRUE= docs
.include <bsd.port.mk>
diff --git a/deskutils/gucharmap/distinfo b/deskutils/gucharmap/distinfo
index 91a55c55ef20..03536448e099 100644
--- a/deskutils/gucharmap/distinfo
+++ b/deskutils/gucharmap/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1617884558
-SHA256 (gnome3/GNOME-gucharmap-061cf7c0ba4ce62d2ce5743313a71cb272a5f82e_GL0.tar.gz) = bfbd39f3fbd5e4953eacac58e8cb6c1028aacee2f38b90904f130db45bc6dbe1
-SIZE (gnome3/GNOME-gucharmap-061cf7c0ba4ce62d2ce5743313a71cb272a5f82e_GL0.tar.gz) = 1978009
+TIMESTAMP = 1628096622
+SHA256 (gnome/GNOME-gucharmap-cdbc989f552833ea4ac0f8fefd095ebf6d61333e_GL0.tar.gz) = f77ae327cea7a87887c938dd6205e383fb3749a6e477f5a87326cd2e1603dbb8
+SIZE (gnome/GNOME-gucharmap-cdbc989f552833ea4ac0f8fefd095ebf6d61333e_GL0.tar.gz) = 1923217
diff --git a/deskutils/gucharmap/files/patch-gucharmap_gucharmap-unicode-info.h b/deskutils/gucharmap/files/patch-gucharmap_gucharmap-unicode-info.h
deleted file mode 100644
index 34750401b534..000000000000
--- a/deskutils/gucharmap/files/patch-gucharmap_gucharmap-unicode-info.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- gucharmap/gucharmap-unicode-info.h.orig 2018-06-17 14:45:00 UTC
-+++ gucharmap/gucharmap-unicode-info.h
-@@ -50,7 +50,10 @@ typedef enum {
- GUCHARMAP_UNICODE_VERSION_9_0,
- GUCHARMAP_UNICODE_VERSION_10_0,
- GUCHARMAP_UNICODE_VERSION_11_0,
-- GUCHARMAP_UNICODE_VERSION_LATEST = GUCHARMAP_UNICODE_VERSION_11_0 /* private, will move forward with each revision */
-+ GUCHARMAP_UNICODE_VERSION_12_0,
-+ GUCHARMAP_UNICODE_VERSION_12_1,
-+ GUCHARMAP_UNICODE_VERSION_13_0,
-+ GUCHARMAP_UNICODE_VERSION_LATEST = GUCHARMAP_UNICODE_VERSION_12_1 /* private, will move forward with each revision */
- } GucharmapUnicodeVersion;
-
- /* return values are read-only */
diff --git a/deskutils/gucharmap/pkg-plist b/deskutils/gucharmap/pkg-plist
index 67f92d0f4dde..47ba339259dd 100644
--- a/deskutils/gucharmap/pkg-plist
+++ b/deskutils/gucharmap/pkg-plist
@@ -1,5 +1,3 @@
-bin/charmap
-bin/gnome-character-map
bin/gucharmap
include/gucharmap-2.90/gucharmap/gucharmap-block-chapters-model.h
include/gucharmap-2.90/gucharmap/gucharmap-block-codepoint-list.h
@@ -8,10 +6,12 @@ include/gucharmap-2.90/gucharmap/gucharmap-chapters-view.h
include/gucharmap-2.90/gucharmap/gucharmap-charmap.h
include/gucharmap-2.90/gucharmap/gucharmap-chartable.h
include/gucharmap-2.90/gucharmap/gucharmap-codepoint-list.h
+include/gucharmap-2.90/gucharmap/gucharmap-macros.h
include/gucharmap-2.90/gucharmap/gucharmap-script-chapters-model.h
include/gucharmap-2.90/gucharmap/gucharmap-script-codepoint-list.h
include/gucharmap-2.90/gucharmap/gucharmap-type-builtins.h
include/gucharmap-2.90/gucharmap/gucharmap-unicode-info.h
+include/gucharmap-2.90/gucharmap/gucharmap-version.h
include/gucharmap-2.90/gucharmap/gucharmap.h
lib/girepository-1.0/Gucharmap-2.90.typelib
lib/libgucharmap_2_90.so
@@ -20,62 +20,95 @@ lib/libgucharmap_2_90.so.7.0.0
libdata/pkgconfig/gucharmap-2.90.pc
share/applications/gucharmap.desktop
share/gir-1.0/Gucharmap-2.90.gir
-share/help/C/gucharmap/figures/gucharmap_window.png
-share/help/C/gucharmap/index.docbook
-share/help/C/gucharmap/legal.xml
-share/help/bg/gucharmap/figures/gucharmap_window.png
-share/help/bg/gucharmap/index.docbook
-share/help/bg/gucharmap/legal.xml
-share/help/ca/gucharmap/index.docbook
-share/help/ca/gucharmap/legal.xml
-share/help/cs/gucharmap/figures/gucharmap_window.png
-share/help/cs/gucharmap/index.docbook
-share/help/cs/gucharmap/legal.xml
-share/help/de/gucharmap/figures/gucharmap_window.png
-share/help/de/gucharmap/index.docbook
-share/help/de/gucharmap/legal.xml
-share/help/el/gucharmap/figures/gucharmap_window.png
-share/help/el/gucharmap/index.docbook
-share/help/el/gucharmap/legal.xml
-share/help/en_GB/gucharmap/index.docbook
-share/help/en_GB/gucharmap/legal.xml
-share/help/es/gucharmap/figures/gucharmap_window.png
-share/help/es/gucharmap/index.docbook
-share/help/es/gucharmap/legal.xml
-share/help/fi/gucharmap/figures/gucharmap_window.png
-share/help/fi/gucharmap/index.docbook
-share/help/fi/gucharmap/legal.xml
-share/help/fr/gucharmap/figures/gucharmap_window.png
-share/help/fr/gucharmap/index.docbook
-share/help/fr/gucharmap/legal.xml
-share/help/gl/gucharmap/index.docbook
-share/help/gl/gucharmap/legal.xml
-share/help/hu/gucharmap/figures/gucharmap_window.png
-share/help/hu/gucharmap/index.docbook
-share/help/hu/gucharmap/legal.xml
-share/help/ko/gucharmap/figures/gucharmap_window.png
-share/help/ko/gucharmap/index.docbook
-share/help/ko/gucharmap/legal.xml
-share/help/oc/gucharmap/index.docbook
-share/help/oc/gucharmap/legal.xml
-share/help/pl/gucharmap/figures/gucharmap_window.png
-share/help/pl/gucharmap/index.docbook
-share/help/pl/gucharmap/legal.xml
-share/help/pt_BR/gucharmap/figures/gucharmap_window.png
-share/help/pt_BR/gucharmap/index.docbook
-share/help/pt_BR/gucharmap/legal.xml
-share/help/ru/gucharmap/index.docbook
-share/help/ru/gucharmap/legal.xml
-share/help/sl/gucharmap/index.docbook
-share/help/sl/gucharmap/legal.xml
-share/help/sv/gucharmap/figures/gucharmap_window.png
-share/help/sv/gucharmap/index.docbook
-share/help/sv/gucharmap/legal.xml
-share/help/vi/gucharmap/index.docbook
-share/help/vi/gucharmap/legal.xml
-share/help/zh_CN/gucharmap/figures/gucharmap_window.png
-share/help/zh_CN/gucharmap/index.docbook
-share/help/zh_CN/gucharmap/legal.xml
+%%DOCS%%share/gtk-doc/html/gucharmap-2.90/GucharmapBlockChaptersModel.html
+%%DOCS%%share/gtk-doc/html/gucharmap-2.90/GucharmapCodepointList.html
+%%DOCS%%share/gtk-doc/html/gucharmap-2.90/GucharmapScriptChaptersModel.html
+%%DOCS%%share/gtk-doc/html/gucharmap-2.90/ch01.html
+%%DOCS%%share/gtk-doc/html/gucharmap-2.90/gucharmap-2.90.devhelp2
+%%DOCS%%share/gtk-doc/html/gucharmap-2.90/gucharmap-gucharmap-chapters-model.html
+%%DOCS%%share/gtk-doc/html/gucharmap-2.90/gucharmap-gucharmap-chapters-view.html
+%%DOCS%%share/gtk-doc/html/gucharmap-2.90/gucharmap-gucharmap-charmap.html
+%%DOCS%%share/gtk-doc/html/gucharmap-2.90/gucharmap-gucharmap-chartable.html
+%%DOCS%%share/gtk-doc/html/gucharmap-2.90/gucharmap-gucharmap-script-codepoint-list.html
+%%DOCS%%share/gtk-doc/html/gucharmap-2.90/gucharmap-gucharmap-unicode-info.html
+%%DOCS%%share/gtk-doc/html/gucharmap-2.90/home.png
+%%DOCS%%share/gtk-doc/html/gucharmap-2.90/index.html
+%%DOCS%%share/gtk-doc/html/gucharmap-2.90/left-insensitive.png
+%%DOCS%%share/gtk-doc/html/gucharmap-2.90/left.png
+%%DOCS%%share/gtk-doc/html/gucharmap-2.90/right-insensitive.png
+%%DOCS%%share/gtk-doc/html/gucharmap-2.90/right.png
+%%DOCS%%share/gtk-doc/html/gucharmap-2.90/style.css
+%%DOCS%%share/gtk-doc/html/gucharmap-2.90/up-insensitive.png
+%%DOCS%%share/gtk-doc/html/gucharmap-2.90/up.png
+%%DOCS%%share/help/C/gucharmap/figures/gucharmap_window.png
+%%DOCS%%share/help/C/gucharmap/index.docbook
+%%DOCS%%share/help/C/gucharmap/legal.xml
+%%DOCS%%share/help/bg/gucharmap/figures/gucharmap_window.png
+%%DOCS%%share/help/bg/gucharmap/index.docbook
+%%DOCS%%share/help/bg/gucharmap/legal.xml
+%%DOCS%%share/help/ca/gucharmap/figures/gucharmap_window.png
+%%DOCS%%share/help/ca/gucharmap/index.docbook
+%%DOCS%%share/help/ca/gucharmap/legal.xml
+%%DOCS%%share/help/cs/gucharmap/figures/gucharmap_window.png
+%%DOCS%%share/help/cs/gucharmap/index.docbook
+%%DOCS%%share/help/cs/gucharmap/legal.xml
+%%DOCS%%share/help/de/gucharmap/figures/gucharmap_window.png
+%%DOCS%%share/help/de/gucharmap/index.docbook
+%%DOCS%%share/help/de/gucharmap/legal.xml
+%%DOCS%%share/help/el/gucharmap/figures/gucharmap_window.png
+%%DOCS%%share/help/el/gucharmap/index.docbook
+%%DOCS%%share/help/el/gucharmap/legal.xml
+%%DOCS%%share/help/en_GB/gucharmap/figures/gucharmap_window.png
+%%DOCS%%share/help/en_GB/gucharmap/index.docbook
+%%DOCS%%share/help/en_GB/gucharmap/legal.xml
+%%DOCS%%share/help/es/gucharmap/figures/gucharmap_window.png
+%%DOCS%%share/help/es/gucharmap/index.docbook
+%%DOCS%%share/help/es/gucharmap/legal.xml
+%%DOCS%%share/help/fi/gucharmap/figures/gucharmap_window.png
+%%DOCS%%share/help/fi/gucharmap/index.docbook
+%%DOCS%%share/help/fi/gucharmap/legal.xml
+%%DOCS%%share/help/fr/gucharmap/figures/gucharmap_window.png
+%%DOCS%%share/help/fr/gucharmap/index.docbook
+%%DOCS%%share/help/fr/gucharmap/legal.xml
+%%DOCS%%share/help/gl/gucharmap/figures/gucharmap_window.png
+%%DOCS%%share/help/gl/gucharmap/index.docbook
+%%DOCS%%share/help/gl/gucharmap/legal.xml
+%%DOCS%%share/help/hu/gucharmap/figures/gucharmap_window.png
+%%DOCS%%share/help/hu/gucharmap/index.docbook
+%%DOCS%%share/help/hu/gucharmap/legal.xml
+%%DOCS%%share/help/id/gucharmap/figures/gucharmap_window.png
+%%DOCS%%share/help/id/gucharmap/index.docbook
+%%DOCS%%share/help/id/gucharmap/legal.xml
+%%DOCS%%share/help/ko/gucharmap/figures/gucharmap_window.png
+%%DOCS%%share/help/ko/gucharmap/index.docbook
+%%DOCS%%share/help/ko/gucharmap/legal.xml
+%%DOCS%%share/help/oc/gucharmap/figures/gucharmap_window.png
+%%DOCS%%share/help/oc/gucharmap/index.docbook
+%%DOCS%%share/help/oc/gucharmap/legal.xml
+%%DOCS%%share/help/pl/gucharmap/figures/gucharmap_window.png
+%%DOCS%%share/help/pl/gucharmap/index.docbook
+%%DOCS%%share/help/pl/gucharmap/legal.xml
+%%DOCS%%share/help/pt_BR/gucharmap/figures/gucharmap_window.png
+%%DOCS%%share/help/pt_BR/gucharmap/index.docbook
+%%DOCS%%share/help/pt_BR/gucharmap/legal.xml
+%%DOCS%%share/help/ru/gucharmap/figures/gucharmap_window.png
+%%DOCS%%share/help/ru/gucharmap/index.docbook
+%%DOCS%%share/help/ru/gucharmap/legal.xml
+%%DOCS%%share/help/sl/gucharmap/figures/gucharmap_window.png
+%%DOCS%%share/help/sl/gucharmap/index.docbook
+%%DOCS%%share/help/sl/gucharmap/legal.xml
+%%DOCS%%share/help/sv/gucharmap/figures/gucharmap_window.png
+%%DOCS%%share/help/sv/gucharmap/index.docbook
+%%DOCS%%share/help/sv/gucharmap/legal.xml
+%%DOCS%%share/help/uk/gucharmap/figures/gucharmap_window.png
+%%DOCS%%share/help/uk/gucharmap/index.docbook
+%%DOCS%%share/help/uk/gucharmap/legal.xml
+%%DOCS%%share/help/vi/gucharmap/figures/gucharmap_window.png
+%%DOCS%%share/help/vi/gucharmap/index.docbook
+%%DOCS%%share/help/vi/gucharmap/legal.xml
+%%DOCS%%share/help/zh_CN/gucharmap/figures/gucharmap_window.png
+%%DOCS%%share/help/zh_CN/gucharmap/index.docbook
+%%DOCS%%share/help/zh_CN/gucharmap/legal.xml
share/locale/af/LC_MESSAGES/gucharmap.mo
share/locale/am/LC_MESSAGES/gucharmap.mo
share/locale/ar/LC_MESSAGES/gucharmap.mo
@@ -164,11 +197,6 @@ share/locale/xh/LC_MESSAGES/gucharmap.mo
share/locale/zh_CN/LC_MESSAGES/gucharmap.mo
share/locale/zh_HK/LC_MESSAGES/gucharmap.mo
share/locale/zh_TW/LC_MESSAGES/gucharmap.mo
-share/metainfo/gucharmap.appdata.xml
-@dir share/help/ca/gucharmap/figures
-@dir share/help/en_GB/gucharmap/figures
-@dir share/help/gl/gucharmap/figures
-@dir share/help/oc/gucharmap/figures
-@dir share/help/ru/gucharmap/figures
-@dir share/help/sl/gucharmap/figures
-@dir share/help/vi/gucharmap/figures
+share/metainfo/gucharmap.metainfo.xml
+share/vala/vapi/gucharmap-2.90.deps
+share/vala/vapi/gucharmap-2.90.vapi