aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2011-09-23 21:22:57 +0000
committerShaun Amott <shaun@FreeBSD.org>2011-09-23 21:22:57 +0000
commit4da8483850c32462b796bb400f467b4039a393cb (patch)
treedb02c4cd84456d2b0896ab03c6c2076bb490ea05
parentf0318868a460b55d36d9718e7c872b60181e8bf9 (diff)
downloadports-4da8483850c32462b796bb400f467b4039a393cb.tar.gz
ports-4da8483850c32462b796bb400f467b4039a393cb.zip
Notes
-rw-r--r--net-p2p/bitcoin/Makefile14
-rw-r--r--net-p2p/bitcoin/distinfo4
2 files changed, 12 insertions, 6 deletions
diff --git a/net-p2p/bitcoin/Makefile b/net-p2p/bitcoin/Makefile
index e142e224b0d8..cc970c8a92b4 100644
--- a/net-p2p/bitcoin/Makefile
+++ b/net-p2p/bitcoin/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bitcoin
-PORTVERSION= 0.3.24
+PORTVERSION= 0.4.0
CATEGORIES= net-p2p finance
MASTER_SITES= https://nodeload.github.com/${PORTNAME}/${PORTNAME}/tarball/ \
http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/
@@ -30,9 +30,11 @@ CXXFLAGS+= -I${LOCALBASE}/include -I${BDB_INCLUDE_DIR}
CXXFLAGS+= -L${LOCALBASE}/lib -L${BDB_LIB_DIR}
CXXFLAGS+= -Wno-invalid-offsetof
-WRKSRC= ${WRKDIR}/bitcoin-bitcoin-36aa6bd/src
+WRKSRC= ${WRKDIR}/bitcoin-bitcoin-72274ed/src
-LOCALES= cs de eo es fr it lt nl pt ru sv zh_cn
+DIST_SUBDIR= ${PORTNAME}
+
+LOCALES= cs de eo es fr it lt nl pt ro ru sv zh_cn
.include <bsd.port.options.mk>
@@ -69,6 +71,10 @@ PLIST_DIRSTRY+= ${LOCALES:C|^|share/locale/|}
.include <bsd.port.pre.mk>
post-patch:
+ @${CP} ${WRKSRC}/protocol.h ${WRKSRC}/protocol.h.orig
+ @${AWK} 'BEGIN { f = 0 } { if ( $$0 ~ /^#include/ && f == 0 ) { f = 1; print "#include <sys/socket.h>"; print "#include <netinet/in.h>" }; print }' \
+ ${WRKSRC}/protocol.h.orig > ${WRKSRC}/protocol.h
+
@cd ${WRKSRC} && ${CP} -p makefile.unix Makefile
@${REINPLACE_CMD} \
-e 's|wx-config|${WX_CONFIG}|g' \
@@ -85,7 +91,7 @@ do-install:
.if !defined(WITHOUT_NLS)
. for lo in ${LOCALES}
- ${MKDIR} -p ${PREFIX}/share/locale/${lo}/LC_MESSAGES
+ @${MKDIR} ${PREFIX}/share/locale/${lo}/LC_MESSAGES
${INSTALL_DATA} ${WRKSRC}/../locale/${lo}/LC_MESSAGES/bitcoin.mo \
${PREFIX}/share/locale/${lo}/LC_MESSAGES/
. endfor
diff --git a/net-p2p/bitcoin/distinfo b/net-p2p/bitcoin/distinfo
index 40b8477ad83e..6a839f4d4abe 100644
--- a/net-p2p/bitcoin/distinfo
+++ b/net-p2p/bitcoin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (v0.3.24) = 8e10a6293af79dc62bed9b68ce764495da8192766473980c8fefeac067831d30
-SIZE (v0.3.24) = 730076
+SHA256 (bitcoin/v0.4.0) = 4feb67c2191ae3c7ebfbcd2fbc98bfdb01242a63f9d9158f5a75482542f02d11
+SIZE (bitcoin/v0.4.0) = 896167