aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-09-24 16:26:10 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-09-24 16:26:10 +0000
commit52fec7c3ae808ccc8f0fa28ce53daf5d8588cf90 (patch)
treee429db3a3a61726286c758d66ba7512686a7a065
parent6e3acb8cb9f4fc42c8b83cf30aa3cb13eccc9bc1 (diff)
downloadports-52fec7c3ae808ccc8f0fa28ce53daf5d8588cf90.tar.gz
ports-52fec7c3ae808ccc8f0fa28ce53daf5d8588cf90.zip
Notes
-rw-r--r--misc/40upgrade/Makefile41
-rw-r--r--misc/40upgrade/pkg-comment1
-rw-r--r--misc/40upgrade/pkg-descr5
-rw-r--r--misc/40upgrade/pkg-install5
-rw-r--r--misc/40upgrade/pkg-plist9
-rw-r--r--misc/40upgrade/pkg-req5
-rw-r--r--misc/41upgrade/Makefile39
-rw-r--r--misc/41upgrade/pkg-comment1
-rw-r--r--misc/41upgrade/pkg-descr5
-rw-r--r--misc/41upgrade/pkg-install5
-rw-r--r--misc/41upgrade/pkg-plist6
-rw-r--r--misc/41upgrade/pkg-req5
-rw-r--r--misc/42upgrade/Makefile38
-rw-r--r--misc/42upgrade/pkg-comment1
-rw-r--r--misc/42upgrade/pkg-descr5
-rw-r--r--misc/42upgrade/pkg-install5
-rw-r--r--misc/42upgrade/pkg-plist1
-rw-r--r--misc/42upgrade/pkg-req5
-rw-r--r--misc/Makefile3
19 files changed, 0 insertions, 185 deletions
diff --git a/misc/40upgrade/Makefile b/misc/40upgrade/Makefile
deleted file mode 100644
index 3ccdbe2eefcd..000000000000
--- a/misc/40upgrade/Makefile
+++ /dev/null
@@ -1,41 +0,0 @@
-# New ports collection makefile for: 4.0R to 4-stable upgrade kit
-# Date created: 11 Jul 2000
-# Whom: asami
-#
-# $FreeBSD$
-#
-
-PORTNAME= 40upgrade
-PORTVERSION= 2000.11.01
-CATEGORIES= misc
-DISTFILES= # empty
-
-MAINTAINER= asami@FreeBSD.org
-
-FORBIDDEN= something wrong with shared library
-
-.include <bsd.port.pre.mk>
-
-.if !defined(PACKAGE_BUILDING)
-BROKEN= this \"port\" is for building packages for distribution only, please get the package from http://www.freebsd.org/ports/ if you need an upgrade
-.elif ${OSVERSION} < 400020 || ${OSVERSION} >= 500000
-FORBIDDEN= this needs to be built on a recent 4-stable system
-.endif
-NO_MTREE= yes
-PREFIX= /
-NO_BUILD= yes
-PKGINSTALL= ${WRKDIR}/INSTALL
-DATE!= cat /var/db/port.mkversion
-MAN1= pkg_add.1 pkg_create.1 pkg_delete.1 pkg_info.1 pkg_version.1
-MANPREFIX= ${PREFIX}usr/share
-MANCOMPRESSED= maybe
-
-do-install:
- ${SED} -e "s/%%VERSION%%/${DATE}/" ${PKGDIR}/pkg-install \
- > ${PKGINSTALL}
-
-deinstall:
- @${ECHO} "You can't delete this port."
- @${FALSE}
-
-.include <bsd.port.post.mk>
diff --git a/misc/40upgrade/pkg-comment b/misc/40upgrade/pkg-comment
deleted file mode 100644
index 1c1809963bb3..000000000000
--- a/misc/40upgrade/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-A convenience package to upgrade your 4.0 system to 4-stable for ports
diff --git a/misc/40upgrade/pkg-descr b/misc/40upgrade/pkg-descr
deleted file mode 100644
index 547db524e0f2..000000000000
--- a/misc/40upgrade/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-This package will allow you to upgrade your 4.0R system to
-4-stable, so you can compile and use all ports in ports-current.
-
-Satoshi
-asami@freebsd.org
diff --git a/misc/40upgrade/pkg-install b/misc/40upgrade/pkg-install
deleted file mode 100644
index 8ed8de67d62f..000000000000
--- a/misc/40upgrade/pkg-install
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-if [ "$2" != "PRE-INSTALL" ]; then
- exit 0
-fi
-echo %%VERSION%% > /var/db/port.mkversion
diff --git a/misc/40upgrade/pkg-plist b/misc/40upgrade/pkg-plist
deleted file mode 100644
index 0fa4e01da206..000000000000
--- a/misc/40upgrade/pkg-plist
+++ /dev/null
@@ -1,9 +0,0 @@
-etc/mtree/BSD.x11-4.dist
-usr/lib/libc.so.4
-usr/lib/libxpg4.so
-usr/lib/libxpg4.so.3
-usr/sbin/pkg_add
-usr/sbin/pkg_create
-usr/sbin/pkg_delete
-usr/sbin/pkg_info
-usr/sbin/pkg_version
diff --git a/misc/40upgrade/pkg-req b/misc/40upgrade/pkg-req
deleted file mode 100644
index 1eb81c651314..000000000000
--- a/misc/40upgrade/pkg-req
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-if [ $2 = "DEINSTALL" ]; then
- echo "Package $1 cannot be removed -- to do so will render your system useless."
- exit 1
-fi
diff --git a/misc/41upgrade/Makefile b/misc/41upgrade/Makefile
deleted file mode 100644
index 07401da331df..000000000000
--- a/misc/41upgrade/Makefile
+++ /dev/null
@@ -1,39 +0,0 @@
-# New ports collection makefile for: 4.1R to 4-stable upgrade kit
-# Date created: 25 Aug 2000
-# Whom: asami
-#
-# $FreeBSD$
-#
-
-PORTNAME= 41upgrade
-PORTVERSION= 2000.11.01
-CATEGORIES= misc
-DISTFILES= # empty
-
-MAINTAINER= asami@FreeBSD.org
-
-.include <bsd.port.pre.mk>
-
-.if !defined(PACKAGE_BUILDING)
-BROKEN= this \"port\" is for building packages for distribution only, please get the package from http://www.freebsd.org/ports/ if you need an upgrade
-.elif ${OSVERSION} < 410000 || ${OSVERSION} >= 500000
-FORBIDDEN= this needs to be built on a recent 4-stable system
-.endif
-NO_MTREE= yes
-PREFIX= /
-NO_BUILD= yes
-PKGINSTALL= ${WRKDIR}/INSTALL
-DATE!= cat /var/db/port.mkversion
-MAN1= pkg_add.1 pkg_create.1 pkg_delete.1 pkg_info.1 pkg_version.1
-MANPREFIX= ${PREFIX}usr/share
-MANCOMPRESSED= maybe
-
-do-install:
- ${SED} -e "s/%%VERSION%%/${DATE}/" ${PKGDIR}/pkg-install \
- > ${PKGINSTALL}
-
-deinstall:
- @${ECHO} "You can't delete this port."
- @${FALSE}
-
-.include <bsd.port.post.mk>
diff --git a/misc/41upgrade/pkg-comment b/misc/41upgrade/pkg-comment
deleted file mode 100644
index abd495e9a42d..000000000000
--- a/misc/41upgrade/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-A convenience package to upgrade your 4.1 system to 4-stable for ports
diff --git a/misc/41upgrade/pkg-descr b/misc/41upgrade/pkg-descr
deleted file mode 100644
index d9cf2f28873f..000000000000
--- a/misc/41upgrade/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-This package will allow you to upgrade your 4.1R system to
-4-stable, so you can compile and use all ports in ports-current.
-
-Satoshi
-asami@freebsd.org
diff --git a/misc/41upgrade/pkg-install b/misc/41upgrade/pkg-install
deleted file mode 100644
index 8ed8de67d62f..000000000000
--- a/misc/41upgrade/pkg-install
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-if [ "$2" != "PRE-INSTALL" ]; then
- exit 0
-fi
-echo %%VERSION%% > /var/db/port.mkversion
diff --git a/misc/41upgrade/pkg-plist b/misc/41upgrade/pkg-plist
deleted file mode 100644
index 399a56d4bb1e..000000000000
--- a/misc/41upgrade/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-etc/mtree/BSD.x11-4.dist
-usr/sbin/pkg_add
-usr/sbin/pkg_create
-usr/sbin/pkg_delete
-usr/sbin/pkg_info
-usr/sbin/pkg_version
diff --git a/misc/41upgrade/pkg-req b/misc/41upgrade/pkg-req
deleted file mode 100644
index 1eb81c651314..000000000000
--- a/misc/41upgrade/pkg-req
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-if [ $2 = "DEINSTALL" ]; then
- echo "Package $1 cannot be removed -- to do so will render your system useless."
- exit 1
-fi
diff --git a/misc/42upgrade/Makefile b/misc/42upgrade/Makefile
deleted file mode 100644
index 8c50e194aaab..000000000000
--- a/misc/42upgrade/Makefile
+++ /dev/null
@@ -1,38 +0,0 @@
-# New ports collection makefile for: 4.2R to 4-stable upgrade kit
-# Date created: 5 Feb 2000
-# Whom: asami
-#
-# $FreeBSD$
-#
-
-PORTNAME= 42upgrade
-PORTVERSION= 2000.02.05
-CATEGORIES= misc
-DISTFILES= # empty
-
-MAINTAINER= asami@FreeBSD.org
-
-.include <bsd.port.pre.mk>
-
-.if !defined(PACKAGE_BUILDING)
-BROKEN= this \"port\" is for building packages for distribution only, please get the package from http://www.freebsd.org/ports/ if you need an upgrade
-.elif ${OSVERSION} < 420000 || ${OSVERSION} >= 500000
-FORBIDDEN= this needs to be built on a recent 4-stable system
-.endif
-NO_MTREE= yes
-PREFIX= /
-NO_BUILD= yes
-PKGINSTALL= ${WRKDIR}/INSTALL
-DATE!= cat /var/db/port.mkversion
-MANPREFIX= ${PREFIX}usr/share
-MANCOMPRESSED= maybe
-
-do-install:
- ${SED} -e "s/%%VERSION%%/${DATE}/" ${PKGDIR}/pkg-install \
- > ${PKGINSTALL}
-
-deinstall:
- @${ECHO} "You can't delete this port."
- @${FALSE}
-
-.include <bsd.port.post.mk>
diff --git a/misc/42upgrade/pkg-comment b/misc/42upgrade/pkg-comment
deleted file mode 100644
index 5a0910774753..000000000000
--- a/misc/42upgrade/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-A convenience package to upgrade your 4.2 system to 4-stable for ports
diff --git a/misc/42upgrade/pkg-descr b/misc/42upgrade/pkg-descr
deleted file mode 100644
index 7b5dcb97fc6c..000000000000
--- a/misc/42upgrade/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-This package will allow you to upgrade your 4.2R system to
-4-stable, so you can compile and use all ports in ports-current.
-
-Satoshi
-asami@freebsd.org
diff --git a/misc/42upgrade/pkg-install b/misc/42upgrade/pkg-install
deleted file mode 100644
index 8ed8de67d62f..000000000000
--- a/misc/42upgrade/pkg-install
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-if [ "$2" != "PRE-INSTALL" ]; then
- exit 0
-fi
-echo %%VERSION%% > /var/db/port.mkversion
diff --git a/misc/42upgrade/pkg-plist b/misc/42upgrade/pkg-plist
deleted file mode 100644
index 549a621fec0c..000000000000
--- a/misc/42upgrade/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-@comment this plist intentionally left empty
diff --git a/misc/42upgrade/pkg-req b/misc/42upgrade/pkg-req
deleted file mode 100644
index 1eb81c651314..000000000000
--- a/misc/42upgrade/pkg-req
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-if [ $2 = "DEINSTALL" ]; then
- echo "Package $1 cannot be removed -- to do so will render your system useless."
- exit 1
-fi
diff --git a/misc/Makefile b/misc/Makefile
index 9badeb51f7d2..bcacd2887d90 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -1,9 +1,6 @@
# $FreeBSD$
#
- SUBDIR += 40upgrade
- SUBDIR += 41upgrade
- SUBDIR += 42upgrade
SUBDIR += 44bsd-more
SUBDIR += GeoIP
SUBDIR += Howto