aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJochen Neumeister <joneum@FreeBSD.org>2018-01-27 12:57:23 +0000
committerJochen Neumeister <joneum@FreeBSD.org>2018-01-27 12:57:23 +0000
commit796275081d66b4e2613900cd3b97297384170593 (patch)
tree5e47085939ec9a6c53ff41b54587cb4f1771483a
parentecf05a768ec4de86cc065d5feb66c8320abb0438 (diff)
downloadports-796275081d66b4e2613900cd3b97297384170593.tar.gz
ports-796275081d66b4e2613900cd3b97297384170593.zip
Notes
-rw-r--r--www/nginx/Makefile6
-rw-r--r--www/nginx/distinfo6
-rw-r--r--www/nginx/files/extra-patch-masterzen-nginx-upload-progress-module9
3 files changed, 15 insertions, 6 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 049b2c403142..919c85b40880 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nginx
PORTVERSION= 1.12.2
-PORTREVISION?= 6
+PORTREVISION?= 7
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
@@ -729,10 +729,10 @@ CONFIGURE_ARGS+=--add-module=${WRKSRC_upload}
.endif
.if ${PORT_OPTIONS:MHTTP_UPLOAD_PROGRESS}
-NGINX_UPLOADPROGRESS_VERSION= 0.9.2
+NGINX_UPLOADPROGRESS_VERSION= afb2d31
GH_ACCOUNT+= masterzen:uploadprogress
GH_PROJECT+= nginx-upload-progress-module:uploadprogress
-GH_TAGNAME+= v${NGINX_UPLOADPROGRESS_VERSION}:uploadprogress
+GH_TAGNAME+= ${NGINX_UPLOADPROGRESS_VERSION}:uploadprogress
CONFIGURE_ARGS+=--add-module=${WRKSRC_uploadprogress}
.endif
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index 5f8c3ad6a356..a03d01a30bbd 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1516812661
+TIMESTAMP = 1517046240
SHA256 (nginx-1.12.2.tar.gz) = 305f379da1d5fb5aefa79e45c829852ca6983c7cd2a79328f8e084a324cf0416
SIZE (nginx-1.12.2.tar.gz) = 981687
SHA256 (ngx_cache_purge-2.3.tar.gz) = 279e0d8a46d3b1521fd43b3f78bc1c08b263899142a7cc5058c1c0361a92c89c
@@ -67,8 +67,8 @@ SHA256 (tarantool-nginx_upstream_module-1278ee5_GH0.tar.gz) = 34d51afcd464582e60
SIZE (tarantool-nginx_upstream_module-1278ee5_GH0.tar.gz) = 48378
SHA256 (Austinb-nginx-upload-module-72ec037_GH0.tar.gz) = c6d4e38ad0712c898cc53721f492f8f73acf2753cc0a0769fa34d4d6ba4e8efd
SIZE (Austinb-nginx-upload-module-72ec037_GH0.tar.gz) = 28303
-SHA256 (masterzen-nginx-upload-progress-module-v0.9.2_GH0.tar.gz) = b286689355442657650421d8e8398bd4abf9dbbaade65947bb0cb74a349cc497
-SIZE (masterzen-nginx-upload-progress-module-v0.9.2_GH0.tar.gz) = 17268
+SHA256 (masterzen-nginx-upload-progress-module-afb2d31_GH0.tar.gz) = 6318851cc3a624aaad3b1f4cd9f51f79c86575c53dfe0c28bbdcf9470b6a33e6
+SIZE (masterzen-nginx-upload-progress-module-afb2d31_GH0.tar.gz) = 17269
SHA256 (yaoweibin-nginx_upstream_check_module-9aecf15_GH0.tar.gz) = 4404c64e845e19feeb07a37976347987892a8e8680a961f793ff0d3ef96c07f4
SIZE (yaoweibin-nginx_upstream_check_module-9aecf15_GH0.tar.gz) = 130039
SHA256 (cryptofuture-nginx-upstream-fair-b5be36f_GH0.tar.gz) = e765afcaab6cd1601e914039a8d00ab18eb6fe01180c58e0e4e098bc5b4d8233
diff --git a/www/nginx/files/extra-patch-masterzen-nginx-upload-progress-module b/www/nginx/files/extra-patch-masterzen-nginx-upload-progress-module
new file mode 100644
index 000000000000..63f85c699a9b
--- /dev/null
+++ b/www/nginx/files/extra-patch-masterzen-nginx-upload-progress-module
@@ -0,0 +1,9 @@
+--- work/nginx-upload-progress-module-0.9.2/config.orig 2018-01-27 09:47:26.335521000 +0100
++++ work/nginx-upload-progress-module-0.9.2/config 2018-01-27 09:47:53.763756000 +0100
+@@ -1,5 +1,5 @@
+ ngx_addon_name=ngx_http_uploadprogress_module
+-if test -n "$ngx_module_link"; then
++if [ $ngx_module_link = DYNAMIC ] ; then
+ ngx_module_type=FILTER
+ ngx_module_name=ngx_http_uploadprogress_module
+ ngx_module_srcs="$ngx_addon_dir/ngx_http_uploadprogress_module.c"