aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2012-12-19 07:55:02 +0000
committerMarcus von Appen <mva@FreeBSD.org>2012-12-19 07:55:02 +0000
commitaad29da8b1dc7ac04bba7b3fe091f0d71d5cc304 (patch)
treed4ef3bd0a29f867e8de5032b2eafab44eb998632
parent6fcea49c92878fa60e73c38bd043c8ae2b2c00e5 (diff)
downloadports-aad29da8b1dc7ac04bba7b3fe091f0d71d5cc304.tar.gz
ports-aad29da8b1dc7ac04bba7b3fe091f0d71d5cc304.zip
Notes
-rw-r--r--audio/openal-soft/Makefile9
-rw-r--r--audio/openal-soft/distinfo4
-rw-r--r--audio/openal-soft/files/patch-Alc_backends_oss.c11
-rw-r--r--audio/openal-soft/pkg-plist4
4 files changed, 9 insertions, 19 deletions
diff --git a/audio/openal-soft/Makefile b/audio/openal-soft/Makefile
index 666cc469e8ae..5baf37a8a8d6 100644
--- a/audio/openal-soft/Makefile
+++ b/audio/openal-soft/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= openal-soft
-PORTVERSION= 1.14
-PORTREVISION= 1
+PORTVERSION= 1.15.1
CATEGORIES= audio
MASTER_SITES= http://kcat.strangesoft.net/openal-releases/
@@ -15,7 +14,9 @@ USE_BZIP2= yes
USE_CMAKE= yes
USE_LDCONFIG= yes
CMAKE_ARGS+= -DALSA:BOOL=OFF -DPORTAUDIO:BOOL=OFF -DSOLARIS:BOOL=OFF \
- -DDSOUND:BOOL=OFF -DALSOFT_CONFIG:BOOL=ON -DEXAMPLES:BOOL=OFF
+ -DDSOUND:BOOL=OFF -DSNDIO:BOOL=OFF -DEXAMPLES:BOOL=OFF \
+ -DMMDEVAPI:BOOL=OFF -DWINMM:BOOL=OFF -DCOREAUDIO:BOOL=OFF \
+ -DOPENSL:BOOL=OFF -DALSOFT_CONFIG:BOOL=ON
OPTIONS_DEFINE= PULSEAUDIO
PULSEAUDIO_DESC= Enable sound streaming using PulseAudio
@@ -35,7 +36,7 @@ post-patch:
@${REINPLACE_CMD} 's|/etc/openal|${ETCDIR}|' \
${WRKSRC}/Alc/alcConfig.c \
${WRKSRC}/CMakeLists.txt
- @${REINPLACE_CMD} 's|alsoft.conf|alsoft.conf.sample|' \
+ @${REINPLACE_CMD} 's|share/openal|${ETCDIR}|' \
${WRKSRC}/CMakeLists.txt
.include <bsd.port.mk>
diff --git a/audio/openal-soft/distinfo b/audio/openal-soft/distinfo
index 665e7094963f..cef8647a881b 100644
--- a/audio/openal-soft/distinfo
+++ b/audio/openal-soft/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openal-soft-1.14.tar.bz2) = 87bd8d61d5943387898c92b6a2bbbb26118e745dec57550c817526a70fad0914
-SIZE (openal-soft-1.14.tar.bz2) = 221579
+SHA256 (openal-soft-1.15.1.tar.bz2) = 0e29a162f0841ccb4135ce76e92e8a704589b680a85eddf76f898de5236eb056
+SIZE (openal-soft-1.15.1.tar.bz2) = 253006
diff --git a/audio/openal-soft/files/patch-Alc_backends_oss.c b/audio/openal-soft/files/patch-Alc_backends_oss.c
deleted file mode 100644
index 20514bf85295..000000000000
--- a/audio/openal-soft/files/patch-Alc_backends_oss.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- Alc/backends/oss.c.orig 2012-03-28 17:55:17.000000000 +0200
-+++ Alc/backends/oss.c 2012-04-22 14:13:19.000000000 +0200
-@@ -511,7 +511,7 @@
- {
- #ifdef HAVE_STAT
- struct stat buf;
-- if(stat(oss_device, &buf) == 0)
-+ if(stat(oss_driver, &buf) == 0)
- #endif
- AppendAllDeviceList(oss_device);
- }
diff --git a/audio/openal-soft/pkg-plist b/audio/openal-soft/pkg-plist
index 3f444f207ecb..2965557d500f 100644
--- a/audio/openal-soft/pkg-plist
+++ b/audio/openal-soft/pkg-plist
@@ -1,13 +1,13 @@
bin/makehrtf
bin/openal-info
-%%ETCDIR%%/alsoft.conf.sample
+%%ETCDIR%%/alsoftrc.sample
include/AL/al.h
include/AL/alc.h
include/AL/alext.h
include/AL/efx.h
include/AL/efx-creative.h
include/AL/efx-presets.h
-lib/libopenal.so.1.14.0
+lib/libopenal.so.1.15.1
lib/libopenal.so.1
lib/libopenal.so
libdata/pkgconfig/openal.pc