aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2019-03-20 16:13:14 +0000
committerMark Felder <feld@FreeBSD.org>2019-03-20 16:13:14 +0000
commitadd1d9c25cab21e09055ed3363d6702ea2e673d7 (patch)
tree79ebfd2010efca175142fa029d4a2b70b803c734
parente9004cc861788195e35202b4260934a863e4c2bc (diff)
downloadports-add1d9c25cab21e09055ed3363d6702ea2e673d7.tar.gz
ports-add1d9c25cab21e09055ed3363d6702ea2e673d7.zip
Notes
-rw-r--r--multimedia/plexmediaserver/Makefile10
-rw-r--r--multimedia/plexmediaserver/distinfo6
-rw-r--r--multimedia/plexmediaserver/files/pkg-message.in43
-rw-r--r--multimedia/plexmediaserver/files/plexmediaserver.in18
4 files changed, 68 insertions, 9 deletions
diff --git a/multimedia/plexmediaserver/Makefile b/multimedia/plexmediaserver/Makefile
index 2508d5a58bc7..5509550fae50 100644
--- a/multimedia/plexmediaserver/Makefile
+++ b/multimedia/plexmediaserver/Makefile
@@ -2,12 +2,12 @@
# $FreeBSD$
PORTNAME= plexmediaserver
-PORTVERSION?= 1.14.1.5488
-DISTVERSIONSUFFIX?=cc260c476
-PORTREVISION?= 1
+PORTVERSION?= 1.15.1.791
+DISTVERSIONSUFFIX?=8bec0f76c
+PORTREVISION?= 0
CATEGORIES= multimedia
-MASTER_SITES?= https://downloads.plex.tv/plex-media-server/${DISTVERSION}-${DISTVERSIONSUFFIX}/
-DISTNAME?= PlexMediaServer-${DISTVERSION}-${DISTVERSIONSUFFIX}-freebsd-${ARCH}
+MASTER_SITES?= https://downloads.plex.tv/plex-media-server-new/${DISTVERSION}-${DISTVERSIONSUFFIX}/freebsd/
+DISTNAME?= PlexMediaServer-${DISTVERSION}-${DISTVERSIONSUFFIX}-FreeBSD-${ARCH}
MAINTAINER?= feld@FreeBSD.org
COMMENT= Plex Media Server component
diff --git a/multimedia/plexmediaserver/distinfo b/multimedia/plexmediaserver/distinfo
index 0fc708e1470d..073e148418ae 100644
--- a/multimedia/plexmediaserver/distinfo
+++ b/multimedia/plexmediaserver/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1545160778
-SHA256 (PlexMediaServer-1.14.1.5488-cc260c476-freebsd-amd64.tar.bz2) = 9a157e1566963bceac6e736d679522b7030cd53ddcbb3b0982a9e0a13cc176f1
-SIZE (PlexMediaServer-1.14.1.5488-cc260c476-freebsd-amd64.tar.bz2) = 90555303
+TIMESTAMP = 1553098065
+SHA256 (PlexMediaServer-1.15.1.791-8bec0f76c-FreeBSD-amd64.tar.bz2) = 37b4e75819b98cdd1ddf6a05193885ed54e76c93fea1a7cb8909e6e655409f20
+SIZE (PlexMediaServer-1.15.1.791-8bec0f76c-FreeBSD-amd64.tar.bz2) = 91986684
diff --git a/multimedia/plexmediaserver/files/pkg-message.in b/multimedia/plexmediaserver/files/pkg-message.in
index 33b96f1a54a0..4ef30fffa444 100644
--- a/multimedia/plexmediaserver/files/pkg-message.in
+++ b/multimedia/plexmediaserver/files/pkg-message.in
@@ -12,4 +12,47 @@ service %%PORTNAME%% start
Once started, visit the following to configure:
http://localhost:32400/web
+@@@ INTEL GPU OFFLOAD NOTES @@@
+
+If you have a supported Intel GPU, you can leverage hardware
+accellerated encoding/decoding in Plex Media Server on FreeBSD 12.0+.
+
+The requirements are as follows:
+
+* Install multimedia/drm-kmod: e.g., pkg install drm-fbsd12.0-kmod
+
+* Enable loading of kernel module on boot: sysrc kld_list+="drm"
+** If Plex will run in a jail, you must load the module outside the jail!
+
+* Load the kernel module now: kldload drm
+
+* Install the supporting Intel VA support library for your GPU
+** multimedia/libva-intel-driver: [LEGACY] Intel GMA 4500 or newer
+** multimedia/libva-intel-media-driver: Intel HD 5000 (Gen8) or newer
+*** This must be installed beside Plex. e.g., in the jail with Plex
+
+* Add plex user to the video group: pw groupmod -n video -m plex
+
+* For jails, make a devfs ruleset to expose /dev/dri/* devices.
+
+e.g., /dev/devfs.rules on the host:
+
+[plex_drm=10]
+add include $devfsrules_hide_all
+add include $devfsrules_unhide_basic
+add include $devfsrules_unhide_login
+add include $devfsrules_jail
+add path 'dri*' unhide
+add path 'dri/*' unhide
+add path 'drm*' unhide
+add path 'drm/*' unhide
+
+* Enable the devfs ruleset for your jail. e.g., devfs_ruleset=10 in your
+/etc/jail.conf or for iocage, iocage set devfs_ruleset="10"
+
+Please refer to documentation for all other FreeBSD jail management
+utilities.
+
+@@@ INTEL GPU OFFLOAD NOTES @@@
+
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
diff --git a/multimedia/plexmediaserver/files/plexmediaserver.in b/multimedia/plexmediaserver/files/plexmediaserver.in
index ac2547ac8093..2a80fdbf69f9 100644
--- a/multimedia/plexmediaserver/files/plexmediaserver.in
+++ b/multimedia/plexmediaserver/files/plexmediaserver.in
@@ -40,11 +40,23 @@ stop_postcmd=plex_stop_postcmd
plex_precmd()
{
+ #Set identification variables for FreeNAS; with fallback to FreeBSD
+ if [ -f "/etc/version" ]; then
+ export PLEX_MEDIA_SERVER_INFO_VENDOR="$(cat /etc/version|cut -d- -f1)"
+ export PLEX_MEDIA_SERVER_INFO_DEVICE=NAS
+ export PLEX_MEDIA_SERVER_INFO_MODEL="$(uname -m)"
+ export PLEX_MEDIA_SERVER_INFO_PLATFORM_VERSION="$(cat /etc/version|cut -d- -f2-)"
+ else
+ export PLEX_MEDIA_SERVER_INFO_VENDOR=FreeBSD
+ export PLEX_MEDIA_SERVER_INFO_DEVICE=PC
+ export PLEX_MEDIA_SERVER_INFO_MODEL="$(uname -m)"
+ export PLEX_MEDIA_SERVER_INFO_PLATFORM_VERSION="$(uname -r)"
+ fi
export SUPPORT_PATH="${%%PORTNAME%%_support_path}"
export HOME="${%%PORTNAME%%_support_path}/Plex Media Server"
export PYTHONHOME="%%DATADIR%%/Resources/Python"
export SCRIPTPATH="%%DATADIR%%"
- export LD_LIBRARY_PATH="%%PREFIX%%/lib/compat:${SCRIPTPATH}"
+ export LD_LIBRARY_PATH="${SCRIPTPATH}/lib"
export PLEX_MEDIA_SERVER_HOME="${SCRIPTPATH}"
export PLEX_MEDIA_SERVER_MAX_PLUGIN_PROCS=${%%PORTNAME%%_maxplugins}
export PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR=${%%PORTNAME%%_support_path}
@@ -62,6 +74,10 @@ plex_precmd()
if [ ! -d "${%%PORTNAME%%_support_path}/Plex Media Server" ]; then
install -d -g ${%%PORTNAME%%_group} -o ${%%PORTNAME%%_user} "${%%PORTNAME%%_support_path}/Plex Media Server";
fi
+
+ if [ ! -d "${%%PORTNAME%%_support_path}/Plex" ]; then
+ install -d -g ${%%PORTNAME%%_group} -o ${%%PORTNAME%%_user} "${%%PORTNAME%%_support_path}/Plex";
+ fi
if [ ${%%PORTNAME%%_tmp} ]; then
export TMPDIR=${%%PORTNAME%%_tmp};