aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-03-11 08:44:52 +0000
committerWen Heping <wen@FreeBSD.org>2011-03-11 08:44:52 +0000
commitb3d21674ab150fd0333b28858479d32c451b1f59 (patch)
tree41d3b67cb974d830c0b21aec524d0847f2b3fe63
parent7510a395cc8c3cdd67bf9f2a183e5e545b9f25d1 (diff)
downloadports-b3d21674ab150fd0333b28858479d32c451b1f59.tar.gz
ports-b3d21674ab150fd0333b28858479d32c451b1f59.zip
Notes
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-ODF-lpOD/Makefile33
-rw-r--r--textproc/p5-ODF-lpOD/distinfo2
-rw-r--r--textproc/p5-ODF-lpOD/pkg-descr7
-rw-r--r--textproc/p5-ODF-lpOD/pkg-plist32
5 files changed, 75 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 29f4e93a8ac0..843825813fe4 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -544,6 +544,7 @@
SUBDIR += p5-NetAddr-IP-Find
SUBDIR += p5-Number-Format
SUBDIR += p5-Number-Spell
+ SUBDIR += p5-ODF-lpOD
SUBDIR += p5-OpenOffice-OODoc
SUBDIR += p5-PDF-API2
SUBDIR += p5-PDF-API3
diff --git a/textproc/p5-ODF-lpOD/Makefile b/textproc/p5-ODF-lpOD/Makefile
new file mode 100644
index 000000000000..b9e965c1a4ca
--- /dev/null
+++ b/textproc/p5-ODF-lpOD/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-ODF-lpOD
+# Date created: March 11, 2011
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ODF-lpOD
+PORTVERSION= 1.110
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:JMGDOC
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= An OpenDocument management interface
+
+RUN_DEPENDS= p5-Archive-Zip>=1.30:${PORTSDIR}/archivers/p5-Archive-Zip \
+ p5-XML-Twig>=3.34:${PORTSDIR}/textproc/p5-XML-Twig
+
+PERL_CONFIGURE= yes
+
+MAN3= ODF::lpOD.3 \
+ ODF::lpOD::Common.3 \
+ ODF::lpOD::Document.3 \
+ ODF::lpOD::Element.3 \
+ ODF::lpOD::StructuredContainer.3 \
+ ODF::lpOD::Style.3 \
+ ODF::lpOD::Table.3 \
+ ODF::lpOD::TextElement.3 \
+ ODF::lpOD::Tutorial.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-ODF-lpOD/distinfo b/textproc/p5-ODF-lpOD/distinfo
new file mode 100644
index 000000000000..355313b2fd85
--- /dev/null
+++ b/textproc/p5-ODF-lpOD/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ODF-lpOD-1.110.tar.gz) = d1d526d399083281f2db161324c53e77d217c474cfb94d217ea73980cca9a666
+SIZE (ODF-lpOD-1.110.tar.gz) = 230957
diff --git a/textproc/p5-ODF-lpOD/pkg-descr b/textproc/p5-ODF-lpOD/pkg-descr
new file mode 100644
index 000000000000..a015a1b689a3
--- /dev/null
+++ b/textproc/p5-ODF-lpOD/pkg-descr
@@ -0,0 +1,7 @@
+ODF::lpOD is an Open Document management interface. It allows the users to
+create or transform office documents, or to extract data from them. It can
+handle documents which comply with the Open Document Format international
+standard (ODF). It may handle text documents (ODT), spreadsheet documents(ODS),
+as well as presentation(ODP) or drawing documents (ODG).
+
+WWW: http://search.cpan.org/dist/ODF-lpOD/
diff --git a/textproc/p5-ODF-lpOD/pkg-plist b/textproc/p5-ODF-lpOD/pkg-plist
new file mode 100644
index 000000000000..874d1bf50f74
--- /dev/null
+++ b/textproc/p5-ODF-lpOD/pkg-plist
@@ -0,0 +1,32 @@
+%%SITE_PERL%%/ODF/lpOD/data/rgb.txt
+%%SITE_PERL%%/ODF/lpOD/data/oasis_odf_logo.png
+%%SITE_PERL%%/ODF/lpOD/templates/spreadsheet.ods
+%%SITE_PERL%%/ODF/lpOD/templates/text.odt
+%%SITE_PERL%%/ODF/lpOD/templates/presentation.odp
+%%SITE_PERL%%/ODF/lpOD/templates/drawing.odg
+%%SITE_PERL%%/ODF/lpOD/Element.pm
+%%SITE_PERL%%/ODF/lpOD/Style.pod
+%%SITE_PERL%%/ODF/lpOD/Table.pod
+%%SITE_PERL%%/ODF/lpOD/Style.pm
+%%SITE_PERL%%/ODF/lpOD/Attributes.pm
+%%SITE_PERL%%/ODF/lpOD/TextElement.pm
+%%SITE_PERL%%/ODF/lpOD/TextElement.pod
+%%SITE_PERL%%/ODF/lpOD/Document.pod
+%%SITE_PERL%%/ODF/lpOD/Common.pm
+%%SITE_PERL%%/ODF/lpOD/Element.pod
+%%SITE_PERL%%/ODF/lpOD/Field.pm
+%%SITE_PERL%%/ODF/lpOD/Table.pm
+%%SITE_PERL%%/ODF/lpOD/Document.pm
+%%SITE_PERL%%/ODF/lpOD/StructuredContainer.pod
+%%SITE_PERL%%/ODF/lpOD/Common.pod
+%%SITE_PERL%%/ODF/lpOD/StructuredContainer.pm
+%%SITE_PERL%%/ODF/lpOD/Tutorial.pod
+%%SITE_PERL%%/ODF/lpOD.pod
+%%SITE_PERL%%/ODF/lpOD.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/ODF/lpOD/.packlist
+@dirrm %%SITE_PERL%%/ODF/lpOD/templates
+@dirrm %%SITE_PERL%%/ODF/lpOD/data
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/ODF/lpOD
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/ODF
+@dirrmtry %%SITE_PERL%%/ODF/lpOD
+@dirrmtry %%SITE_PERL%%/ODF