aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2014-07-13 16:09:00 +0000
committerThomas Zander <riggs@FreeBSD.org>2014-07-13 16:09:00 +0000
commitb592464e2e066d3f7af1459ed1ce3dfc3c92526f (patch)
treebed0a0422543699ab91364b492979260c3232bfd
parentc667d5ea1f073b2ebe694362059496bd31ff57d8 (diff)
downloadports-b592464e2e066d3f7af1459ed1ce3dfc3c92526f.tar.gz
ports-b592464e2e066d3f7af1459ed1ce3dfc3c92526f.zip
Notes
-rw-r--r--MOVED1
-rw-r--r--graphics/py-stl/Makefile56
-rw-r--r--graphics/py-stl/distinfo2
-rw-r--r--graphics/py-stl/pkg-plist10
-rw-r--r--graphics/py-stltools/Makefile44
-rw-r--r--graphics/py-stltools/distinfo2
-rw-r--r--graphics/py-stltools/pkg-descr (renamed from graphics/py-stl/pkg-descr)12
-rw-r--r--graphics/py-stltools/pkg-plist33
8 files changed, 86 insertions, 74 deletions
diff --git a/MOVED b/MOVED
index adbc64c7024f..f27fb5710d03 100644
--- a/MOVED
+++ b/MOVED
@@ -6250,3 +6250,4 @@ textproc/stardict-OxfordCollocation||2014-07-10|Removed due to possible copyrigh
textproc/stardict-longman||2014-07-10|Removed due to possible copyright infringement
textproc/stardict-oald||2014-07-10|Removed due to possible copyright infringement
editors/nxml||2014-07-13|Needs recently removed emacs21 or emacs22
+graphics/py-stl|graphics/py-stltools|2014-07-13|Upstream project has been renamed
diff --git a/graphics/py-stl/Makefile b/graphics/py-stl/Makefile
deleted file mode 100644
index 4d8d0a35f81f..000000000000
--- a/graphics/py-stl/Makefile
+++ /dev/null
@@ -1,56 +0,0 @@
-# Created by: Roland Smith <rsmith@xs4all.nl>
-# $FreeBSD$
-
-PORTNAME= stl
-PORTVERSION= 3.1
-CATEGORIES= graphics python
-MASTER_SITES= http://rsmith.home.xs4all.nl/software/
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= py-${PORTNAME}-${PORTVERSION}
-
-MAINTAINER= rsmith@xs4all.nl
-COMMENT= Converts STL models to POV-Ray meshes or PostScript/PDF images
-
-LICENSE= BSD
-
-# bypass infrastructure bug
-OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
-
-USES= zip
-USE_PYTHON= yes
-USE_PYDISTUTILS= YES
-PYDISTUTILS_EGGINFO= py_stl-${PORTVERSION}-py${PYTHON_VER}.egg-info
-
-CONFLICTS= stl2pov-[0-9]*
-
-MAN1= stl2ps.1 stlinfo.1 stl2pov.1
-
-OPTIONS_DEFINE= PYCAIRO
-PYCAIRO_DESC= Use (py)Cairo to enable stl2pdf
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-STL_SCRIPTS= stl2pov stl2ps stlinfo
-
-.if ${PORT_OPTIONS:MPYCAIRO}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}cairo>1.8:${PORTSDIR}/graphics/py-cairo
-MAN1+= stl2pdf.1
-PLIST_SUB= STL2PDF=""
-STL_SCRIPTS+= stl2pdf
-.else
-PLIST_SUB= STL2PDF="@comment "
-.endif
-
-NO_BUILD= YES
-
-post-install:
-.if empty(PORT_OPTIONS:MPYCAIRO)
- @${RM} -f ${PREFIX}/bin/stl2pdf.py
-.endif
-.for s in ${STL_SCRIPTS}
- ${INSTALL_MAN} ${WRKSRC}/${s}.1 ${MANPREFIX}/man/man1
- @${MV} ${PREFIX}/bin/${s}.py ${PREFIX}/bin/${s}
-.endfor
-
-.include <bsd.port.mk>
diff --git a/graphics/py-stl/distinfo b/graphics/py-stl/distinfo
deleted file mode 100644
index bbc24adfd142..000000000000
--- a/graphics/py-stl/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (py-stl-3.1.zip) = d5a2eccbd627d05b28d3b6d619202d3a55b4d94dbf21a63b68109688ebc8e929
-SIZE (py-stl-3.1.zip) = 115488
diff --git a/graphics/py-stl/pkg-plist b/graphics/py-stl/pkg-plist
deleted file mode 100644
index d28cb76238b3..000000000000
--- a/graphics/py-stl/pkg-plist
+++ /dev/null
@@ -1,10 +0,0 @@
-%%PYTHON_SITELIBDIR%%/stl.py
-%%PYTHON_SITELIBDIR%%/stl.pyc
-%%PYTHON_SITELIBDIR%%/stl.pyo
-%%PYTHON_SITELIBDIR%%/xform.py
-%%PYTHON_SITELIBDIR%%/xform.pyc
-%%PYTHON_SITELIBDIR%%/xform.pyo
-%%STL2PDF%%bin/stl2pdf
-bin/stl2pov
-bin/stl2ps
-bin/stlinfo
diff --git a/graphics/py-stltools/Makefile b/graphics/py-stltools/Makefile
new file mode 100644
index 000000000000..8da6f9fc9082
--- /dev/null
+++ b/graphics/py-stltools/Makefile
@@ -0,0 +1,44 @@
+# Created by: R.F. Smith <rsmith@xs4all.nl>
+# $FreeBSD$
+
+PORTNAME= stltools
+PORTVERSION= 3.2
+CATEGORIES= graphics python
+MASTER_SITES= http://rsmith.home.xs4all.nl/files/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rsmith@xs4all.nl
+COMMENT= Converts STL models to POV-Ray meshes or PostScript/PDF images
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= ${PYNUMPY}
+
+USES= zip
+USE_PYTHON= YES
+PYTHON_VERSION= python2.7
+USE_PYDISTUTILS= YES
+
+DOCS= README.txt
+EXAMPLES= test/cube.stl test/cube_bin.stl
+
+OPTIONS_DEFINE= PYCAIRO
+PYCAIRO_DESC= Use (py)Cairo to enable stl2pdf to function.
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MPYCAIRO}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}cairo>1.8:${PORTSDIR}/graphics/py-cairo
+.endif
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for i in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
+.endfor
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+.for i in ${EXAMPLES}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${EXAMPLESDIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/graphics/py-stltools/distinfo b/graphics/py-stltools/distinfo
new file mode 100644
index 000000000000..3f9998e5d84b
--- /dev/null
+++ b/graphics/py-stltools/distinfo
@@ -0,0 +1,2 @@
+SHA256 (stltools-3.2.zip) = 535322dd2b48f7d21c149f230aa8fffecbd15707958b0ee67438737dd73c0105
+SIZE (stltools-3.2.zip) = 24266
diff --git a/graphics/py-stl/pkg-descr b/graphics/py-stltools/pkg-descr
index 325be5ca76d4..d9e737ca98e6 100644
--- a/graphics/py-stl/pkg-descr
+++ b/graphics/py-stltools/pkg-descr
@@ -1,11 +1,11 @@
-The python modules stl.py and xform.py are for reading, creating and
-transforming STL (STereoLithography) files. These modules are used by the
-following scripts:
+The modules in the stltools package can read and write STL files, perform 3D
+coordinate transforms and projections. These modules are used by the following
+provided scripts;
stl2pov: Converts the STL model to a mesh usable with the POV-ray raytracer.
stl2ps: Creates a view of the STL model in scalable PostScript.
-stl2pdf: Creates a view of the STL model as a PDF. Requires graphics/py-cairo
-sltinfo: Either displays some information about a STL file or prints it in
-text format.
+stl2pdf: Creates a view of the STL model as a PDF. Requires graphics/py-cairo.
+stlinfo: Either displays some information about a STL file or prints it in
+ text format.
WWW: http://rsmith.home.xs4all.nl/software/py-stl-stl2pov.html
diff --git a/graphics/py-stltools/pkg-plist b/graphics/py-stltools/pkg-plist
new file mode 100644
index 000000000000..b5bd9e460db3
--- /dev/null
+++ b/graphics/py-stltools/pkg-plist
@@ -0,0 +1,33 @@
+bin/stl2pdf
+bin/stl2pov
+bin/stl2ps
+bin/stlinfo
+%%PYTHON_SITELIBDIR%%/stltools-3.2-py2.7.egg-info/PKG-INFO
+%%PYTHON_SITELIBDIR%%/stltools-3.2-py2.7.egg-info/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/stltools-3.2-py2.7.egg-info/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/stltools-3.2-py2.7.egg-info/top_level.txt
+%%PYTHON_SITELIBDIR%%/stltools/__init__.py
+%%PYTHON_SITELIBDIR%%/stltools/__init__.pyc
+%%PYTHON_SITELIBDIR%%/stltools/__init__.pyo
+%%PYTHON_SITELIBDIR%%/stltools/bbox.py
+%%PYTHON_SITELIBDIR%%/stltools/bbox.pyc
+%%PYTHON_SITELIBDIR%%/stltools/bbox.pyo
+%%PYTHON_SITELIBDIR%%/stltools/matrix.py
+%%PYTHON_SITELIBDIR%%/stltools/matrix.pyc
+%%PYTHON_SITELIBDIR%%/stltools/matrix.pyo
+%%PYTHON_SITELIBDIR%%/stltools/stl.py
+%%PYTHON_SITELIBDIR%%/stltools/stl.pyc
+%%PYTHON_SITELIBDIR%%/stltools/stl.pyo
+%%PYTHON_SITELIBDIR%%/stltools/utils.py
+%%PYTHON_SITELIBDIR%%/stltools/utils.pyc
+%%PYTHON_SITELIBDIR%%/stltools/utils.pyo
+%%PYTHON_SITELIBDIR%%/stltools/vecops.py
+%%PYTHON_SITELIBDIR%%/stltools/vecops.pyc
+%%PYTHON_SITELIBDIR%%/stltools/vecops.pyo
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cube.stl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cube_bin.stl
+@dirrm %%PYTHON_SITELIBDIR%%/stltools
+@dirrm %%PYTHON_SITELIBDIR%%/stltools-3.2-py2.7.egg-info
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%