aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2009-11-22 19:26:33 +0000
committerDoug Barton <dougb@FreeBSD.org>2009-11-22 19:26:33 +0000
commite9cf7164b93e5dbdb7bef22c3dc3980161a34dad (patch)
tree0695525adffd038b8556fae5a562a75df2807d8b
parentf94646a276ad78504b88cf605f4c2a12daffa08d (diff)
downloadports-e9cf7164b93e5dbdb7bef22c3dc3980161a34dad.tar.gz
ports-e9cf7164b93e5dbdb7bef22c3dc3980161a34dad.zip
Notes
-rw-r--r--net-p2p/libtorrent-rasterbar-14/Makefile2
-rw-r--r--net-p2p/libtorrent-rasterbar-14/distinfo6
-rw-r--r--net-p2p/libtorrent-rasterbar-14/files/patch-src__storage.cpp16
-rw-r--r--net-p2p/rblibtorrent-devel/Makefile2
-rw-r--r--net-p2p/rblibtorrent-devel/distinfo6
-rw-r--r--net-p2p/rblibtorrent-devel/files/patch-src__storage.cpp16
6 files changed, 26 insertions, 22 deletions
diff --git a/net-p2p/libtorrent-rasterbar-14/Makefile b/net-p2p/libtorrent-rasterbar-14/Makefile
index 8e65f92a18c8..22aba2e77cec 100644
--- a/net-p2p/libtorrent-rasterbar-14/Makefile
+++ b/net-p2p/libtorrent-rasterbar-14/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libtorrent
-PORTVERSION= 0.14.6
+PORTVERSION= 0.14.7
CATEGORIES= net-p2p
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
PKGNAMEPREFIX= rb
diff --git a/net-p2p/libtorrent-rasterbar-14/distinfo b/net-p2p/libtorrent-rasterbar-14/distinfo
index afa3b649b0f6..4c6cac07b2e1 100644
--- a/net-p2p/libtorrent-rasterbar-14/distinfo
+++ b/net-p2p/libtorrent-rasterbar-14/distinfo
@@ -1,3 +1,3 @@
-MD5 (libtorrent-rasterbar-0.14.6.tar.gz) = 1b5b91a5d0abb8cefef9f4195738e621
-SHA256 (libtorrent-rasterbar-0.14.6.tar.gz) = 98540fe765163e6f22d53462694aee4e4213606179974470ebe1d8adc02b5f56
-SIZE (libtorrent-rasterbar-0.14.6.tar.gz) = 1995813
+MD5 (libtorrent-rasterbar-0.14.7.tar.gz) = 6959f719245d82758235fd73d93373b2
+SHA256 (libtorrent-rasterbar-0.14.7.tar.gz) = 1ff89795c8433dfd9ba94d45f21048abcb73cf9f8b56eff9bdf34b5e3b41694b
+SIZE (libtorrent-rasterbar-0.14.7.tar.gz) = 1938654
diff --git a/net-p2p/libtorrent-rasterbar-14/files/patch-src__storage.cpp b/net-p2p/libtorrent-rasterbar-14/files/patch-src__storage.cpp
index 700b77976501..3bc14260d622 100644
--- a/net-p2p/libtorrent-rasterbar-14/files/patch-src__storage.cpp
+++ b/net-p2p/libtorrent-rasterbar-14/files/patch-src__storage.cpp
@@ -1,5 +1,5 @@
---- src/storage.cpp.orig 2009-04-13 02:37:54.000000000 +0900
-+++ src/storage.cpp 2009-04-29 15:56:16.000000000 +0900
+--- src/storage.cpp.orig 2009-11-06 09:45:13.000000000 -0800
++++ src/storage.cpp 2009-11-21 23:12:53.000000000 -0800
@@ -53,7 +53,7 @@
#include <boost/multi_index_container.hpp>
#include <boost/multi_index/member.hpp>
@@ -28,7 +28,7 @@
}
#endif // BOOST_VERSION
#endif // BOOST_NO_EXCEPTIONS
-@@ -458,17 +458,17 @@
+@@ -460,17 +460,17 @@
}
#ifndef BOOST_NO_EXCEPTIONS
}
@@ -49,7 +49,7 @@
return true;
}
#endif // BOOST_VERSION
-@@ -501,16 +501,16 @@
+@@ -503,16 +503,16 @@
#endif
#ifndef BOOST_NO_EXCEPTIONS
}
@@ -69,7 +69,7 @@
return false;
}
#endif // BOOST_VERSION
-@@ -558,17 +558,17 @@
+@@ -560,17 +560,17 @@
m_mapped_files->rename_file(index, new_filename);
#ifndef BOOST_NO_EXCEPTIONS
}
@@ -91,7 +91,7 @@
return true;
}
#endif // BOOST_VERSION
-@@ -591,15 +591,15 @@
+@@ -593,7 +593,7 @@
#endif
{ fs::remove(safe_convert(p)); }
#ifndef BOOST_NO_EXCEPTIONS
@@ -99,7 +99,9 @@
+#if 0 // BOOST_VERSION >= 103500
catch (boost::system::system_error& e)
{
- set_error(p, e.code());
+ // no such file or directory is not an error
+@@ -601,9 +601,9 @@
+ set_error(p, e.code());
}
#else
- catch (boost::filesystem::filesystem_error& e)
diff --git a/net-p2p/rblibtorrent-devel/Makefile b/net-p2p/rblibtorrent-devel/Makefile
index 8e65f92a18c8..22aba2e77cec 100644
--- a/net-p2p/rblibtorrent-devel/Makefile
+++ b/net-p2p/rblibtorrent-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libtorrent
-PORTVERSION= 0.14.6
+PORTVERSION= 0.14.7
CATEGORIES= net-p2p
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
PKGNAMEPREFIX= rb
diff --git a/net-p2p/rblibtorrent-devel/distinfo b/net-p2p/rblibtorrent-devel/distinfo
index afa3b649b0f6..4c6cac07b2e1 100644
--- a/net-p2p/rblibtorrent-devel/distinfo
+++ b/net-p2p/rblibtorrent-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (libtorrent-rasterbar-0.14.6.tar.gz) = 1b5b91a5d0abb8cefef9f4195738e621
-SHA256 (libtorrent-rasterbar-0.14.6.tar.gz) = 98540fe765163e6f22d53462694aee4e4213606179974470ebe1d8adc02b5f56
-SIZE (libtorrent-rasterbar-0.14.6.tar.gz) = 1995813
+MD5 (libtorrent-rasterbar-0.14.7.tar.gz) = 6959f719245d82758235fd73d93373b2
+SHA256 (libtorrent-rasterbar-0.14.7.tar.gz) = 1ff89795c8433dfd9ba94d45f21048abcb73cf9f8b56eff9bdf34b5e3b41694b
+SIZE (libtorrent-rasterbar-0.14.7.tar.gz) = 1938654
diff --git a/net-p2p/rblibtorrent-devel/files/patch-src__storage.cpp b/net-p2p/rblibtorrent-devel/files/patch-src__storage.cpp
index 700b77976501..3bc14260d622 100644
--- a/net-p2p/rblibtorrent-devel/files/patch-src__storage.cpp
+++ b/net-p2p/rblibtorrent-devel/files/patch-src__storage.cpp
@@ -1,5 +1,5 @@
---- src/storage.cpp.orig 2009-04-13 02:37:54.000000000 +0900
-+++ src/storage.cpp 2009-04-29 15:56:16.000000000 +0900
+--- src/storage.cpp.orig 2009-11-06 09:45:13.000000000 -0800
++++ src/storage.cpp 2009-11-21 23:12:53.000000000 -0800
@@ -53,7 +53,7 @@
#include <boost/multi_index_container.hpp>
#include <boost/multi_index/member.hpp>
@@ -28,7 +28,7 @@
}
#endif // BOOST_VERSION
#endif // BOOST_NO_EXCEPTIONS
-@@ -458,17 +458,17 @@
+@@ -460,17 +460,17 @@
}
#ifndef BOOST_NO_EXCEPTIONS
}
@@ -49,7 +49,7 @@
return true;
}
#endif // BOOST_VERSION
-@@ -501,16 +501,16 @@
+@@ -503,16 +503,16 @@
#endif
#ifndef BOOST_NO_EXCEPTIONS
}
@@ -69,7 +69,7 @@
return false;
}
#endif // BOOST_VERSION
-@@ -558,17 +558,17 @@
+@@ -560,17 +560,17 @@
m_mapped_files->rename_file(index, new_filename);
#ifndef BOOST_NO_EXCEPTIONS
}
@@ -91,7 +91,7 @@
return true;
}
#endif // BOOST_VERSION
-@@ -591,15 +591,15 @@
+@@ -593,7 +593,7 @@
#endif
{ fs::remove(safe_convert(p)); }
#ifndef BOOST_NO_EXCEPTIONS
@@ -99,7 +99,9 @@
+#if 0 // BOOST_VERSION >= 103500
catch (boost::system::system_error& e)
{
- set_error(p, e.code());
+ // no such file or directory is not an error
+@@ -601,9 +601,9 @@
+ set_error(p, e.code());
}
#else
- catch (boost::filesystem::filesystem_error& e)