aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2010-11-27 06:01:33 +0000
committerGreg Lewis <glewis@FreeBSD.org>2010-11-27 06:01:33 +0000
commitf40ff1b561a6c66519759754338bc5220ba9582d (patch)
tree53abd2011810311a518708c802f73864cbac475e
parentbe03d28886a687418b2143487bb123d34ef0c361 (diff)
downloadports-f40ff1b561a6c66519759754338bc5220ba9582d.tar.gz
ports-f40ff1b561a6c66519759754338bc5220ba9582d.zip
Notes
-rw-r--r--mail/Makefile1
-rw-r--r--mail/dovecot2-pigeonhole/Makefile60
-rw-r--r--mail/dovecot2-pigeonhole/distinfo3
-rw-r--r--mail/dovecot2-pigeonhole/pkg-descr7
-rw-r--r--mail/dovecot2-pigeonhole/pkg-message18
-rw-r--r--mail/dovecot2-pigeonhole/pkg-plist71
6 files changed, 160 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index c9c959385b56..9d6cb15f0fc6 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -101,6 +101,7 @@
SUBDIR += dovecot-managesieve
SUBDIR += dovecot-sieve
SUBDIR += dovecot2
+ SUBDIR += dovecot2-pigeonhole
SUBDIR += drac
SUBDIR += drbl
SUBDIR += dsbl-testers
diff --git a/mail/dovecot2-pigeonhole/Makefile b/mail/dovecot2-pigeonhole/Makefile
new file mode 100644
index 000000000000..4fa402785f43
--- /dev/null
+++ b/mail/dovecot2-pigeonhole/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: dovecot-pigeonhole
+# Date created: 2006-12-29
+# Whom: Nils Vogels <nivo+kw+ports.bfa274@is-root.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dovecot-pigeonhole
+PORTVERSION= 0.2.1
+CATEGORIES= mail
+MASTER_SITES= http://www.rename-it.nl/dovecot/${DOVECOTVERSION}/
+DISTNAME= ${PORTNAME:C/-/-${DOVECOTVERSION}-/}-${PORTVERSION}
+
+MAINTAINER= bra@fsn.hu
+COMMENT= A Sieve plugin for the Dovecot 'deliver' LDA and LMTP
+
+RUN_DEPENDS= dovecot>=${DOVECOTVERSION}:${PORTSDIR}/mail/dovecot${DOVECOTVER}
+
+DOVECOTVERSION= 2.0
+DOVECOTVER:= ${DOVECOTVERSION:C/\.[0-9]//}
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --docdir=${DOCSDIR} \
+ --with-dovecot="${LOCALBASE}/lib/dovecot"
+CONFIGURE_ENV= LDFLAGS='${LDFLAGS}'
+LDFLAGS+= -L${LOCALBASE}/lib
+USE_LDCONFIG= ${PREFIX}/lib/dovecot
+
+MAN1= sieve-dump.1 sieve-test.1 sievec.1 sieved.1
+MAN7= pigeonhole.7
+
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:S/-/\//}
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= AUTHORS COPYING COPYING.LGPL INSTALL NEWS README TODO spamtest-virustest.txt
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e '\
+ s!/doc/$${PACKAGE_TARNAME}!/doc/${PORTNAME:S/-/\//}!g;\
+ s!$${docdir}/dovecot/sieve!$${docdir}!g;\
+ ' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -E -e '\
+ /^docfiles = spamtest-virustest.txt$$/D;\
+ /^[[:space:]]+test -z "\$$\(sieve_docdir\)" \|\| \$$\(MKDIR_P\) "\$$\(DESTDIR\)\$$\(sieve_docdir\)"$$/D;\
+ ' ${WRKSRC}/doc/Makefile.in
+ @${LN} -f ${WRKSRC}/doc/spamtest-virustest.txt ${WRKSRC}/
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${INSTALL} ${_SHROWNGRP} -m ${BINMODE} -d ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/dovecot2-pigeonhole/distinfo b/mail/dovecot2-pigeonhole/distinfo
new file mode 100644
index 000000000000..63d2f79a9410
--- /dev/null
+++ b/mail/dovecot2-pigeonhole/distinfo
@@ -0,0 +1,3 @@
+MD5 (dovecot-2.0-pigeonhole-0.2.1.tar.gz) = 7baf6ebac21bdb865cb733d8e96ee81b
+SHA256 (dovecot-2.0-pigeonhole-0.2.1.tar.gz) = 8249421cb69ca299e2830da8b635ca0a5ab692ab29456c188ba8078d7672ccda
+SIZE (dovecot-2.0-pigeonhole-0.2.1.tar.gz) = 1195090
diff --git a/mail/dovecot2-pigeonhole/pkg-descr b/mail/dovecot2-pigeonhole/pkg-descr
new file mode 100644
index 000000000000..4facbff4621a
--- /dev/null
+++ b/mail/dovecot2-pigeonhole/pkg-descr
@@ -0,0 +1,7 @@
+Sieve language support by a plugin for the Dovecot deliver LDA&LMTP
+
+ * Mail filtering
+ * Mail forwarding
+ * Vacation auto-reply
+
+WWW: http://wiki2.dovecot.org/Pigeonhole
diff --git a/mail/dovecot2-pigeonhole/pkg-message b/mail/dovecot2-pigeonhole/pkg-message
new file mode 100644
index 000000000000..50b246a30834
--- /dev/null
+++ b/mail/dovecot2-pigeonhole/pkg-message
@@ -0,0 +1,18 @@
+---------------------------------------------------------------------
+
+ This port assumes you are familiar with Dovecot and have it installed
+ and running on the system you have installed this plugin on.
+
+ You can enable the plugin with this directive in your dovecot.conf:
+
+ protocol lda {
+ # Support for dynamically loadable plugins. mail_plugins is
+ # a space separated list of plugins to load.
+ mail_plugins = sieve # ... other plugins like quota
+ }
+
+ Further information on configuration can be found at:
+
+ http://wiki2.dovecot.org/Pigeonhole
+
+---------------------------------------------------------------------
diff --git a/mail/dovecot2-pigeonhole/pkg-plist b/mail/dovecot2-pigeonhole/pkg-plist
new file mode 100644
index 000000000000..2350ab65ea57
--- /dev/null
+++ b/mail/dovecot2-pigeonhole/pkg-plist
@@ -0,0 +1,71 @@
+bin/sieve-dump
+bin/sieve-test
+bin/sievec
+include/dovecot/sieve/pigeonhole-config.h
+include/dovecot/sieve/rfc2822.h
+include/dovecot/sieve/sieve-actions.h
+include/dovecot/sieve/sieve-address-parts.h
+include/dovecot/sieve/sieve-address.h
+include/dovecot/sieve/sieve-ast.h
+include/dovecot/sieve/sieve-binary-dumper.h
+include/dovecot/sieve/sieve-binary-private.h
+include/dovecot/sieve/sieve-binary.h
+include/dovecot/sieve/sieve-code-dumper.h
+include/dovecot/sieve/sieve-code.h
+include/dovecot/sieve/sieve-commands.h
+include/dovecot/sieve/sieve-common.h
+include/dovecot/sieve/sieve-comparators.h
+include/dovecot/sieve/sieve-config.h
+include/dovecot/sieve/sieve-dump.h
+include/dovecot/sieve/sieve-error-private.h
+include/dovecot/sieve/sieve-error.h
+include/dovecot/sieve/sieve-ext-enotify.h
+include/dovecot/sieve/sieve-ext-environment.h
+include/dovecot/sieve/sieve-ext-variables.h
+include/dovecot/sieve/sieve-extensions.h
+include/dovecot/sieve/sieve-generator.h
+include/dovecot/sieve/sieve-interpreter.h
+include/dovecot/sieve/sieve-lexer.h
+include/dovecot/sieve/sieve-limits.h
+include/dovecot/sieve/sieve-match-types.h
+include/dovecot/sieve/sieve-match.h
+include/dovecot/sieve/sieve-message.h
+include/dovecot/sieve/sieve-objects.h
+include/dovecot/sieve/sieve-parser.h
+include/dovecot/sieve/sieve-plugins.h
+include/dovecot/sieve/sieve-result.h
+include/dovecot/sieve/sieve-runtime-trace.h
+include/dovecot/sieve/sieve-runtime.h
+include/dovecot/sieve/sieve-script-private.h
+include/dovecot/sieve/sieve-script.h
+include/dovecot/sieve/sieve-settings.h
+include/dovecot/sieve/sieve-smtp.h
+include/dovecot/sieve/sieve-stringlist.h
+include/dovecot/sieve/sieve-types.h
+include/dovecot/sieve/sieve-validator.h
+include/dovecot/sieve/sieve.h
+lib/dovecot/lib90_sieve_plugin.a
+lib/dovecot/lib90_sieve_plugin.la
+lib/dovecot/lib90_sieve_plugin.so
+lib/dovecot/libdovecot-sieve.a
+lib/dovecot/libdovecot-sieve.la
+lib/dovecot/libdovecot-sieve.so
+lib/dovecot/libdovecot-sieve.so.0
+lib/dovecot/settings/libmanagesieve_login_settings.a
+lib/dovecot/settings/libmanagesieve_login_settings.la
+lib/dovecot/settings/libmanagesieve_login_settings.so
+lib/dovecot/settings/libmanagesieve_settings.a
+lib/dovecot/settings/libmanagesieve_settings.la
+lib/dovecot/settings/libmanagesieve_settings.so
+libexec/dovecot/managesieve
+libexec/dovecot/managesieve-login
+share/doc/dovecot/example-config/conf.d/20-managesieve.conf
+share/doc/dovecot/example-config/conf.d/90-sieve.conf
+@dirrmtry share/doc/dovecot/example-config/conf.d
+@dirrmtry share/doc/dovecot/example-config
+@dirrmtry share/doc/dovecot
+@dirrmtry libexec/dovecot
+@dirrm lib/dovecot/settings
+@dirrmtry lib/dovecot
+@dirrm include/dovecot/sieve
+@dirrmtry include/dovecot