aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2015-09-07 07:24:55 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2015-09-07 07:24:55 +0000
commit032cc488607d3935061bde31a99b38814aa84971 (patch)
treea586bd692f45b7773f055d74b7c857d1f5455737
parentaa458c166fc192704d36a1677a41021535eaaadb (diff)
downloadports-032cc488607d3935061bde31a99b38814aa84971.tar.gz
ports-032cc488607d3935061bde31a99b38814aa84971.zip
Notes
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/php-mecab/Makefile28
-rw-r--r--textproc/php-mecab/distinfo2
-rw-r--r--textproc/php-mecab/pkg-descr3
4 files changed, 34 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index af3f6becd197..c33c408a31b8 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1149,6 +1149,7 @@
SUBDIR += peco
SUBDIR += perl2html
SUBDIR += permute
+ SUBDIR += php-mecab
SUBDIR += php5-ctype
SUBDIR += php5-dom
SUBDIR += php5-pspell
diff --git a/textproc/php-mecab/Makefile b/textproc/php-mecab/Makefile
new file mode 100644
index 000000000000..b73bbfa0aae9
--- /dev/null
+++ b/textproc/php-mecab/Makefile
@@ -0,0 +1,28 @@
+# Created by: Gasol Wu <gasol.wu@gmail.com>
+# $FreeBSD$
+
+PORTNAME= mecab
+PORTVERSION= 0.5.0.20121209
+CATEGORIES= textproc
+PKGNAMEPREFIX= php-
+
+MAINTAINER= gasol.wu@gmail.com
+COMMENT= PHP bindings of the MeCab
+
+LICENSE= MIT
+
+LIB_DEPENDS= libmecab.so:${PORTSDIR}/japanese/mecab
+
+USE_GITHUB= yes
+GH_ACCOUNT= rsky
+GH_PROJECT= ${PKGNAMEPREFIX}${PORTNAME}
+GH_TAGNAME= 55e6481
+
+WRKSRC= ${WRKDIR}/${GH_PROJECT}-${GH_TAGNAME_EXTRACT}/mecab
+CONFIGURE_ARGS+= --with-mecab=${LOCALBASE}/bin/mecab-config
+USE_PHP= yes
+USE_PHPIZE= yes
+USE_PHPEXT= yes
+USES= tar:tgz
+
+.include <bsd.port.mk>
diff --git a/textproc/php-mecab/distinfo b/textproc/php-mecab/distinfo
new file mode 100644
index 000000000000..d6072f657420
--- /dev/null
+++ b/textproc/php-mecab/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rsky-php-mecab-0.5.0.20121209-55e6481_GH0.tgz) = 927443ae5e407757ba55c88e9b43afb768a31ffee36a131d2ae56bd4907f1240
+SIZE (rsky-php-mecab-0.5.0.20121209-55e6481_GH0.tgz) = 52084
diff --git a/textproc/php-mecab/pkg-descr b/textproc/php-mecab/pkg-descr
new file mode 100644
index 000000000000..0fd01f470b7f
--- /dev/null
+++ b/textproc/php-mecab/pkg-descr
@@ -0,0 +1,3 @@
+MeCab: Yet Another Part-of-Speech and Morphological Analyzer
+
+WWW: https://github.com/rsky/php-mecab