aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2010-08-18 18:12:02 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2010-08-18 18:12:02 +0000
commit0358b4667d1d61f12b832b1a904c4cb36e295182 (patch)
treef5da0bfa9a1516f646930e6a94b1633eb9286d60
parentd065569ad9831e6b542c3be610256e60abe03abe (diff)
downloadports-0358b4667d1d61f12b832b1a904c4cb36e295182.tar.gz
ports-0358b4667d1d61f12b832b1a904c4cb36e295182.zip
Notes
-rw-r--r--devel/Makefile3
-rw-r--r--devel/htable/Makefile27
-rw-r--r--devel/htable/distinfo3
-rw-r--r--devel/htable/pkg-descr6
4 files changed, 38 insertions, 1 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 91c0f54ccdeb..76d5bf7fdf1e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -616,8 +616,8 @@
SUBDIR += hs-split
SUBDIR += hs-terminfo
SUBDIR += hs-test-framework
- SUBDIR += hs-test-framework-quickcheck2
SUBDIR += hs-test-framework-hunit
+ SUBDIR += hs-test-framework-quickcheck2
SUBDIR += hs-testpack
SUBDIR += hs-transformers
SUBDIR += hs-unamb
@@ -631,6 +631,7 @@
SUBDIR += hs-uvector-algorithms
SUBDIR += hs-vector
SUBDIR += hs-vector-algorithms
+ SUBDIR += htable
SUBDIR += hypersrc
SUBDIR += i386-rtems-binutils
SUBDIR += i386-rtems-gcc
diff --git a/devel/htable/Makefile b/devel/htable/Makefile
new file mode 100644
index 000000000000..2557bfb6dea3
--- /dev/null
+++ b/devel/htable/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: htable
+# Date created: 13 Aug 2010
+# Whom: Frederic Culot <frederic@culot.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= htable
+PORTVERSION= 1.1
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp2.culot.org/culot/
+
+MAINTAINER= frederic@culot.org
+COMMENT= Lightweight implementation of hash tables in C
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+MAN3= htable.3
+PLIST_FILES= include/htable.h
+
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/src/htable.h ${PREFIX}/include
+ ${INSTALL_MAN} ${WRKSRC}/src/htable.3 ${MAN3PREFIX}/man/man3
+
+.include <bsd.port.mk>
diff --git a/devel/htable/distinfo b/devel/htable/distinfo
new file mode 100644
index 000000000000..63d24d7b2392
--- /dev/null
+++ b/devel/htable/distinfo
@@ -0,0 +1,3 @@
+MD5 (htable-1.1.tar.gz) = 6bb0e2a4feefdc506e56947fc1fce901
+SHA256 (htable-1.1.tar.gz) = e83da23ebbf23ce22b94e663c2fe5223239a7a857f3758e4baed4a717312e8fa
+SIZE (htable-1.1.tar.gz) = 10765
diff --git a/devel/htable/pkg-descr b/devel/htable/pkg-descr
new file mode 100644
index 000000000000..7a59450378c9
--- /dev/null
+++ b/devel/htable/pkg-descr
@@ -0,0 +1,6 @@
+htable is a lightweight implementation of hash tables in C, greatly
+inspired by the implementations of spray and red-black trees found in
+*BSD kernels. To use it, you only need to copy the header file
+"htable.h" into your project.
+
+WWW: http://culot.org/public/Code/htable.html