aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-04-02 15:14:47 +0000
committerLars Thegler <lth@FreeBSD.org>2005-04-02 15:14:47 +0000
commit126bed76fdc238e1a15b1bc169b1a7c7a3046050 (patch)
treedfdb04716710b32c117f6d3282dc919cf9b4ba97
parentb2551be64bdd79137f97a8696c167cc1eb11ca2d (diff)
downloadports-126bed76fdc238e1a15b1bc169b1a7c7a3046050.tar.gz
ports-126bed76fdc238e1a15b1bc169b1a7c7a3046050.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTTP-Server-Simple-Static/Makefile32
-rw-r--r--www/p5-HTTP-Server-Simple-Static/distinfo2
-rw-r--r--www/p5-HTTP-Server-Simple-Static/pkg-descr4
-rw-r--r--www/p5-HTTP-Server-Simple-Static/pkg-plist4
5 files changed, 43 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 46b11d7ccac6..71b707347c6c 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -500,6 +500,7 @@
SUBDIR += p5-HTTP-Proxy
SUBDIR += p5-HTTP-Recorder
SUBDIR += p5-HTTP-Server-Simple
+ SUBDIR += p5-HTTP-Server-Simple-Static
SUBDIR += p5-HTTP-WebTest
SUBDIR += p5-HTTPD-Log-Filter
SUBDIR += p5-HTTPD-User-Manage
diff --git a/www/p5-HTTP-Server-Simple-Static/Makefile b/www/p5-HTTP-Server-Simple-Static/Makefile
new file mode 100644
index 000000000000..077ac96060d3
--- /dev/null
+++ b/www/p5-HTTP-Server-Simple-Static/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: www/p5-HTTP-Server-Simple-Static
+# Date created: 30 March 2005
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-Server-Simple-Static
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTTP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Serve static files with HTTP::Server::Simple
+
+RUN_DEPENDS= ${SITE_PERL}/HTTP/Server/Simple.pm:${PORTSDIR}/www/p5-HTTP-Server-Simple \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/MIME/Types.pm:${PORTSDIR}/mail/p5-MIME-Types \
+ ${SITE_PERL}/File/MMagic.pm:${PORTSDIR}/devel/p5-File-MMagic
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= HTTP::Server::Simple::Static.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires Perl 5.6 or newer. Install lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-HTTP-Server-Simple-Static/distinfo b/www/p5-HTTP-Server-Simple-Static/distinfo
new file mode 100644
index 000000000000..7ee77bd81ca6
--- /dev/null
+++ b/www/p5-HTTP-Server-Simple-Static/distinfo
@@ -0,0 +1,2 @@
+MD5 (HTTP-Server-Simple-Static-0.02.tar.gz) = 5f719e2d5e3420547742e3a3309cf6d2
+SIZE (HTTP-Server-Simple-Static-0.02.tar.gz) = 2216
diff --git a/www/p5-HTTP-Server-Simple-Static/pkg-descr b/www/p5-HTTP-Server-Simple-Static/pkg-descr
new file mode 100644
index 000000000000..ee029dfdf819
--- /dev/null
+++ b/www/p5-HTTP-Server-Simple-Static/pkg-descr
@@ -0,0 +1,4 @@
+This mixin adds a method to serve static files from your
+HTTP::Server::Simple subclass.
+
+WWW: http://search.cpan.org/dist/HTTP-Server-Simple-Static
diff --git a/www/p5-HTTP-Server-Simple-Static/pkg-plist b/www/p5-HTTP-Server-Simple-Static/pkg-plist
new file mode 100644
index 000000000000..2de22f14920d
--- /dev/null
+++ b/www/p5-HTTP-Server-Simple-Static/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/HTTP/Server/Simple/Static.pm
+@unexec rmdir %D/%%SITE_PERL%%/HTTP/Server/Simple 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/HTTP/Server 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/HTTP 2>/dev/null || true