aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2010-04-21 12:56:46 +0000
committerMartin Matuska <mm@FreeBSD.org>2010-04-21 12:56:46 +0000
commit159cf134b0cda7a46fa061050d142423140f3da6 (patch)
tree6b7658a59810ecc6f3df4f2940f43f49b425ca77
parentc28afb69f02dc9c7a11a6e31fc4a5db00f971694 (diff)
downloadports-159cf134b0cda7a46fa061050d142423140f3da6.tar.gz
ports-159cf134b0cda7a46fa061050d142423140f3da6.zip
Notes
-rw-r--r--multimedia/avidemux2/Makefile4
-rw-r--r--multimedia/ffmpeg-devel/Makefile3
-rw-r--r--multimedia/ffmpeg/Makefile21
-rw-r--r--multimedia/gstreamer-plugins-ugly/Makefile2
-rw-r--r--multimedia/gstreamer-plugins/Makefile.common2
-rw-r--r--multimedia/mpeg4ip/Makefile4
-rw-r--r--multimedia/transcode/Makefile4
-rw-r--r--multimedia/vlc/Makefile4
-rw-r--r--net/opal3/Makefile4
9 files changed, 16 insertions, 32 deletions
diff --git a/multimedia/avidemux2/Makefile b/multimedia/avidemux2/Makefile
index d2d24905e984..de0775a8f1b4 100644
--- a/multimedia/avidemux2/Makefile
+++ b/multimedia/avidemux2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= avidemux2
PORTVERSION= 2.4.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_BERLIOS} \
SF/avidemux/avidemux/${PORTVERSION}
@@ -155,7 +155,7 @@ LIB_DEPENDS+= faad.2:${PORTSDIR}/audio/faad
.if defined(WITHOUT_X264)
CMAKE_ARGS+= -DNO_x264=1
.else
-LIB_DEPENDS+= x264.65:${PORTSDIR}/multimedia/x264
+LIB_DEPENDS+= x264.85:${PORTSDIR}/multimedia/x264
.endif
.if defined(WITHOUT_XVID)
diff --git a/multimedia/ffmpeg-devel/Makefile b/multimedia/ffmpeg-devel/Makefile
index 632bc114b9d9..83c79a8e8546 100644
--- a/multimedia/ffmpeg-devel/Makefile
+++ b/multimedia/ffmpeg-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ffmpeg
DISTVERSION= 2010-04-18
+PORTREVISION= 1
CATEGORIES= multimedia audio ipv6 net
MASTER_SITES= http://people.freebsd.org/~mm/distfiles/
PKGNAMESUFFIX= -devel
@@ -267,7 +268,7 @@ CONFIGURE_ARGS+= --disable-libvorbis
# x264
.ifdef(WITH_X264)
-LIB_DEPENDS+= x264.85:${PORTSDIR}/multimedia/x264-devel
+LIB_DEPENDS+= x264.85:${PORTSDIR}/multimedia/x264
CONFIGURE_ARGS+= --enable-libx264
.else
CONFIGURE_ARGS+= --disable-libx264
diff --git a/multimedia/ffmpeg/Makefile b/multimedia/ffmpeg/Makefile
index 75c11157c228..195faddf31bc 100644
--- a/multimedia/ffmpeg/Makefile
+++ b/multimedia/ffmpeg/Makefile
@@ -8,7 +8,7 @@
PORTNAME= ffmpeg
PORTVERSION= 0.5.1
PORTEPOCH= 1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia audio ipv6 net
MASTER_SITES= http://ffmpeg.org/releases/
@@ -46,7 +46,6 @@ OPTIONS= AMR_NB "AMR Narrow Band encoder" off \
VORBIS "Vorbis encoder via libvorbis (implies OGG)" on \
X11GRAB "enable X11 grabbing" off \
X264 "H.264 encoder" on \
- X264_DEV "Require x264 from multimedia/x264-devel" off \
XVID "Xvid encoder via xvidcore" on
COMPAT_HEADERS=libavcodec/avcodec.h \
@@ -296,23 +295,7 @@ CONFIGURE_ARGS+= --disable-x11grab
# x264
.ifndef(WITHOUT_X264)
-# Automatically choose the multimedia/x264-devel port if installed
-. if !defined(WITH_X264_DEV)
-. if exists(${LOCALBASE}/include/x264.h)
-X264_BUILD!= ${GREP} "define X264_BUILD .." ${LOCALBASE}/include/x264.h | ${AWK} '{ print $$3 }'
-. if ${X264_BUILD} == "85"
-_WANT_X264_DEVEL= yes
-. endif
-. endif
-. else
-_WANT_X264_DEVEL=yes
-. endif
-
-. if defined(_WANT_X264_DEVEL)
-LIB_DEPENDS+= x264.85:${PORTSDIR}/multimedia/x264-devel
-. else
-LIB_DEPENDS+= x264.65:${PORTSDIR}/multimedia/x264
-. endif
+LIB_DEPENDS+= x264.85:${PORTSDIR}/multimedia/x264
CONFIGURE_ARGS+= --enable-libx264
.else
CONFIGURE_ARGS+= --disable-libx264
diff --git a/multimedia/gstreamer-plugins-ugly/Makefile b/multimedia/gstreamer-plugins-ugly/Makefile
index 8f2db5579f80..bf883e8c1f67 100644
--- a/multimedia/gstreamer-plugins-ugly/Makefile
+++ b/multimedia/gstreamer-plugins-ugly/Makefile
@@ -6,7 +6,7 @@
# $MCom: ports/multimedia/gstreamer-plugins-ugly/Makefile,v 1.13 2008/03/19 14:05:37 ahze Exp $
#
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= multimedia
COMMENT= Ugly gstreamer-plugins
diff --git a/multimedia/gstreamer-plugins/Makefile.common b/multimedia/gstreamer-plugins/Makefile.common
index a783a8d38f1f..6446f85aff95 100644
--- a/multimedia/gstreamer-plugins/Makefile.common
+++ b/multimedia/gstreamer-plugins/Makefile.common
@@ -474,7 +474,7 @@ gst_vorbis_PLIST_FILES= ${GST_LIB_DIR}/libgstvorbis.la \
gst_vorbis_DIST= base
# x264
-gst_x264_LIB_DEPENDS+= x264.65:${PORTSDIR}/multimedia/x264
+gst_x264_LIB_DEPENDS+= x264.85:${PORTSDIR}/multimedia/x264
gst_x264_PLIST_FILES= ${GST_LIB_DIR}/libgstx264.la \
${GST_LIB_DIR}/libgstx264.so \
share/gstreamer-${VERSION}/presets/GstX264Enc.prs
diff --git a/multimedia/mpeg4ip/Makefile b/multimedia/mpeg4ip/Makefile
index 8d92fa608257..4a506a1d3df8 100644
--- a/multimedia/mpeg4ip/Makefile
+++ b/multimedia/mpeg4ip/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mpeg4ip
PORTVERSION= 1.6.1
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= multimedia audio ipv6 net
MASTER_SITES= LOCAL/ahze
# http://sourceforge.net/forum/forum.php?thread_id=1839453&forum_id=59136
@@ -27,7 +27,7 @@ LIB_DEPENDS= faac.0:${PORTSDIR}/audio/faac \
a52.0:${PORTSDIR}/audio/liba52 \
mpeg2.0:${PORTSDIR}/multimedia/libmpeg2 \
avcodec.1:${PORTSDIR}/multimedia/ffmpeg \
- x264.65:${PORTSDIR}/multimedia/x264
+ x264.85:${PORTSDIR}/multimedia/x264
RUN_DEPENDS= mpeg4ip-libmp4v2>=1.6.1:${PORTSDIR}/multimedia/mpeg4ip-libmp4v2
USE_GNOME= gtk20
diff --git a/multimedia/transcode/Makefile b/multimedia/transcode/Makefile
index 4177b81945c9..9930e952dd45 100644
--- a/multimedia/transcode/Makefile
+++ b/multimedia/transcode/Makefile
@@ -7,7 +7,7 @@
PORTNAME= transcode
PORTVERSION= 1.1.5
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_BERLIOS} \
http://fromani.exit1.org/
@@ -117,7 +117,7 @@ CONFIGURE_ARGS+= --disable-xvid
.endif
.if defined(WITH_X264)
-LIB_DEPENDS+= x264.65:${PORTSDIR}/multimedia/x264
+LIB_DEPENDS+= x264.85:${PORTSDIR}/multimedia/x264
CONFIGURE_ARGS+= --with-x264-prefix=${LOCALBASE} --enable-x264
.else
CONFIGURE_ARGS+= --disable-x264
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index 8c3a588dca20..49c2e84a99cc 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -10,7 +10,7 @@
PORTNAME= vlc
DISTVERSION= 1.0.5
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 3
CATEGORIES= multimedia audio ipv6 net www
MASTER_SITES= http://download.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSION}/ \
@@ -355,7 +355,7 @@ CONFIGURE_ARGS+=--disable-schroedinger
.if !defined(WITHOUT_X264)
CONFIGURE_ARGS+=--enable-x264
-LIB_DEPENDS+= x264.65:${PORTSDIR}/multimedia/x264
+LIB_DEPENDS+= x264.85:${PORTSDIR}/multimedia/x264
.else
CONFIGURE_ARGS+=--disable-x264
.endif
diff --git a/net/opal3/Makefile b/net/opal3/Makefile
index ef73fb6096ed..0e73edc0b3a7 100644
--- a/net/opal3/Makefile
+++ b/net/opal3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= opal3
PORTVERSION= 3.6.6
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net
MASTER_SITES= SF/opalvoip/v3.6%20Lalande/Stable%205
DISTNAME= opal-${PORTVERSION}
@@ -121,7 +121,7 @@ PLIST_SUB+= THEORA="@comment "
.endif
.if defined(WITH_X264)
-LIB_DEPENDS+= x264.6[0-9]:${PORTSDIR}/multimedia/x264
+LIB_DEPENDS+= x264.85:${PORTSDIR}/multimedia/x264
CONFIGURE_ARGS+= --enable-h264
PLIST_SUB+= X264=""
WITH_VIDEO= yes