aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2012-09-26 20:33:56 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2012-09-26 20:33:56 +0000
commit16587df73c9d70692d458b20ef5c6a9ce3035053 (patch)
tree0f397a9d59dc53f5c4415a3858064bfaa2cab779
parent7e974c72a6d3907213a8f3d0d80ae5c3793cc1d9 (diff)
downloadports-16587df73c9d70692d458b20ef5c6a9ce3035053.tar.gz
ports-16587df73c9d70692d458b20ef5c6a9ce3035053.zip
Notes
-rw-r--r--MOVED1
-rw-r--r--www/Makefile2
-rw-r--r--www/smarty2/Makefile60
-rw-r--r--www/smarty2/distinfo4
-rw-r--r--www/smarty2/files/pkg-message.in4
-rw-r--r--www/smarty2/pkg-descr11
-rw-r--r--www/smarty2/pkg-plist260
7 files changed, 341 insertions, 1 deletions
diff --git a/MOVED b/MOVED
index 7c91cce71bb1..099146f088ed 100644
--- a/MOVED
+++ b/MOVED
@@ -3714,3 +3714,4 @@ www/linuxpluginwrapper||2012-09-22|Has expired: doesn't support ELF symbol versi
net/fping+ipv6|net/fping|2012-09-24|IPv6 support has been merged
textproc/aspell-without-dicten|textproc/aspell|2012-09-24|The dictionary is no longer installed with aspell
www/jakarta-jmeter|www/jmeter|2012-09-25|Former Jakarta projects now live on their own
+www/smarty|www/smarty2|2012-09-26|Renamed to prepare for addition of Smarty 3.x to the tree
diff --git a/www/Makefile b/www/Makefile
index 647ecf73e62e..286b02dffb3c 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1789,7 +1789,7 @@
SUBDIR += sitecopy
SUBDIR += siteframe
SUBDIR += skytemplate
- SUBDIR += smarty
+ SUBDIR += smarty2
SUBDIR += smb_auth
SUBDIR += snarf
SUBDIR += snownews
diff --git a/www/smarty2/Makefile b/www/smarty2/Makefile
new file mode 100644
index 000000000000..05495ec38105
--- /dev/null
+++ b/www/smarty2/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: smarty
+# Date created: 10 March 2002
+# Whom: Simon 'corecode' Schubert <corecode@corecode.ath.cx>
+#
+# $FreeBSD$
+#
+
+PORTNAME= smarty
+PORTVERSION= 2.6.27
+CATEGORIES= www
+MASTER_SITES= http://www.smarty.net/files/ \
+ http://www.smarty.net/files/docs/:manual
+DISTFILES= Smarty-${PORTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= glarkin@FreeBSD.org
+COMMENT= The PHP compiling template engine
+
+USE_ZIP= yes
+
+DOCSVERSION= 2.6
+
+WRKSRC= ${WRKDIR}/Smarty-${PORTVERSION}
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+DISTFILES+= manual-en-${DOCSVERSION}${EXTRACT_SUFX}:manual
+.endif
+
+NO_BUILD= yes
+USE_PHP= pcre
+WANT_PHP_WEB= yes
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_FILES= pkg-message
+
+do-install:
+ @${MKDIR} ${DATADIR}
+.for f in Config_File.class.php Smarty.class.php Smarty_Compiler.class.php debug.tpl
+ @${INSTALL_DATA} ${WRKSRC}/libs/$f ${DATADIR}
+.endfor
+ @${MKDIR} ${DATADIR}/internals
+ @${INSTALL_DATA} ${WRKSRC}/libs/internals/* ${DATADIR}/internals
+ @${MKDIR} ${DATADIR}/plugins
+ @${INSTALL_DATA} ${WRKSRC}/libs/plugins/* ${DATADIR}/plugins
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+.for f in BUGS FAQ INSTALL NEWS README
+ @${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}
+.endfor
+ @${MKDIR} ${DOCSDIR}/manual
+ @cd ${WRKDIR}/manual-en && ${FIND} . | ${CPIO} --quiet -dumpR ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}/manual
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/smarty2/distinfo b/www/smarty2/distinfo
new file mode 100644
index 000000000000..0127b68736f4
--- /dev/null
+++ b/www/smarty2/distinfo
@@ -0,0 +1,4 @@
+SHA256 (Smarty-2.6.27.zip) = 327504671bee91d014fa2868ca8cdaa90a7ac299495b6c7f2d32ff57cab7ee6b
+SIZE (Smarty-2.6.27.zip) = 194429
+SHA256 (manual-en-2.6.zip) = 694888f142c1eaacc5f442d050bb23292feaf2844af3a69fabd1a15a7f01034b
+SIZE (manual-en-2.6.zip) = 314640
diff --git a/www/smarty2/files/pkg-message.in b/www/smarty2/files/pkg-message.in
new file mode 100644
index 000000000000..b9d8ebd9a029
--- /dev/null
+++ b/www/smarty2/files/pkg-message.in
@@ -0,0 +1,4 @@
+You need to adjust php's include_path to contain `%%DATADIR%%'!
+For example, insert
+ include_path = ".:%%DATADIR%%"
+into `%%LOCALBASE%%/etc/php.ini'.
diff --git a/www/smarty2/pkg-descr b/www/smarty2/pkg-descr
new file mode 100644
index 000000000000..b582ce4ed4d6
--- /dev/null
+++ b/www/smarty2/pkg-descr
@@ -0,0 +1,11 @@
+Smarty is a template engine for PHP. Many other template engines for PHP
+provide basic variable substitution and dynamic block functionality.
+Smarty takes a step further to be a "smart" template engine, adding
+features such as configuration files, template functions, and variable
+modifiers, and making all of this functionality as easy as possible to
+use for both programmers and template designers. Smarty also converts
+the templates into PHP scripts, eliminating the need to parse the
+templates on every invocation. This makes Smarty extremely scalable and
+managable for large application needs.
+
+WWW: http://www.smarty.net/
diff --git a/www/smarty2/pkg-plist b/www/smarty2/pkg-plist
new file mode 100644
index 000000000000..4a14f0e7bfd0
--- /dev/null
+++ b/www/smarty2/pkg-plist
@@ -0,0 +1,260 @@
+%%PORTDOCS%%%%DOCSDIR%%/BUGS
+%%PORTDOCS%%%%DOCSDIR%%/FAQ
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/manual/advanced.features.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/advanced.features.outputfilters.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/advanced.features.postfilters.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/advanced.features.prefilters.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.append.by.ref.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.append.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.assign.by.ref.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.assign.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.clear.all.assign.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.clear.all.cache.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.clear.assign.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.clear.cache.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.clear.compiled.tpl.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.clear.config.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.config.load.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.display.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.fetch.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.functions.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.get.config.vars.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.get.registered.object.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.get.template.vars.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.is.cached.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.load.filter.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.register.block.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.register.compiler.function.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.register.function.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.register.modifier.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.register.object.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.register.outputfilter.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.register.postfilter.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.register.prefilter.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.register.resource.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.template.exists.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.trigger.error.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.unregister.block.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.unregister.compiler.function.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.unregister.function.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.unregister.modifier.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.unregister.object.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.unregister.outputfilter.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.unregister.postfilter.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.unregister.prefilter.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.unregister.resource.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/api.variables.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/appendixes.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/bugs.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/caching.cacheable.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/caching.groups.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/caching.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/caching.multiple.caches.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/chapter.debugging.console.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/config.files.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/constant.smarty.core.dir.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/getting.started.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/index.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/installation.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/installing.smarty.basic.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/installing.smarty.extended.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.basic.syntax.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.builtin.functions.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.combining.modifiers.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.config.variables.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.custom.functions.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.escaping.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.function.config.load.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.function.counter.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.function.cycle.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.function.debug.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.function.eval.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.function.fetch.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.function.foreach.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.function.html.checkboxes.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.function.html.image.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.function.html.options.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.function.html.radios.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.function.html.select.date.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.function.html.select.time.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.function.html.table.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.function.if.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.function.include.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.function.include.php.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.function.insert.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.function.ldelim.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.function.literal.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.function.mailto.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.function.math.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.function.php.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.function.section.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.function.strip.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.function.textformat.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.math.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.modifier.cat.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.modifier.count.characters.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.modifier.count.paragraphs.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.modifier.count.sentences.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.modifier.count.words.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.modifier.date.format.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.modifier.default.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.modifier.escape.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.modifier.indent.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.modifier.lower.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.modifier.nl2br.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.modifier.regex.replace.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.modifier.replace.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.modifier.spacify.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.modifier.string.format.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.modifier.strip.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.modifier.strip.tags.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.modifier.truncate.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.modifier.upper.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.modifier.wordwrap.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.modifiers.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.syntax.attributes.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.syntax.functions.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.syntax.quotes.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.syntax.variables.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.variables.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/language.variables.smarty.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/plugins.block.functions.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/plugins.compiler.functions.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/plugins.functions.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/plugins.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/plugins.inserts.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/plugins.modifiers.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/plugins.naming.conventions.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/plugins.outputfilters.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/plugins.prefilters.postfilters.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/plugins.resources.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/plugins.writing.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/preface.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/resources.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/section.template.cache.handler.func.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/smarty.constants.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/smarty.for.designers.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/smarty.for.programmers.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/template.resources.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/tips.componentized.templates.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/tips.dates.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/tips.default.var.handling.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/tips.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/tips.obfuscating.email.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/tips.passing.vars.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/tips.wap.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/troubleshooting.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.autoload.filters.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.cache.dir.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.cache.handler.func.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.cache.lifetime.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.cache.modified.check.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.caching.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.compile.check.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.compile.dir.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.compile.id.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.compiler.class.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.config.booleanize.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.config.dir.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.config.fix.newlines.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.config.overwrite.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.config.read.hidden.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.debug.tpl.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.debugging.ctrl.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.debugging.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.default.modifiers.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.default.resource.type.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.default.template.handler.func.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.error.reporting.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.force.compile.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.left.delimiter.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.php.handling.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.plugins.dir.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.request.use.auto.globals.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.request.vars.order.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.right.delimiter.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.secure.dir.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.security.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.security.settings.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.trusted.dir.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/variable.use.sub.dirs.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/what.is.smarty.html
+%%DATADIR%%/Config_File.class.php
+%%DATADIR%%/Smarty.class.php
+%%DATADIR%%/Smarty_Compiler.class.php
+%%DATADIR%%/debug.tpl
+%%DATADIR%%/internals/core.assemble_plugin_filepath.php
+%%DATADIR%%/internals/core.assign_smarty_interface.php
+%%DATADIR%%/internals/core.create_dir_structure.php
+%%DATADIR%%/internals/core.display_debug_console.php
+%%DATADIR%%/internals/core.get_include_path.php
+%%DATADIR%%/internals/core.get_microtime.php
+%%DATADIR%%/internals/core.get_php_resource.php
+%%DATADIR%%/internals/core.is_secure.php
+%%DATADIR%%/internals/core.is_trusted.php
+%%DATADIR%%/internals/core.load_plugins.php
+%%DATADIR%%/internals/core.load_resource_plugin.php
+%%DATADIR%%/internals/core.process_cached_inserts.php
+%%DATADIR%%/internals/core.process_compiled_include.php
+%%DATADIR%%/internals/core.read_cache_file.php
+%%DATADIR%%/internals/core.rm_auto.php
+%%DATADIR%%/internals/core.rmdir.php
+%%DATADIR%%/internals/core.run_insert_handler.php
+%%DATADIR%%/internals/core.smarty_include_php.php
+%%DATADIR%%/internals/core.write_cache_file.php
+%%DATADIR%%/internals/core.write_compiled_include.php
+%%DATADIR%%/internals/core.write_compiled_resource.php
+%%DATADIR%%/internals/core.write_file.php
+%%DATADIR%%/plugins/block.textformat.php
+%%DATADIR%%/plugins/compiler.assign.php
+%%DATADIR%%/plugins/function.assign_debug_info.php
+%%DATADIR%%/plugins/function.config_load.php
+%%DATADIR%%/plugins/function.counter.php
+%%DATADIR%%/plugins/function.cycle.php
+%%DATADIR%%/plugins/function.debug.php
+%%DATADIR%%/plugins/function.eval.php
+%%DATADIR%%/plugins/function.fetch.php
+%%DATADIR%%/plugins/function.html_checkboxes.php
+%%DATADIR%%/plugins/function.html_image.php
+%%DATADIR%%/plugins/function.html_options.php
+%%DATADIR%%/plugins/function.html_radios.php
+%%DATADIR%%/plugins/function.html_select_date.php
+%%DATADIR%%/plugins/function.html_select_time.php
+%%DATADIR%%/plugins/function.html_table.php
+%%DATADIR%%/plugins/function.mailto.php
+%%DATADIR%%/plugins/function.math.php
+%%DATADIR%%/plugins/function.popup.php
+%%DATADIR%%/plugins/function.popup_init.php
+%%DATADIR%%/plugins/modifier.capitalize.php
+%%DATADIR%%/plugins/modifier.cat.php
+%%DATADIR%%/plugins/modifier.count_characters.php
+%%DATADIR%%/plugins/modifier.count_paragraphs.php
+%%DATADIR%%/plugins/modifier.count_sentences.php
+%%DATADIR%%/plugins/modifier.count_words.php
+%%DATADIR%%/plugins/modifier.date_format.php
+%%DATADIR%%/plugins/modifier.debug_print_var.php
+%%DATADIR%%/plugins/modifier.default.php
+%%DATADIR%%/plugins/modifier.escape.php
+%%DATADIR%%/plugins/modifier.indent.php
+%%DATADIR%%/plugins/modifier.lower.php
+%%DATADIR%%/plugins/modifier.nl2br.php
+%%DATADIR%%/plugins/modifier.regex_replace.php
+%%DATADIR%%/plugins/modifier.replace.php
+%%DATADIR%%/plugins/modifier.spacify.php
+%%DATADIR%%/plugins/modifier.string_format.php
+%%DATADIR%%/plugins/modifier.strip.php
+%%DATADIR%%/plugins/modifier.strip_tags.php
+%%DATADIR%%/plugins/modifier.truncate.php
+%%DATADIR%%/plugins/modifier.upper.php
+%%DATADIR%%/plugins/modifier.wordwrap.php
+%%DATADIR%%/plugins/outputfilter.trimwhitespace.php
+%%DATADIR%%/plugins/shared.escape_special_chars.php
+%%DATADIR%%/plugins/shared.make_timestamp.php
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/internals
+@dirrm %%DATADIR%%/plugins
+@dirrm %%DATADIR%%