aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-09-18 08:14:23 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-09-18 08:14:23 +0000
commit2e7f27934a9580751196aa2ace7230c9e763524f (patch)
tree985075045a3e320b7edb1a42256318fd6f5f3038
parentcdf2a00af52a8eb98245773b34b055c7f995532b (diff)
downloadports-2e7f27934a9580751196aa2ace7230c9e763524f.tar.gz
ports-2e7f27934a9580751196aa2ace7230c9e763524f.zip
Notes
-rw-r--r--audio/nuvolaplayer/Makefile2
-rw-r--r--audio/sherlock-lv2/Makefile4
-rw-r--r--biology/pbbam/Makefile2
-rw-r--r--biology/pbcopper/Makefile2
-rw-r--r--biology/unanimity/Makefile2
-rw-r--r--cad/freehdl/Makefile6
-rw-r--r--databases/p5-Tie-LevelDB/Makefile3
-rw-r--r--databases/pointcloud/Makefile2
-rw-r--r--devel/icmake/Makefile8
-rw-r--r--games/atanks/Makefile2
-rw-r--r--games/super_methane_brothers/Makefile2
-rw-r--r--games/taisei/Makefile2
-rw-r--r--graphics/gegl3/Makefile2
-rw-r--r--graphics/libmypaint/Makefile2
-rw-r--r--graphics/perceptualdiff/Makefile4
-rw-r--r--mail/evolution/Makefile5
-rw-r--r--mail/geary/Makefile2
-rw-r--r--math/piranha/Makefile2
-rw-r--r--multimedia/gstreamer1-editing-services/Makefile4
-rw-r--r--net-mgmt/seafile-server/Makefile2
-rw-r--r--x11-toolkits/girara/Makefile2
-rw-r--r--x11/brisk-menu/Makefile2
22 files changed, 30 insertions, 34 deletions
diff --git a/audio/nuvolaplayer/Makefile b/audio/nuvolaplayer/Makefile
index ba7f33d64416..5e38865f8419 100644
--- a/audio/nuvolaplayer/Makefile
+++ b/audio/nuvolaplayer/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= ${PORTNAME}-all-services>=0:www/${PORTNAME}-all-services
USE_GITHUB= yes
GH_ACCOUNT= tiliado
-USES= gnome libarchive pkgconfig waf
+USES= compiler:c11 gnome libarchive pkgconfig waf
USE_GNOME= glib20 gtk30
USE_XORG= x11
# src/nuvolakit-runner/components/keybindings/XKeyGrabber.c:128:2: error: non-void function 'nuvola_xkey_grabber_construct' should return a value [-Wreturn-type]
diff --git a/audio/sherlock-lv2/Makefile b/audio/sherlock-lv2/Makefile
index 3e603d2ca62a..a4cf8c534f05 100644
--- a/audio/sherlock-lv2/Makefile
+++ b/audio/sherlock-lv2/Makefile
@@ -12,14 +12,12 @@ COMMENT= Investigative LV2 plugin bundle
LICENSE= ART20
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= fails to build: cc1: unrecognized command line option -std=gnu11
-
BUILD_DEPENDS= lv2>0:audio/lv2
LIB_DEPENDS= libserd-0.so:devel/serd \
libsord-0.so:devel/sord \
libsratom-0.so:audio/sratom
-USES= cmake pkgconfig
+USES= cmake compiler:c11 pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= OpenMusicKontrollers
GH_PROJECT= sherlock.lv2
diff --git a/biology/pbbam/Makefile b/biology/pbbam/Makefile
index 5157d6f0754f..6264263a500d 100644
--- a/biology/pbbam/Makefile
+++ b/biology/pbbam/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS= boost-libs>=1.60.0:devel/boost-libs
LIB_DEPENDS= libhts.so:biology/htslib \
libboost_regex.so:devel/boost-libs
-USES= cmake pkgconfig
+USES= cmake compiler:c++14-lang pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= PacificBiosciences
GH_TAGNAME= c6b8113adb5104948879e9ff69f739121f12a09f
diff --git a/biology/pbcopper/Makefile b/biology/pbcopper/Makefile
index 1ca04afddd65..542fdc05d882 100644
--- a/biology/pbcopper/Makefile
+++ b/biology/pbcopper/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LIB_DEPENDS= libboost_regex.so:devel/boost-libs
-USES= cmake
+USES= cmake compiler:c++14-lang
# Although there are a couple releases, git describe --tags does not work
# so we cannot use the usual USE_GITHUB tools here.
USE_GITHUB= yes
diff --git a/biology/unanimity/Makefile b/biology/unanimity/Makefile
index 12b0250150a3..5ad1a13a4d84 100644
--- a/biology/unanimity/Makefile
+++ b/biology/unanimity/Makefile
@@ -20,7 +20,7 @@ BUILD_DEPENDS= pbseqan>=g20171002:biology/pbseqan \
LIB_DEPENDS= libhts.so:biology/htslib \
libboost_regex.so:devel/boost-libs
-USES= cmake pkgconfig python
+USES= cmake compiler:c++14-lang pkgconfig python
USE_GITHUB= yes
GH_ACCOUNT= PacificBiosciences
diff --git a/cad/freehdl/Makefile b/cad/freehdl/Makefile
index cec3b6092f9b..23087b5c3049 100644
--- a/cad/freehdl/Makefile
+++ b/cad/freehdl/Makefile
@@ -10,11 +10,7 @@ MASTER_SITES= http://freehdl.seul.org/~enaroska/
MAINTAINER= ports@FreeBSD.org
COMMENT= Free VHDL simulator
-BROKEN_mips= fails to build: cc1plus: error: unrecognized command line option "-std=gnu++03"
-BROKEN_mips64= fails to build: cc1plus: error: unrecognized command line option "-std=gnu++03"
-BROKEN_powerpc64= fails to build: cc1plus: error: unrecognized command line option "-std=gnu++03"
-
-USES= gmake pathfix libtool makeinfo perl5 pkgconfig
+USES= compiler:c++0x gmake pathfix libtool makeinfo perl5 pkgconfig
USE_LDCONFIG= yes
USE_GCC= any
GNU_CONFIGURE= yes
diff --git a/databases/p5-Tie-LevelDB/Makefile b/databases/p5-Tie-LevelDB/Makefile
index 98889d162b9a..38f090a7ad6b 100644
--- a/databases/p5-Tie-LevelDB/Makefile
+++ b/databases/p5-Tie-LevelDB/Makefile
@@ -15,14 +15,13 @@ LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
BROKEN_aarch64= does not build: error: Please implement AtomicPointer for this platform
-BROKEN_powerpc64= does not build: error: unrecognized command line option -std=c++0x
BROKEN_sparc64= does not build: unrecognized command line options
LIB_DEPENDS= libleveldb.so:databases/leveldb
MAKE_ARGS= CC="${CXX}"
+USES= compiler:c++0x gmake localbase perl5
USE_PERL5= configure
-USES= compiler gmake localbase perl5
.include <bsd.port.pre.mk>
diff --git a/databases/pointcloud/Makefile b/databases/pointcloud/Makefile
index 0a44a743b278..b29830ad49a8 100644
--- a/databases/pointcloud/Makefile
+++ b/databases/pointcloud/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
BUILD_DEPENDS= ${LOCALBASE}/include/laz-perf/las.hpp:archivers/lazperf
LIB_DEPENDS= libght.so:devel/libght
-USES= autoreconf gmake gnome pgsql
+USES= autoreconf compiler:c++0x gmake gnome pgsql
WANT_PGSQL= server
USE_GNOME= libxml2
GNU_CONFIGURE= yes
diff --git a/devel/icmake/Makefile b/devel/icmake/Makefile
index 489756543fc9..3fb02f6a0408 100644
--- a/devel/icmake/Makefile
+++ b/devel/icmake/Makefile
@@ -20,7 +20,7 @@ PLIST_SUB+= PORTVERSION="${PORTVERSION}"
REINPLACE_ARGS= -I ""
-USES= shebangfix
+USES= compiler shebangfix
SHEBANG_FILES= build comp/build comp/icm_bootstrap comp/updategrammar \
comp/updateparser comp/updatescanner dep/build dep/icm_bootstrap \
exec/build exec/icm_bootstrap exec/list/test/build exec/string/test/build \
@@ -37,6 +37,12 @@ GL_COMMIT= 8e3ac3057363162b87279bab1e9ba356eb0aea0f
OPTIONS_DEFINE= DOCS
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} == gcc && ${COMPILER_VERSION} == 42
+CFLAGS+= -std=gnu99
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|find|find .|g' \
${WRKSRC}/icm_prepare
diff --git a/games/atanks/Makefile b/games/atanks/Makefile
index 63c0f3e8cd19..2f56fbdbbd3c 100644
--- a/games/atanks/Makefile
+++ b/games/atanks/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= liballeg.so:devel/allegro
-USES= gmake
+USES= compiler:c++0x gmake
PORTDOCS= Changelog README README_ru.txt credits.txt
diff --git a/games/super_methane_brothers/Makefile b/games/super_methane_brothers/Makefile
index dee96306db8d..303f7a7e6972 100644
--- a/games/super_methane_brothers/Makefile
+++ b/games/super_methane_brothers/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libclan23Core.so:devel/clanlib
-USES= gmake localbase pkgconfig tar:tgz
+USES= compiler:c++0x gmake localbase pkgconfig tar:tgz
MAKE_ENV= METHANE_FLAGS="${CPPFLAGS}" METHANE_LIBS="${LIBS}"
MAKE_JOBS_UNSAFE= yes
diff --git a/games/taisei/Makefile b/games/taisei/Makefile
index 3652e915fbda..5ad005df98f4 100644
--- a/games/taisei/Makefile
+++ b/games/taisei/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libpng.so:graphics/png \
USE_GITHUB= yes
GH_ACCOUNT= ${PORTNAME}-project
-USES= cmake pkgconfig
+USES= cmake compiler:c11 pkgconfig
CMAKE_ARGS= -DTAISEI_VERSION_OVERRIDE=${PORTVERSION}
USE_SDL= sdl2 ttf2 mixer2
diff --git a/graphics/gegl3/Makefile b/graphics/gegl3/Makefile
index 9367e5a64dd7..aede146b4332 100644
--- a/graphics/gegl3/Makefile
+++ b/graphics/gegl3/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libbabl-0.1.so:x11/babl \
libjson-glib-1.0.so:devel/json-glib \
libpng.so:graphics/png
-USES= cpe gettext gmake jpeg libtool localbase \
+USES= compiler:c11 cpe gettext gmake jpeg libtool localbase \
pathfix pkgconfig shebangfix uniquefiles tar:bzip2
USE_GNOME= glib20 intltool introspection:build
USE_LDCONFIG= yes
diff --git a/graphics/libmypaint/Makefile b/graphics/libmypaint/Makefile
index a5e6c900f892..9bfe16b3be1a 100644
--- a/graphics/libmypaint/Makefile
+++ b/graphics/libmypaint/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libjson-c.so:devel/json-c
-USES= gmake gnome libtool localbase pkgconfig tar:xz
+USES= compiler:c11 gmake gnome libtool localbase pkgconfig tar:xz
USE_GNOME= glib20 intltool introspection:build
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/graphics/perceptualdiff/Makefile b/graphics/perceptualdiff/Makefile
index 0b0d04deefb3..db20fea46e0b 100644
--- a/graphics/perceptualdiff/Makefile
+++ b/graphics/perceptualdiff/Makefile
@@ -13,13 +13,11 @@ LICENSE= GPLv2
LIB_DEPENDS= libfreeimage.so:graphics/freeimage
-BROKEN_powerpc64= fails to compile: cc1plus: unrecognized command line option "-std=c++0x"
-
PLIST_FILES= bin/perceptualdiff
USE_GITHUB= yes
GH_ACCOUNT= myint
-USES= cmake
+USES= cmake compiler:c++0x
.include <bsd.port.mk>
diff --git a/mail/evolution/Makefile b/mail/evolution/Makefile
index bd71ffe539fe..2876fdbac727 100644
--- a/mail/evolution/Makefile
+++ b/mail/evolution/Makefile
@@ -41,8 +41,9 @@ RUN_DEPENDS= highlight:textproc/highlight \
PORTSCOUT= limitw:1,even
-USES= desktop-file-utils cmake gettext gnome iconv:wchar_t \
- sqlite libarchive localbase pathfix pkgconfig tar:xz
+USES= compiler:c11 desktop-file-utils cmake gettext gnome \
+ iconv:wchar_t sqlite libarchive localbase pathfix pkgconfig \
+ tar:xz
USE_GNOME= cairo evolutiondataserver3 gnomedesktop3 intltool
GNU_CONFIGURE= yes
USE_XORG= x11
diff --git a/mail/geary/Makefile b/mail/geary/Makefile
index 6d587fc7d49c..88820f7eed9e 100644
--- a/mail/geary/Makefile
+++ b/mail/geary/Makefile
@@ -29,7 +29,7 @@ LIB_DEPENDS= libgmime-2.6.so:mail/gmime26 \
libsoup-2.4.so:devel/libsoup \
libenchant.so:textproc/enchant
-USES= cmake:outsource desktop-file-utils gettext libtool \
+USES= cmake:outsource compiler:c11 desktop-file-utils gettext libtool \
localbase:ldflags pkgconfig shebangfix sqlite tar:xz
USE_GNOME= cairo gnomedocutils gnomeprefix gtk30 intlhack introspection
SHEBANG_FILES= desktop/geary-attach
diff --git a/math/piranha/Makefile b/math/piranha/Makefile
index 57a9f41da976..38fabfe2b434 100644
--- a/math/piranha/Makefile
+++ b/math/piranha/Makefile
@@ -18,7 +18,7 @@ LICENSE_FILE_LGPL3= ${WRKSRC}/COPYING.lgpl3
BUILD_DEPENDS= ${HEADER_DEPENDS}
RUN_DEPENDS= ${HEADER_DEPENDS}
-USES= cmake:outsource
+USES= cmake:outsource compiler:c++14-lang
USE_GITHUB= yes
GH_ACCOUNT= bluescarni
NO_BUILD= yes
diff --git a/multimedia/gstreamer1-editing-services/Makefile b/multimedia/gstreamer1-editing-services/Makefile
index a37cf0895448..5855408f5b67 100644
--- a/multimedia/gstreamer1-editing-services/Makefile
+++ b/multimedia/gstreamer1-editing-services/Makefile
@@ -10,11 +10,9 @@ DISTNAME= gstreamer-editing-services-${PORTVERSION}
MAINTAINER= multimedia@FreeBSD.org
COMMENT= GStreamer editing services
-BROKEN_powerpc64= fails to compile: ges-extractable.h:24: error: redefinition of typedef 'GESExtractable'
-
PORTSCOUT= limitw:1,even
-USES= gmake gnome libtool pathfix python:2.7 pkgconfig tar:xz
+USES= compiler:c11 gmake gnome libtool pathfix python:2.7 pkgconfig tar:xz
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_GNOME= glib20 introspection:build libxml2 pygobject3
diff --git a/net-mgmt/seafile-server/Makefile b/net-mgmt/seafile-server/Makefile
index 4d2795767903..ac10e5c8b1ae 100644
--- a/net-mgmt/seafile-server/Makefile
+++ b/net-mgmt/seafile-server/Makefile
@@ -28,7 +28,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
CONFLICTS= seafile-[0-9]*
-USES= autoreconf iconv libarchive libtool localbase mysql \
+USES= autoreconf compiler:c11 iconv libarchive libtool localbase mysql \
pathfix pgsql pkgconfig python:-2.7 shebangfix sqlite ssl
USE_GITHUB= yes
GH_ACCOUNT= haiwen
diff --git a/x11-toolkits/girara/Makefile b/x11-toolkits/girara/Makefile
index 52f130205d6a..6ad61b4cd2ce 100644
--- a/x11-toolkits/girara/Makefile
+++ b/x11-toolkits/girara/Makefile
@@ -11,7 +11,7 @@ MASTER_SITES= https://pwmt.org/projects/girara/download/ \
MAINTAINER= madpilot@FreeBSD.org
COMMENT= GTK3 Interface Library for Zathura PDF Viewer
-USES= meson pathfix pkgconfig tar:xz
+USES= compiler:c11 meson pathfix pkgconfig tar:xz
PATHFIX_MAKEFILEIN= Makefile
USE_GNOME= cairo gdkpixbuf2 glib20 gtk30
USE_LDCONFIG= yes
diff --git a/x11/brisk-menu/Makefile b/x11/brisk-menu/Makefile
index bad2fe3e249d..3024990c155d 100644
--- a/x11/brisk-menu/Makefile
+++ b/x11/brisk-menu/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libnotify.so:devel/libnotify
-USES= gnome mate meson ninja pkgconfig gettext
+USES= compiler:c11 gnome mate meson ninja pkgconfig gettext
MESON_ARGS= --sysconfdir=${PREFIX}/etc
USE_GITHUB= yes