aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2013-09-11 16:45:58 +0000
committerJohn Marino <marino@FreeBSD.org>2013-09-11 16:45:58 +0000
commit30fb06c870312f125ce13d34b81a10f7906677eb (patch)
tree07c99aa739c6b74a8b8c37fee0caed1e65bb175c
parentf19c454457053117207f92b46d70774cb96bfdf7 (diff)
downloadports-30fb06c870312f125ce13d34b81a10f7906677eb.tar.gz
ports-30fb06c870312f125ce13d34b81a10f7906677eb.zip
Notes
-rw-r--r--devel/glademm/Makefile8
-rw-r--r--games/exult/Makefile12
-rw-r--r--games/vamos/Makefile1
-rw-r--r--games/xbomb/Makefile7
-rw-r--r--graphics/ocre/Makefile3
-rw-r--r--graphics/pygts/Makefile7
-rw-r--r--mail/wmmaiload/Makefile8
-rw-r--r--misc/gkrellshoot2/Makefile1
-rw-r--r--misc/xosd/Makefile2
-rw-r--r--multimedia/shell-fm/Makefile8
-rw-r--r--multimedia/vdr-plugin-epgsearch/Makefile1
-rw-r--r--print/paps/Makefile7
-rw-r--r--security/kc/Makefile1
-rw-r--r--textproc/p5-XML-Canonical/Makefile2
-rw-r--r--www/newsbeuter/Makefile3
-rw-r--r--www/npapi-xine/Makefile7
-rw-r--r--x11-wm/herbstluftwm/Makefile2
-rw-r--r--x11/setlayout/Makefile7
18 files changed, 30 insertions, 57 deletions
diff --git a/devel/glademm/Makefile b/devel/glademm/Makefile
index ae292dd1236b..a9ca537fc20a 100644
--- a/devel/glademm/Makefile
+++ b/devel/glademm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: glademm
-# Date created: 4th November 2003
-# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
-#
+# Created by: Alexander Nedotsukov <bland@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= glademm
PORTVERSION= 2.6.0
@@ -15,7 +11,7 @@ DISTNAME= ${PORTNAME:S/2$//}-${PORTVERSION}
MAINTAINER= bland@FreeBSD.org
COMMENT= A C++ code generator backend for glade and glade2
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_GNOME= gnomeprefix gnomehack
GNU_CONFIGURE= yes
diff --git a/games/exult/Makefile b/games/exult/Makefile
index 11d63d00204e..21929687b67f 100644
--- a/games/exult/Makefile
+++ b/games/exult/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: exult
-# Date created: 18 February 2002
-# Whom: Igor Pokrovsky <tiamat@telegraph.spb.ru>
-#
+# Created by: Igor Pokrovsky <tiamat@telegraph.spb.ru>
# $FreeBSD$
-#
PORTNAME= exult
PORTVERSION= 1.2
@@ -19,7 +15,7 @@ RUN_DEPENDS= timidity:${PORTSDIR}/audio/timidity
USE_SDL= sdl mixer
USE_XORG= x11
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_AUTOTOOLS= libtool
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -30,12 +26,14 @@ MAN6= exult.6
SUB_FILES= pkg-message
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|desktop||' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|/usr/X11R6|${LOCALBASE}|g' ${WRKSRC}/configure
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for i in FAQ NEWS README
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
diff --git a/games/vamos/Makefile b/games/vamos/Makefile
index 5f3792271497..85f16cc6ad3a 100644
--- a/games/vamos/Makefile
+++ b/games/vamos/Makefile
@@ -17,6 +17,7 @@ LICENSE= GPLv2
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+USES= pkgconfig
USE_OPENAL= al alut
USE_XORG= sm ice x11 xi xext xmu
USE_GL= glut
diff --git a/games/xbomb/Makefile b/games/xbomb/Makefile
index 703cb7dc5f1c..0c3456b19d1f 100644
--- a/games/xbomb/Makefile
+++ b/games/xbomb/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xbomb
-# Date created: 20 Feb 1998
-# Whom: Thomas Gellekum <tg@FreeBSD.org>
-#
+# Created by: Thomas Gellekum <tg@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= xbomb
PORTVERSION= 2.2a
@@ -14,6 +10,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Minesweeper with a couple of grid types
+USES= pkgconfig
USE_XORG= xaw7
MAN6= xbomb.6
diff --git a/graphics/ocre/Makefile b/graphics/ocre/Makefile
index cac9d48dba23..857156cad0a3 100644
--- a/graphics/ocre/Makefile
+++ b/graphics/ocre/Makefile
@@ -21,8 +21,7 @@ RUN_DEPENDS= display:${PORTSDIR}/graphics/ImageMagick \
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/${PORTNAME}
USE_GNOME= gtk20
-USES= gettext
-USE_GMAKE= yes
+USES= gettext gmake pkgconfig
MAKE_ENV= CFLAGS1="${CFLAGS}"
MANLANG= "" es
diff --git a/graphics/pygts/Makefile b/graphics/pygts/Makefile
index bab8cdd54b91..c98ab422d78e 100644
--- a/graphics/pygts/Makefile
+++ b/graphics/pygts/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pygts
-# Date created: 17 May, 2009
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= pygts
PORTVERSION= 0.3.1
@@ -19,5 +15,6 @@ LIB_DEPENDS= gts.5:${PORTSDIR}/graphics/gts
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+USES= pkgconfig
.include <bsd.port.mk>
diff --git a/mail/wmmaiload/Makefile b/mail/wmmaiload/Makefile
index c6e6ec62c8d0..03351f43843c 100644
--- a/mail/wmmaiload/Makefile
+++ b/mail/wmmaiload/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: wmmaiload
-# Date created: Sat Sep 21 01:48:10 EDT 2002
-# Whom: pat
-#
+# Created by: pat
# $FreeBSD$
-#
PORTNAME= wmmaiload
PORTVERSION= 2.2.1
@@ -14,9 +10,9 @@ MASTER_SITES= http://tnemeth.free.fr/projets/programmes/
MAINTAINER= ports@FreeBSD.org
COMMENT= Incoming mail monitor dockapp with a similar look to wmcpuload
+USES= gmake pkgconfig
USE_XORG= xpm
USE_OPENSSL= yes
-USE_GMAKE= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
MAKE_ARGS= CC="${CC}" \
diff --git a/misc/gkrellshoot2/Makefile b/misc/gkrellshoot2/Makefile
index 5111de430622..ae1b3aa2c590 100644
--- a/misc/gkrellshoot2/Makefile
+++ b/misc/gkrellshoot2/Makefile
@@ -11,6 +11,7 @@ PKGNAMESUFFIX= 2
MAINTAINER= ports@FreeBSD.org
COMMENT= Screen locking and screen capture plugin for GKrellM 2
+USES= pkgconfig
BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2 \
import:${PORTSDIR}/graphics/ImageMagick
diff --git a/misc/xosd/Makefile b/misc/xosd/Makefile
index 8acb115aa13a..c66bf7b2b48a 100644
--- a/misc/xosd/Makefile
+++ b/misc/xosd/Makefile
@@ -12,9 +12,9 @@ COMMENT= X11 on-screen-display program and library
LICENSE= GPLv2
+USES= gmake pkgconfig
USE_AUTOTOOLS= libtool
USE_CSTD= gnu89
-USE_GMAKE= yes
USE_XORG= x11 xext xt sm ice
USE_LDCONFIG= yes
CONFIGURE_ENV= LIBS=${PTHREAD_LIBS}' -L${LOCALBASE}/lib' \
diff --git a/multimedia/shell-fm/Makefile b/multimedia/shell-fm/Makefile
index 2805d9430800..50bf1dfd5d9a 100644
--- a/multimedia/shell-fm/Makefile
+++ b/multimedia/shell-fm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: shell-fm
-# Date created: 15 December 2006
-# Whom: Nikos Ntarmos <ntarmos@ceid.upatras.gr>
-#
+# Created by: Nikos Ntarmos <ntarmos@ceid.upatras.gr>
# $FreeBSD$
-#
PORTNAME= shell-fm
PORTVERSION= 0.7
@@ -17,8 +13,8 @@ COMMENT= A command-line client for Last.FM
LIB_DEPENDS= ao:${PORTSDIR}/audio/libao \
mad:${PORTSDIR}/audio/libmad
+USES= gmake pkgconfig
USE_BZIP2= true
-USE_GMAKE= true
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -I${LOCALBASE}/include
diff --git a/multimedia/vdr-plugin-epgsearch/Makefile b/multimedia/vdr-plugin-epgsearch/Makefile
index 8550aa3d8782..a2cba558ab29 100644
--- a/multimedia/vdr-plugin-epgsearch/Makefile
+++ b/multimedia/vdr-plugin-epgsearch/Makefile
@@ -15,6 +15,7 @@ COMMENT= Video Disk Recorder - EPG search plugin
LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre \
tre:${PORTSDIR}/textproc/libtre
+USES= pkgconfig
USE_BZIP2= yes
PATCH_STRIP= -p1
PORTDOCS= COPYING README HISTORY
diff --git a/print/paps/Makefile b/print/paps/Makefile
index 4b22654a414f..22abd564c8ce 100644
--- a/print/paps/Makefile
+++ b/print/paps/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: paps
-# Date created: 8 January 2008
-# Whom: johans
-#
+# Created by: johans
# $FreeBSD$
-#
PORTNAME= paps
PORTVERSION= 0.6.8
@@ -20,5 +16,6 @@ MAN1= paps.1
GNU_CONFIGURE= yes
USE_GNOME= pango
+USES= pkgconfig
.include <bsd.port.mk>
diff --git a/security/kc/Makefile b/security/kc/Makefile
index 36209fcd12b0..385a2abee643 100644
--- a/security/kc/Makefile
+++ b/security/kc/Makefile
@@ -11,6 +11,7 @@ COMMENT= Console based password storing application
LICENSE= BSD
+USES= pkgconfig
LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2 \
pcre:${PORTSDIR}/devel/pcre
RUN_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser
diff --git a/textproc/p5-XML-Canonical/Makefile b/textproc/p5-XML-Canonical/Makefile
index 81fdf456eac3..6fc9a8fc7036 100644
--- a/textproc/p5-XML-Canonical/Makefile
+++ b/textproc/p5-XML-Canonical/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= p5-XML-GDOME>=0:${PORTSDIR}/textproc/p5-XML-GDOME
RUN_DEPENDS:= ${BUILD_DEPENDS}
LIB_DEPENDS= gdome:${PORTSDIR}/textproc/gdome2
-USES= perl5
+USES= perl5 pkgconfig
USE_PERL5= configure
MAN3= XML::Canonical.3
diff --git a/www/newsbeuter/Makefile b/www/newsbeuter/Makefile
index 35a22a2f9024..5da666bccaa4 100644
--- a/www/newsbeuter/Makefile
+++ b/www/newsbeuter/Makefile
@@ -17,8 +17,7 @@ LIB_DEPENDS= stfl.1:${PORTSDIR}/devel/stfl \
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USE_GMAKE= yes
-USES= gettext ncurses
+USES= gettext ncurses gmake pkgconfig
USE_PERL5_BUILD=yes
USE_SQLITE= yes
USE_GNOME= libxml2
diff --git a/www/npapi-xine/Makefile b/www/npapi-xine/Makefile
index 9585fe506be2..721b464cb07b 100644
--- a/www/npapi-xine/Makefile
+++ b/www/npapi-xine/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: npapi-xine
-# Date created: 03 February 2007
-# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
-#
+# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= xine
PORTVERSION= 1.0.2
@@ -18,6 +14,7 @@ COMMENT= Embed Xine player into browser
LIB_DEPENDS= xine.2:${PORTSDIR}/multimedia/libxine
+USES= pkgconfig
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_NPAPI= native
diff --git a/x11-wm/herbstluftwm/Makefile b/x11-wm/herbstluftwm/Makefile
index 484977991649..6f9cb6c2aaa6 100644
--- a/x11-wm/herbstluftwm/Makefile
+++ b/x11-wm/herbstluftwm/Makefile
@@ -12,7 +12,7 @@ LICENSE= BSD
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_XORG= x11 xinerama
USE_GNOME= glib20
diff --git a/x11/setlayout/Makefile b/x11/setlayout/Makefile
index add84c30f516..b1bef7063214 100644
--- a/x11/setlayout/Makefile
+++ b/x11/setlayout/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: setlayout
-# Date created: 17 December 2007
-# Whom: oleg@bsdpower.com
-#
+# Created by: oleg@bsdpower.com
# $FreeBSD$
-#
PORTNAME= setlayout
DISTVERSION= 20080210
@@ -15,6 +11,7 @@ EXTRACT_ONLY= #none
MAINTAINER= oleg@bsdpower.com
COMMENT= Arrange desktops in an MxN grid layout
+USES= pkgconfig
USE_XORG= x11
NO_WRKSUBDIR= yes
PLIST_FILES= bin/${PORTNAME}