aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-09-10 01:23:13 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-09-10 01:23:13 +0000
commit327a5adb419b8c0983dff937479883231be2bbfa (patch)
tree47c1f6f84a01793d85bccb57539d9343fb33b291
parent04214ff398e967fa0fdb30f4765466d03f0b3623 (diff)
downloadports-327a5adb419b8c0983dff937479883231be2bbfa.tar.gz
ports-327a5adb419b8c0983dff937479883231be2bbfa.zip
Notes
-rw-r--r--math/giacxcas/Makefile18
-rw-r--r--math/giacxcas/distinfo4
-rw-r--r--math/giacxcas/pkg-plist28
3 files changed, 38 insertions, 12 deletions
diff --git a/math/giacxcas/Makefile b/math/giacxcas/Makefile
index fe012335cbb3..232468dc18d3 100644
--- a/math/giacxcas/Makefile
+++ b/math/giacxcas/Makefile
@@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= giacxcas
-PORTVERSION= 1.0.0
-PORTREVISION= 1
+PORTVERSION= 1.1.0
CATEGORIES= math
MASTER_SITES= http://www-fourier.ujf-grenoble.fr/~parisse/giac/freebsd/ \
- http://people.math.jussieu.fr/~han/xcas/sources/
+ http://www.math.jussieu.fr/~han/xcas/sources/
DISTFILES= fltk-giac.tar.gz CoCoALib-0.9950.tgz giac-${PORTVERSION}.tar.gz
DIST_SUBDIR= ${PORTNAME}
@@ -17,21 +16,20 @@ LICENSE= GPLv3
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
${LOCALBASE}/lib/libntl.a:${PORTSDIR}/math/ntl
-LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp \
- pari:${PORTSDIR}/math/pari \
- mpfr:${PORTSDIR}/math/mpfr \
- gsl:${PORTSDIR}/math/gsl \
- lapack:${PORTSDIR}/math/lapack
+LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
+ libpari.so:${PORTSDIR}/math/pari \
+ libmpfr.so:${PORTSDIR}/math/mpfr \
+ libgsl.so:${PORTSDIR}/math/gsl \
+ liblapack.so:${PORTSDIR}/math/lapack
NO_CDROM= French documentation is for non-commercial use only
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_GL= gl
USE_XORG= xcursor xft xi
USE_TEX= latex:build dvipsk:build
USE_LDCONFIG= yes
-USES= gettext
+USES= gettext gmake
DOCSDIR= ${PREFIX}/share/doc/giac
PORTDOCS= *
diff --git a/math/giacxcas/distinfo b/math/giacxcas/distinfo
index 20074b1ddf6c..080b44cb094f 100644
--- a/math/giacxcas/distinfo
+++ b/math/giacxcas/distinfo
@@ -2,5 +2,5 @@ SHA256 (giacxcas/fltk-giac.tar.gz) = 538243c536a62e562bc26dec1c54454f54ce614cc54
SIZE (giacxcas/fltk-giac.tar.gz) = 4776876
SHA256 (giacxcas/CoCoALib-0.9950.tgz) = b30d840593e1930c1629467918b508c429e0a983ef0d1343eab570f238275678
SIZE (giacxcas/CoCoALib-0.9950.tgz) = 4120680
-SHA256 (giacxcas/giac-1.0.0.tar.gz) = 35bc4a366ad26a0ff8f96d728f625b4f7070fa8b64976c1b82d1392bd78be67b
-SIZE (giacxcas/giac-1.0.0.tar.gz) = 32735131
+SHA256 (giacxcas/giac-1.1.0.tar.gz) = 23eaad028abc2e5453c8ad5029c5610e4f051f9385973832ec0785cf6cbfe5eb
+SIZE (giacxcas/giac-1.1.0.tar.gz) = 45684044
diff --git a/math/giacxcas/pkg-plist b/math/giacxcas/pkg-plist
index 310d83bd68e8..b8ffb41a1c52 100644
--- a/math/giacxcas/pkg-plist
+++ b/math/giacxcas/pkg-plist
@@ -41,6 +41,7 @@ include/giac/modfactor.h
include/giac/modpoly.h
include/giac/monomial.h
include/giac/moyal.h
+include/giac/myostream.h
include/giac/pari.h
include/giac/permu.h
include/giac/plot.h
@@ -75,6 +76,16 @@ lib/libgiac.so
lib/libgiac.so.0
share/application-registry/xcas.applications
share/applications/xcas.desktop
+share/icons/hicolor/256x256/apps/xcas.png
+share/icons/hicolor/256x256/mimetypes/application-x-xcas.png
+share/icons/hicolor/128x128/apps/xcas.png
+share/icons/hicolor/128x128/mimetypes/application-x-xcas.png
+share/icons/hicolor/64x64/apps/xcas.png
+share/icons/hicolor/64x64/mimetypes/application-x-xcas.png
+share/icons/hicolor/32x32/apps/xcas.png
+share/icons/hicolor/32x32/mimetypes/application-x-xcas.png
+share/icons/hicolor/16x16/apps/xcas.png
+share/icons/hicolor/16x16/mimetypes/application-x-xcas.png
share/locale/de/LC_MESSAGES/giac.mo
share/locale/el/LC_MESSAGES/giac.mo
share/locale/en/LC_MESSAGES/giac.mo
@@ -84,6 +95,23 @@ share/locale/it/LC_MESSAGES/giac.mo
share/locale/pt/LC_MESSAGES/giac.mo
share/locale/zh/LC_MESSAGES/giac.mo
share/pixmaps/xcas.xpm
+@dirrmtry share/icons/hicolor/256x256/mimetypes
+@dirrmtry share/icons/hicolor/256x256/apps
+@dirrmtry share/icons/hicolor/256x256
+@dirrmtry share/icons/hicolor/128x128/mimetypes
+@dirrmtry share/icons/hicolor/128x128/apps
+@dirrmtry share/icons/hicolor/128x128
+@dirrmtry share/icons/hicolor/64x64/mimetypes
+@dirrmtry share/icons/hicolor/64x64/apps
+@dirrmtry share/icons/hicolor/64x64
+@dirrmtry share/icons/hicolor/32x32/mimetypes
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/16x16/mimetypes
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/16x16
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
@dirrmtry share/applications
@dirrmtry share/application-registry
@dirrm include/giac