aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-01-03 23:21:23 +0000
committerWill Andrews <will@FreeBSD.org>2001-01-03 23:21:23 +0000
commit45134e244219a5a577db739526b0fc25a2e01fc6 (patch)
treeae501ac5eb501c89425c0b2234521cfb2d2dcfad
parent0bfbdfaac8ccfa5f6fc5076575071145595c2dd6 (diff)
downloadports-45134e244219a5a577db739526b0fc25a2e01fc6.tar.gz
ports-45134e244219a5a577db739526b0fc25a2e01fc6.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Apache-AddHostPath/Makefile23
-rw-r--r--www/p5-Apache-AddHostPath/distinfo1
-rw-r--r--www/p5-Apache-AddHostPath/pkg-comment1
-rw-r--r--www/p5-Apache-AddHostPath/pkg-descr13
-rw-r--r--www/p5-Apache-AddHostPath/pkg-plist3
6 files changed, 42 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 2435e2a404bb..62aabc218ebd 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -131,6 +131,7 @@
SUBDIR += oops
SUBDIR += p5-Apache
SUBDIR += p5-Apache-ASP
+ SUBDIR += p5-Apache-AddHostPath
SUBDIR += p5-Apache-Archive
SUBDIR += p5-Apache-AuthCookie
SUBDIR += p5-Apache-AuthTicket
diff --git a/www/p5-Apache-AddHostPath/Makefile b/www/p5-Apache-AddHostPath/Makefile
new file mode 100644
index 000000000000..6f1de3440b29
--- /dev/null
+++ b/www/p5-Apache-AddHostPath/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: Apache::AddHostPath
+# Date created: 04 Nov 2000
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-AddHostPath
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Apache::AddHostPath.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Apache-AddHostPath/distinfo b/www/p5-Apache-AddHostPath/distinfo
new file mode 100644
index 000000000000..d85f45fbe91f
--- /dev/null
+++ b/www/p5-Apache-AddHostPath/distinfo
@@ -0,0 +1 @@
+MD5 (Apache-AddHostPath-0.02.tar.gz) = 1ab6fde8659285d70e084c3c1c99589f
diff --git a/www/p5-Apache-AddHostPath/pkg-comment b/www/p5-Apache-AddHostPath/pkg-comment
new file mode 100644
index 000000000000..231aec3ea03e
--- /dev/null
+++ b/www/p5-Apache-AddHostPath/pkg-comment
@@ -0,0 +1 @@
+Perl interface for transforming a requested URI based on host/port
diff --git a/www/p5-Apache-AddHostPath/pkg-descr b/www/p5-Apache-AddHostPath/pkg-descr
new file mode 100644
index 000000000000..7e18a096c8a7
--- /dev/null
+++ b/www/p5-Apache-AddHostPath/pkg-descr
@@ -0,0 +1,13 @@
+Apache::AddHostPath is a perl module that can transform a requested URI based
+on the hostname and port number from the http request header. It allows you
+to manage an arbitrary number of domains/subdomains all pointed at the same
+document root, but for which you want a combination of shared and distinct
+files. Essentially, the module implements Apache's URI translation phase by
+attempting to use some or all of the URL hostname and port number as the base
+of the URI. It simply does file and directory existence tests on a series
+of URIs (from most-specific to least-specific) and sets the URI to the
+most specific match.
+
+Author: Robert C W Jenks <rjenks@cvsroot.org>
+
+--will
diff --git a/www/p5-Apache-AddHostPath/pkg-plist b/www/p5-Apache-AddHostPath/pkg-plist
new file mode 100644
index 000000000000..096401a077a4
--- /dev/null
+++ b/www/p5-Apache-AddHostPath/pkg-plist
@@ -0,0 +1,3 @@
+lib/perl5/site_perl/%%PERL_VER%%/Apache/AddHostPath.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/AddHostPath/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/AddHostPath