aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2012-12-17 06:15:27 +0000
committerAndrej Zverev <az@FreeBSD.org>2012-12-17 06:15:27 +0000
commit4603fee495c39760f26ff412f82621f02102e0fe (patch)
treef1474faebc87d10e4fb68c74e95047fe5ecd8ebc
parentca9da06ad1b5c76a9f22078699ba52131f20f53e (diff)
downloadports-4603fee495c39760f26ff412f82621f02102e0fe.tar.gz
ports-4603fee495c39760f26ff412f82621f02102e0fe.zip
Notes
-rw-r--r--astro/p5-Astro-SpaceTrack/Makefile13
-rw-r--r--astro/p5-Astro-satpass/Makefile8
-rw-r--r--graphics/p5-Geometry-Primitive/Makefile8
-rw-r--r--graphics/p5-Graph-ReadWrite/Makefile9
-rw-r--r--graphics/p5-Image-Info/Makefile9
-rw-r--r--graphics/p5-Image-Pngslimmer/Makefile9
-rw-r--r--graphics/p5-SWF-File/Makefile9
-rw-r--r--science/p5-Geo-Coordinates-Converter/Makefile9
-rw-r--r--textproc/p5-Pod-POM/Makefile9
9 files changed, 9 insertions, 74 deletions
diff --git a/astro/p5-Astro-SpaceTrack/Makefile b/astro/p5-Astro-SpaceTrack/Makefile
index b553d277e4f8..65f1d51b0f6a 100644
--- a/astro/p5-Astro-SpaceTrack/Makefile
+++ b/astro/p5-Astro-SpaceTrack/Makefile
@@ -29,15 +29,4 @@ MAN1= SpaceTrack.1
MAN3= Astro::SpaceTrack.3 \
Astro::SpaceTrack::BulkData.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501000
-BUILD_DEPENDS+= p5-IO-Compress>=0:${PORTSDIR}/archivers/p5-IO-Compress
-RUN_DEPENDS+= p5-IO-Compress>=0:${PORTSDIR}/archivers/p5-IO-Compress
-.endif
-
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/astro/p5-Astro-satpass/Makefile b/astro/p5-Astro-satpass/Makefile
index 6eee399964ca..739b514a5378 100644
--- a/astro/p5-Astro-satpass/Makefile
+++ b/astro/p5-Astro-satpass/Makefile
@@ -63,10 +63,4 @@ RUN_DEPENDS+= p5-Geo-WebService-Elevation-USGS>=0:${PORTSDIR}/science/p5-Geo-Web
RUN_DEPENDS+= p5-SOAP-Lite>=0:${PORTSDIR}/net/p5-SOAP-Lite
.endif
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-Geometry-Primitive/Makefile b/graphics/p5-Geometry-Primitive/Makefile
index 3ae65482d7f5..0de230852e44 100644
--- a/graphics/p5-Geometry-Primitive/Makefile
+++ b/graphics/p5-Geometry-Primitive/Makefile
@@ -37,10 +37,4 @@ MAN3= Geometry::Primitive.3 \
Geometry::Primitive::Rectangle.3 \
Geometry::Primitive::Shape.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-RUN_DEPENDS+= p5-Math-Complex>=1.56:${PORTSDIR}/math/p5-Math-Complex
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-Graph-ReadWrite/Makefile b/graphics/p5-Graph-ReadWrite/Makefile
index 163055a57c95..a93b23d5ca49 100644
--- a/graphics/p5-Graph-ReadWrite/Makefile
+++ b/graphics/p5-Graph-ReadWrite/Makefile
@@ -36,11 +36,4 @@ MAN3= Graph::Reader.3 \
post-patch:
@${REINPLACE_CMD} -e 's|Graph-ReadWrite|Graph::ReadWrite|' ${WRKSRC}/Makefile.PL
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
-RUN_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-Image-Info/Makefile b/graphics/p5-Image-Info/Makefile
index 41001c57c1d0..15bdda07875f 100644
--- a/graphics/p5-Image-Info/Makefile
+++ b/graphics/p5-Image-Info/Makefile
@@ -35,11 +35,4 @@ MAN3= Bundle::Image::Info::Everything.3 \
Image::Info::XBM.3 \
Image::Info::XPM.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501000
-RUN_DEPENDS+= p5-IO-Compress>=0:${PORTSDIR}/archivers/p5-IO-Compress
-BUILD_DEPENDS+= p5-IO-Compress>=0:${PORTSDIR}/archivers/p5-IO-Compress
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-Image-Pngslimmer/Makefile b/graphics/p5-Image-Pngslimmer/Makefile
index 90843aabc5cb..d9a6ec99b4e4 100644
--- a/graphics/p5-Image-Pngslimmer/Makefile
+++ b/graphics/p5-Image-Pngslimmer/Makefile
@@ -19,11 +19,4 @@ PERL_CONFIGURE= yes
MAN3= Image::Pngslimmer.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500903
-RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
-BUILD_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-SWF-File/Makefile b/graphics/p5-SWF-File/Makefile
index 309e89ff4d24..6768113f1c39 100644
--- a/graphics/p5-SWF-File/Makefile
+++ b/graphics/p5-SWF-File/Makefile
@@ -32,11 +32,4 @@ post-patch:
post-configure:
@${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500903
-RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
-BUILD_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/science/p5-Geo-Coordinates-Converter/Makefile b/science/p5-Geo-Coordinates-Converter/Makefile
index f7d294427ecf..8c92743e5488 100644
--- a/science/p5-Geo-Coordinates-Converter/Makefile
+++ b/science/p5-Geo-Coordinates-Converter/Makefile
@@ -29,11 +29,4 @@ MAN3= Geo::Coordinates::Converter::Datum.3 \
Geo::Coordinates::Converter::Format.3 \
Geo::Coordinates::Converter::Format::ISO6709.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-parent>0:${PORTSDIR}/devel/p5-parent
-RUN_DEPENDS+= p5-parent>0:${PORTSDIR}/devel/p5-parent
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/p5-Pod-POM/Makefile b/textproc/p5-Pod-POM/Makefile
index 7b13b2e79c62..27815d0bfc45 100644
--- a/textproc/p5-Pod-POM/Makefile
+++ b/textproc/p5-Pod-POM/Makefile
@@ -44,11 +44,4 @@ MAN3= Pod::POM.3 \
Pod::POM::View::Pod.3 \
Pod::POM::View::Text.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
-RUN_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>