aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2003-08-27 17:24:06 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2003-08-27 17:24:06 +0000
commit4895a28d7f92240eac4188ac40e391c865caef57 (patch)
tree1f63c6a5020c9dac15b68faa5b9ae4a8c0984ecf
parent5360b147da9caee835e4105a8ff1cda69f925bba (diff)
downloadports-4895a28d7f92240eac4188ac40e391c865caef57.tar.gz
ports-4895a28d7f92240eac4188ac40e391c865caef57.zip
Notes
-rw-r--r--math/Makefile1
-rw-r--r--math/ruby-bitset/Makefile29
-rw-r--r--math/ruby-bitset/distinfo1
-rw-r--r--math/ruby-bitset/pkg-descr4
-rw-r--r--math/ruby-bitset/pkg-plist4
5 files changed, 39 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index e3b1906290a7..d073215844f2 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -149,6 +149,7 @@
SUBDIR += rcalc
SUBDIR += rpc
SUBDIR += ruby-algebra
+ SUBDIR += ruby-bitset
SUBDIR += ruby-bitvector
SUBDIR += ruby-gmp
SUBDIR += ruby-gnuplot
diff --git a/math/ruby-bitset/Makefile b/math/ruby-bitset/Makefile
new file mode 100644
index 000000000000..e8a84f292f4f
--- /dev/null
+++ b/math/ruby-bitset/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: Ruby/BitSet
+# Date created: 30 October 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bitset
+PORTVERSION= 0.6.1
+CATEGORIES= math ruby
+MASTER_SITES= http://www.moonwolf.com/ruby/archive/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= A bit set library for Ruby
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample/* ${RUBY_MODEXAMPLESDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/ruby-bitset/distinfo b/math/ruby-bitset/distinfo
new file mode 100644
index 000000000000..61a7806ca14f
--- /dev/null
+++ b/math/ruby-bitset/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/bitset-0.6.1.tar.gz) = fe8ad1c429e3d615525d407c02df00f4
diff --git a/math/ruby-bitset/pkg-descr b/math/ruby-bitset/pkg-descr
new file mode 100644
index 000000000000..f59666cc579b
--- /dev/null
+++ b/math/ruby-bitset/pkg-descr
@@ -0,0 +1,4 @@
+Ruby/BitSet is a bit set library for boolean operation.
+
+Author: MoonWolf <moonwolf@moonwolf.com>
+WWW: http://raa.ruby-lang.org/list.rhtml?name=bitset
diff --git a/math/ruby-bitset/pkg-plist b/math/ruby-bitset/pkg-plist
new file mode 100644
index 000000000000..ba7fca7b81fe
--- /dev/null
+++ b/math/ruby-bitset/pkg-plist
@@ -0,0 +1,4 @@
+%%RUBY_SITEARCHLIBDIR%%/bitset.so
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/htmlentity.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/xmlchar.rb
+%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%