aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-08-02 10:06:15 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-08-02 10:06:15 +0000
commit4e803096866cb72e99754042fd840f714893c081 (patch)
treef6af21525f1be393b2b13467a73abdbe2b51c3a2
parente4cb58ea1568edb74441f50528aa96fcbd807c1d (diff)
downloadports-4e803096866cb72e99754042fd840f714893c081.tar.gz
ports-4e803096866cb72e99754042fd840f714893c081.zip
Notes
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Plucene-Simple/Makefile31
-rw-r--r--textproc/p5-Plucene-Simple/distinfo3
-rw-r--r--textproc/p5-Plucene-Simple/pkg-descr8
-rw-r--r--textproc/p5-Plucene-Simple/pkg-plist2
5 files changed, 45 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 82a664518847..2ed3cfaa1962 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -401,6 +401,7 @@
SUBDIR += p5-Petal-Utils
SUBDIR += p5-Plucene
SUBDIR += p5-Plucene-Plugin-Analyzer-SnowballAnalyzer
+ SUBDIR += p5-Plucene-Simple
SUBDIR += p5-Pod-Constants
SUBDIR += p5-Pod-DocBook
SUBDIR += p5-Pod-Escapes
diff --git a/textproc/p5-Plucene-Simple/Makefile b/textproc/p5-Plucene-Simple/Makefile
new file mode 100644
index 000000000000..f96f38d1597f
--- /dev/null
+++ b/textproc/p5-Plucene-Simple/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Plucene-Simple
+# Date created: 2 August 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Plucene-Simple
+DISTVERSION= 1.04
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/S/ST/STRYTOAST
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME:S/-//}-${PORTVERSION}
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= An interface to Plucene
+
+BUILD_DEPENDS= p5-Time-Piece>=1.08:${PORTSDIR}/devel/p5-Time-Piece \
+ p5-Time-Piece-Range>=1.0:${PORTSDIR}/devel/p5-Time-Piece-Range \
+ p5-Plucene>=1.09:${PORTSDIR}/textproc/p5-Plucene \
+ p5-File-Find-Rule>=0.10:${PORTSDIR}/devel/p5-File-Find-Rule \
+ p5-File-Slurp>=2002.1031:${PORTSDIR}/devel/p5-File-Slurp \
+ p5-Test-Class>=0.03:${PORTSDIR}/devel/p5-Test-Class
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= YES
+
+MAN3= ${PORTNAME:S/-/::/g}.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Plucene-Simple/distinfo b/textproc/p5-Plucene-Simple/distinfo
new file mode 100644
index 000000000000..ad6bcb96b4a2
--- /dev/null
+++ b/textproc/p5-Plucene-Simple/distinfo
@@ -0,0 +1,3 @@
+MD5 (PluceneSimple-1.04.tar.gz) = caa098838dcae2e1683d72be59dcbbf9
+SHA256 (PluceneSimple-1.04.tar.gz) = 00c2eb91d035a1dd4522a9ffd01817b4ac32605159671868ccf6b23607a44b1f
+SIZE (PluceneSimple-1.04.tar.gz) = 6133
diff --git a/textproc/p5-Plucene-Simple/pkg-descr b/textproc/p5-Plucene-Simple/pkg-descr
new file mode 100644
index 000000000000..0d7c6fe16a19
--- /dev/null
+++ b/textproc/p5-Plucene-Simple/pkg-descr
@@ -0,0 +1,8 @@
+This provides a simple interface to Plucene. Plucene is large and multi-
+featured, and it expected that users will subclass it, and tie all the
+pieces together to suit their own needs. Plucene::Simple is, therefore,
+just one way to use Plucene. It's not expected that it will do exactly
+what *you* want, but you can always use it as an example of how to
+build your own interface.
+
+WWW: http://search.cpan.org/dist/PluceneSimple/
diff --git a/textproc/p5-Plucene-Simple/pkg-plist b/textproc/p5-Plucene-Simple/pkg-plist
new file mode 100644
index 000000000000..bc86ae43f967
--- /dev/null
+++ b/textproc/p5-Plucene-Simple/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Plucene/Simple.pm
+@dirrmtry %%SITE_PERL%%/Plucene