aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2016-05-13 19:01:27 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2016-05-13 19:01:27 +0000
commit554d4fd2daeceb762238bc49ad43b337b017e4d0 (patch)
tree4416eeb4d00e522533bea4ac4d43e5f71c4a30f5
parent742fe64a95f947a3cc13b0d2adb767993fb3f2c6 (diff)
downloadports-554d4fd2daeceb762238bc49ad43b337b017e4d0.tar.gz
ports-554d4fd2daeceb762238bc49ad43b337b017e4d0.zip
Notes
-rw-r--r--editors/gate/Makefile1
-rw-r--r--editors/gate/files/patch-Makefile.in2
-rw-r--r--editors/gate/files/patch-configure9
-rw-r--r--editors/gate/files/patch-gate.h11
-rw-r--r--editors/gate/files/patch-line.c11
-rw-r--r--editors/gate/files/patch-main.c11
-rw-r--r--editors/gate/files/patch-spel.c22
-rw-r--r--editors/gate/files/patch-subs.c13
8 files changed, 64 insertions, 16 deletions
diff --git a/editors/gate/Makefile b/editors/gate/Makefile
index 9025e680cd2b..f0a67ffc5737 100644
--- a/editors/gate/Makefile
+++ b/editors/gate/Makefile
@@ -15,6 +15,7 @@ RUN_DEPENDS= aspell:textproc/aspell
USES= ncurses
GNU_CONFIGURE= yes
+USE_CSTD= gnu89
CONFIGURE_ARGS= --with-aspell=${LOCALBASE}/bin/aspell
ALL_TARGET= gate gate.1
diff --git a/editors/gate/files/patch-Makefile.in b/editors/gate/files/patch-Makefile.in
index 215976d53d47..ea70d12af278 100644
--- a/editors/gate/files/patch-Makefile.in
+++ b/editors/gate/files/patch-Makefile.in
@@ -1,6 +1,6 @@
--- Makefile.in.orig 2003-06-19 16:47:56 UTC
+++ Makefile.in
-@@ -25,7 +25,7 @@ DIST= README $(SRCS) gate.h config.h.in
+@@ -25,7 +25,7 @@ DIST= README $(SRCS) gate.h config.h.in
Makefile.in gate.1.C gate.help CHANGES
gate: $(OBJS)
diff --git a/editors/gate/files/patch-configure b/editors/gate/files/patch-configure
index 579cf63aaf5b..d15f08f5a38b 100644
--- a/editors/gate/files/patch-configure
+++ b/editors/gate/files/patch-configure
@@ -9,3 +9,12 @@
LIBS="-l$i $ac_func_search_save_LIBS"
cat > conftest.$ac_ext <<EOF
#line 1773 "configure"
+@@ -2123,7 +2123,7 @@ res_datadir=`eval "echo $datadir"`
+ prefix=$gate_prefix
+
+ cat >> confdefs.h <<EOF
+-#define HELP_FILE "${res_datadir}/gate.help"
++#define HELP_FILE "/usr/local/share/gate/gate.help"
+ EOF
+
+
diff --git a/editors/gate/files/patch-gate.h b/editors/gate/files/patch-gate.h
new file mode 100644
index 000000000000..f4873775e0f9
--- /dev/null
+++ b/editors/gate/files/patch-gate.h
@@ -0,0 +1,11 @@
+--- gate.h.orig 2005-01-24 06:24:26 UTC
++++ gate.h
+@@ -211,7 +211,7 @@ int mv_file(char *src, char *dst);
+
+ /* LINE.C */
+ int outcol(char *str,int n,int icol);
+-int getline(char *bf, char *wbf, int *wcol, char *prompt);
++int get_line(char *bf, char *wbf, int *wcol, char *prompt);
+ void back_to_col(int ncol);
+ void print_to_index(int newi);
+
diff --git a/editors/gate/files/patch-line.c b/editors/gate/files/patch-line.c
new file mode 100644
index 000000000000..c36f28220fe7
--- /dev/null
+++ b/editors/gate/files/patch-line.c
@@ -0,0 +1,11 @@
+--- line.c.orig 2003-06-19 15:06:54 UTC
++++ line.c
+@@ -82,7 +82,7 @@ void mcursor(int *col, int *lin, char ch
+ * If <wbuf> is NULL, then this does a more ordinary, wrapless read.
+ */
+
+-int getline(char *buf, char *wbuf, int *wcol, char *prompt)
++int get_line(char *buf, char *wbuf, int *wcol, char *prompt)
+ {
+ int linemode= (wbuf == NULL); /* reading single line, not file */
+ int wrapon= !linemode; /* is line wrap enabled? */
diff --git a/editors/gate/files/patch-main.c b/editors/gate/files/patch-main.c
new file mode 100644
index 000000000000..fa47f6591b78
--- /dev/null
+++ b/editors/gate/files/patch-main.c
@@ -0,0 +1,11 @@
+--- main.c.orig 2005-01-24 17:05:01 UTC
++++ main.c
+@@ -87,7 +87,7 @@ int main(int argc,char **argv)
+ wcol= 0;
+ for (;;)
+ {
+- if (getline(bf[sw], bf[!sw], &wcol, prompt))
++ if (get_line(bf[sw], bf[!sw], &wcol, prompt))
+ {
+ putchar('\n');
+ done(RET_ENTER);
diff --git a/editors/gate/files/patch-spel.c b/editors/gate/files/patch-spel.c
index dfde6de5f20a..e04fda6d22f8 100644
--- a/editors/gate/files/patch-spel.c
+++ b/editors/gate/files/patch-spel.c
@@ -1,13 +1,11 @@
-diff --git spel.c spel.c
-index 5c53256..1e9ad04 100644
---- spel.c
+--- spel.c.orig 2003-06-19 16:55:51 UTC
+++ spel.c
-@@ -151,7 +151,7 @@ empty_repl()
- /* ADD_REPL - Add the given replacement to the list of replacements.
- * "replace" may be NULL to indicate that the word is to be ignored.
- */
--
-+void
- add_repl(char *word, int word_len, char *replace)
- {
- struct repl *r;
+@@ -683,7 +683,7 @@ int fix_word(char *line, int offset, int
+ for(;;)
+ {
+ subtask= 1;
+- if (getline(bf,NULL,&wcol,st))
++ if (get_line(bf,NULL,&wcol,st))
+ {
+ printf("\nSpell Check Interupted.\n");
+ return 1;
diff --git a/editors/gate/files/patch-subs.c b/editors/gate/files/patch-subs.c
index b5e61269fa9d..295bb224a02f 100644
--- a/editors/gate/files/patch-subs.c
+++ b/editors/gate/files/patch-subs.c
@@ -1,7 +1,14 @@
-diff --git subs.c subs.c
-index 287d9d3..a6caea9 100644
---- subs.c
+--- subs.c.orig 2005-01-24 06:16:01 UTC
+++ subs.c
+@@ -74,7 +74,7 @@ int ask_spell_subs(char **replace, int *
+ subtask= 1;
+ sprintf(st,"Replacement for \"%.*s\" (? for help): ",
+ strlen(match+1)-1, match+1);
+- if (getline(*replace= bf,NULL,wcol,st))
++ if (get_line(*replace= bf,NULL,wcol,st))
+ {
+ printf("\nSpell Check Interupted.\n");
+ do_subs= 'q';
@@ -429,7 +429,7 @@ int cliplast(char *lastbuf, int bufsize)
#endif