aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2016-01-08 04:46:37 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2016-01-08 04:46:37 +0000
commit5de147f82f4dbef0d7ffeda7337760d8ae5825db (patch)
tree75deaeb438c4661e05c68ee7c0ba8d757f7308f5
parent86ce13e106e71e7db42bdecdfbc75d5a1312b126 (diff)
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-hypothesis/Makefile25
-rw-r--r--devel/py-hypothesis/distinfo2
-rw-r--r--devel/py-hypothesis/pkg-descr6
4 files changed, 34 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f248bb890006..13c28fcf90ae 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4077,6 +4077,7 @@
SUBDIR += py-hgsubversion
SUBDIR += py-hgtools
SUBDIR += py-humanize
+ SUBIDR += py-hypothesis
SUBDIR += py-icalendar
SUBDIR += py-ice
SUBDIR += py-icu
diff --git a/devel/py-hypothesis/Makefile b/devel/py-hypothesis/Makefile
new file mode 100644
index 000000000000..f2596130826d
--- /dev/null
+++ b/devel/py-hypothesis/Makefile
@@ -0,0 +1,25 @@
+# Created by: Brendan Molloy <brendan+freebsd@bbqsrc.net>
+# $FreeBSD$
+
+PORTNAME= hypothesis
+PORTVERSION= 1.18.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= brendan+freebsd@bbqsrc.net
+COMMENT= Library for property based testing
+
+LICENSE= MPL
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+do-test:
+ @(cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test)
+
+.include <bsd.port.mk>
diff --git a/devel/py-hypothesis/distinfo b/devel/py-hypothesis/distinfo
new file mode 100644
index 000000000000..9006a7f70515
--- /dev/null
+++ b/devel/py-hypothesis/distinfo
@@ -0,0 +1,2 @@
+SHA256 (hypothesis-1.18.1.tar.gz) = 839d382393684e9544cfc855b6a19e1121391bd720a7ace5a6865408c0db0768
+SIZE (hypothesis-1.18.1.tar.gz) = 84868
diff --git a/devel/py-hypothesis/pkg-descr b/devel/py-hypothesis/pkg-descr
new file mode 100644
index 000000000000..d30cde22f7fa
--- /dev/null
+++ b/devel/py-hypothesis/pkg-descr
@@ -0,0 +1,6 @@
+Hypothesis is a library for testing your Python code against a much larger
+range of examples than you would ever want to write by hand. It's based on the
+Haskell library, Quickcheck, and is designed to integrate seamlessly into your
+existing Python unit testing work flow.
+
+WWW: https://github.com/DRMacIver/hypothesis