aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-13 01:50:57 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-13 01:50:57 +0000
commit6637f55607684a19e1b172cb1de0123450228aa0 (patch)
tree098338b080a4628438a448506f01fffef7f1370c
parent611a734e7730f12b513c098ef6ffc017f5ca6d0b (diff)
downloadports-6637f55607684a19e1b172cb1de0123450228aa0.tar.gz
ports-6637f55607684a19e1b172cb1de0123450228aa0.zip
Notes
-rw-r--r--misc/sword/Makefile15
-rw-r--r--misc/sword/distinfo6
-rw-r--r--misc/sword/files/patch-configure16
-rw-r--r--misc/sword/files/patch-configure.ac16
-rw-r--r--misc/sword/pkg-descr15
-rw-r--r--misc/sword/pkg-plist115
-rw-r--r--misc/sword15/Makefile15
-rw-r--r--misc/sword15/distinfo6
-rw-r--r--misc/sword15/files/patch-configure16
-rw-r--r--misc/sword15/files/patch-configure.ac16
-rw-r--r--misc/sword15/pkg-descr15
-rw-r--r--misc/sword15/pkg-plist115
12 files changed, 208 insertions, 158 deletions
diff --git a/misc/sword/Makefile b/misc/sword/Makefile
index 65cace6b5623..3a64eff493b9 100644
--- a/misc/sword/Makefile
+++ b/misc/sword/Makefile
@@ -6,17 +6,12 @@
#
PORTNAME= sword
-PORTVERSION= 1.5.7
+PORTVERSION= 1.5.8
CATEGORIES= misc
MASTER_SITES= ftp://ftp.crosswire.org/pub/sword/source/v1.5/ \
- ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-# 1.5.7a version fixes some build problems. Since there was no FreeBSD
-# version of 1.5.7 it's really no problem to put the a here. WRKSRC is also
-# just work/sword-1.5.7
-DISTFILES= ${DISTNAME}a${EXTRACT_SUFX}
-
-MAINTAINER= ports@FreeBSD.org
+ http://www.goodking.ca/pub/files/
+
+MAINTAINER= thomas@goodking.ca
COMMENT= A project framework for manipulating Bible texts
USE_GNOME= pkgconfig
@@ -45,7 +40,7 @@ post-patch:
${WRKSRC}/Makefile.in
post-install:
- @${MKDIR} -p ${PREFIX}/share/sword/mods.d
+ @${MKDIR} ${PREFIX}/share/sword/mods.d
.if !exists(${PREFIX}/etc/sword.conf)
@(cd ${WRKSRC} && make install_config)
.else
diff --git a/misc/sword/distinfo b/misc/sword/distinfo
index 5bb6f42c7935..a2f49f6af447 100644
--- a/misc/sword/distinfo
+++ b/misc/sword/distinfo
@@ -1,3 +1,3 @@
-MD5 (sword-1.5.7a.tar.gz) = e77801ac7abb7a940eb8a75d725e346f
-SHA256 (sword-1.5.7a.tar.gz) = 37f9e3e231f7ce65f9d0e6d8e9fee5467e632b1834c62327db5420fc14e50246
-SIZE (sword-1.5.7a.tar.gz) = 1535217
+MD5 (sword-1.5.8.tar.gz) = c36398c84bfb044c0c66ef3ffcf29400
+SHA256 (sword-1.5.8.tar.gz) = aeb57fe89716807f331eb17fcf23ef1ba3ad3e7018cd2d32560677ffe6937ce9
+SIZE (sword-1.5.8.tar.gz) = 1714799
diff --git a/misc/sword/files/patch-configure b/misc/sword/files/patch-configure
index aa6514ab106b..8ff7c16b76b2 100644
--- a/misc/sword/files/patch-configure
+++ b/misc/sword/files/patch-configure
@@ -1,13 +1,13 @@
---- configure.orig Tue Aug 17 13:48:32 2004
-+++ configure Tue Aug 17 13:49:13 2004
-@@ -20183,8 +20183,8 @@
+--- configure.orig Sun May 29 00:59:43 2005
++++ configure Mon Jul 10 14:10:06 2006
+@@ -20481,8 +20481,8 @@
echo "curl found - remote install options available"
- CURL_CFLAGS=`$CURL_CONFIG --cflags`
+ CURL_AM_CFLAGS=`$CURL_CONFIG --cflags`
CURL_LIBS=`$CURL_CONFIG --libs`
-- CXXFLAGS="$CXXFLAGS -DCURLAVAILABLE"
-- CFLAGS="$CFLAGS -DCURLAVAILABLE"
-+ CXXFLAGS="$CXXFLAGS -DCURLAVAILABLE $CURL_CFLAGS"
-+ CFLAGS="$CFLAGS -DCURLAVAILABLE $CURL_CFLAGS"
+- AM_CXXFLAGS="$AM_CXXFLAGS -DCURLAVAILABLE"
+- AM_CFLAGS="$AM_CFLAGS -DCURLAVAILABLE"
++ AM_CXXFLAGS="$AM_CXXFLAGS -DCURLAVAILABLE $CURL_AM_CFLAGS"
++ AM_CFLAGS="$AM_CFLAGS -DCURLAVAILABLE $CURL_AM_CFLAGS"
fi
fi
diff --git a/misc/sword/files/patch-configure.ac b/misc/sword/files/patch-configure.ac
index 64a367923b83..f461d8952bcf 100644
--- a/misc/sword/files/patch-configure.ac
+++ b/misc/sword/files/patch-configure.ac
@@ -1,13 +1,13 @@
---- configure.ac.orig Tue Aug 17 13:48:26 2004
-+++ configure.ac Tue Aug 17 13:48:53 2004
-@@ -151,8 +151,8 @@
+--- configure.ac.orig Mon Jul 10 18:22:50 2006
++++ configure.ac Mon Jul 10 18:23:13 2006
+@@ -187,8 +187,8 @@
echo "curl found - remote install options available"
- CURL_CFLAGS=`$CURL_CONFIG --cflags`
+ CURL_AM_CFLAGS=`$CURL_CONFIG --cflags`
CURL_LIBS=`$CURL_CONFIG --libs`
-- CXXFLAGS="$CXXFLAGS -DCURLAVAILABLE"
-- CFLAGS="$CFLAGS -DCURLAVAILABLE"
-+ CXXFLAGS="$CXXFLAGS -DCURLAVAILABLE $CURL_CFLAGS"
-+ CFLAGS="$CFLAGS -DCURLAVAILABLE $CURL_CFLAGS"
+- AM_CXXFLAGS="$AM_CXXFLAGS -DCURLAVAILABLE"
+- AM_CFLAGS="$AM_CFLAGS -DCURLAVAILABLE"
++ AM_CXXFLAGS="$AM_CXXFLAGS -DCURLAVAILABLE $CURL_AM_CFLAGS"
++ AM_CFLAGS="$AM_CFLAGS -DCURLAVAILABLE $CURL_AM_CFLAGS"
fi
fi
diff --git a/misc/sword/pkg-descr b/misc/sword/pkg-descr
index 288424dfcb59..4fb7725c1fc8 100644
--- a/misc/sword/pkg-descr
+++ b/misc/sword/pkg-descr
@@ -1,9 +1,8 @@
-The SWORD Project is an effort to create an ever expanding software package
-for research and study of God and His Word. The SWORD Bible Framework allows
-easy manipulation of Bible texts, commentaries, lexicons, dictionaries, etc.
-Many frontends are build using this framework. An installed module set may be
-shared between any frontend using the framework.
+The SWORD Project is an effort to create an ever expanding software
+package for research and study of God and His Word. The SWORD Bible
+Framework allows easy manipulation of Bible texts, commentaries,
+lexicons, dictionaries, etc. Many frontends are build using this
+framework. An installed module set may be shared between any frontend
+using the framework.
-WWW: http://www.crosswire.org/
-
-- Willem van Engen <wvengen@stack.nl>
+WWW: http://www.crosswire.org/sword
diff --git a/misc/sword/pkg-plist b/misc/sword/pkg-plist
index a236dc5b2e96..4d6129aa89dd 100644
--- a/misc/sword/pkg-plist
+++ b/misc/sword/pkg-plist
@@ -1,9 +1,9 @@
-etc/sword.conf
bin/addld
bin/diatheke
bin/imp2ld
bin/imp2vs
bin/installmgr
+bin/mkfastmod
bin/mod2imp
bin/mod2osis
bin/mod2vpl
@@ -11,10 +11,12 @@ bin/mod2zmod
bin/osis2mod
bin/vpl2mod
bin/vs2osisref
+etc/sword.conf
include/sword/Greek2Greek.h
include/sword/GreekChars.h
include/sword/canon.h
include/sword/cipherfil.h
+include/sword/curlftpt.h
include/sword/defs.h
include/sword/echomod.h
include/sword/encfiltmgr.h
@@ -22,7 +24,10 @@ include/sword/entriesblk.h
include/sword/femain.h
include/sword/filemgr.h
include/sword/flatapi.h
+include/sword/ftplib.h
+include/sword/ftplibftpt.h
include/sword/ftpparse.h
+include/sword/ftptrans.h
include/sword/gbffootnotes.h
include/sword/gbfheadings.h
include/sword/gbfhtml.h
@@ -52,17 +57,18 @@ include/sword/osisheadings.h
include/sword/osishtmlhref.h
include/sword/osislemma.h
include/sword/osismorph.h
+include/sword/osisosis.h
include/sword/osisplain.h
include/sword/osisredletterwords.h
include/sword/osisrtf.h
include/sword/osisscripref.h
include/sword/osisstrongs.h
include/sword/osiswebif.h
+include/sword/osiswordjs.h
include/sword/plainfootnotes.h
include/sword/plainhtml.h
include/sword/rawcom.h
include/sword/rawfiles.h
-include/sword/rawgbf.h
include/sword/rawgenbook.h
include/sword/rawld.h
include/sword/rawld4.h
@@ -75,6 +81,7 @@ include/sword/roman.h
include/sword/rtfhtml.h
include/sword/sapphire.h
include/sword/scsuutf8.h
+include/sword/stringmgr.h
include/sword/strkey.h
include/sword/swbasicfilter.h
include/sword/swbuf.h
@@ -84,13 +91,10 @@ include/sword/swcom.h
include/sword/swcomprs.h
include/sword/swconfig.h
include/sword/swdisp.h
-include/sword/swdisprtf.h
-include/sword/swdisprtfchap.h
include/sword/swfilter.h
include/sword/swfiltermgr.h
include/sword/swgenbook.h
include/sword/swinputmeth.h
-%%INSTALLMGR%%include/sword/swinstallmgr.h
include/sword/swkey.h
include/sword/swld.h
include/sword/swlocale.h
@@ -100,14 +104,11 @@ include/sword/swmgr.h
include/sword/swmodule.h
include/sword/swobject.h
include/sword/swoptfilter.h
-%%INSTALLMGR%%include/sword/swremotemgr.h
include/sword/swsearchable.h
include/sword/swtext.h
include/sword/swunicod.h
include/sword/swversion.h
-include/sword/swwinlog.h
include/sword/sysdata.h
-include/sword/tbdisp.h
include/sword/thmlfootnotes.h
include/sword/thmlgbf.h
include/sword/thmlheadings.h
@@ -122,11 +123,12 @@ include/sword/thmlscripref.h
include/sword/thmlstrongs.h
include/sword/thmlvariants.h
include/sword/thmlwebif.h
+include/sword/thmlwordjs.h
include/sword/treekey.h
include/sword/treekeyidx.h
include/sword/unicodertf.h
-include/sword/unixstr.h
include/sword/untgz.h
+include/sword/url.h
include/sword/utf16utf8.h
include/sword/utf8arshaping.h
include/sword/utf8bidireorder.h
@@ -139,10 +141,7 @@ include/sword/utf8nfc.h
include/sword/utf8nfkd.h
include/sword/utf8transliterator.h
include/sword/utf8utf16.h
-include/sword/utilconf.h
-include/sword/utilfuns.h
include/sword/utilstr.h
-include/sword/utilweb.h
include/sword/utilxml.h
include/sword/versekey.h
include/sword/zcom.h
@@ -153,39 +152,71 @@ include/sword/zlib.h
include/sword/zstr.h
include/sword/ztext.h
include/sword/zverse.h
+lib/libsword-1.5.8.so
lib/libsword.a
lib/libsword.la
lib/libsword.so
-lib/libsword.so.4
libdata/pkgconfig/sword.pc
-share/sword/locales.d/abbr.conf
-share/sword/locales.d/bg_BG-cp1251.conf
-share/sword/locales.d/cs.conf
-share/sword/locales.d/da.conf
-share/sword/locales.d/de.conf
-share/sword/locales.d/de_abbrev.conf
-share/sword/locales.d/en_GB.conf
-share/sword/locales.d/es.conf
-share/sword/locales.d/et.conf
-share/sword/locales.d/et_abbr.conf
-share/sword/locales.d/fi.conf
-share/sword/locales.d/fr.conf
-share/sword/locales.d/id.conf
-share/sword/locales.d/it.conf
-share/sword/locales.d/la.conf
-share/sword/locales.d/nl.conf
-share/sword/locales.d/no.conf
-share/sword/locales.d/pl.conf
-share/sword/locales.d/pt.conf
-share/sword/locales.d/pt_BR.conf
-share/sword/locales.d/ro.conf
-share/sword/locales.d/ru_RU-cp1251.conf
-share/sword/locales.d/ru_RU-koi8-r.conf
-share/sword/locales.d/sk.conf
-share/sword/locales.d/uk_UA-cp1251.conf
-share/sword/locales.d/uk_UA-koi8-u.conf
-@dirrm share/sword/locales.d
-@dirrm share/sword/mods.d
-@dirrm share/sword
+%%DATADIR%%/locales.d/abbr.conf
+%%DATADIR%%/locales.d/af-utf8.conf
+%%DATADIR%%/locales.d/af.conf
+%%DATADIR%%/locales.d/bg_BG-cp1251.conf
+%%DATADIR%%/locales.d/bg_BG-utf8.conf
+%%DATADIR%%/locales.d/cs-utf8.conf
+%%DATADIR%%/locales.d/cs.conf
+%%DATADIR%%/locales.d/da-utf8.conf
+%%DATADIR%%/locales.d/da.conf
+%%DATADIR%%/locales.d/de-utf8.conf
+%%DATADIR%%/locales.d/de.conf
+%%DATADIR%%/locales.d/de_abbrev-utf8.conf
+%%DATADIR%%/locales.d/de_abbrev.conf
+%%DATADIR%%/locales.d/en_GB.conf
+%%DATADIR%%/locales.d/es-utf8.conf
+%%DATADIR%%/locales.d/es.conf
+%%DATADIR%%/locales.d/et-utf8.conf
+%%DATADIR%%/locales.d/et.conf
+%%DATADIR%%/locales.d/et_abbr-utf8.conf
+%%DATADIR%%/locales.d/et_abbr.conf
+%%DATADIR%%/locales.d/fi-utf8.conf
+%%DATADIR%%/locales.d/fi.conf
+%%DATADIR%%/locales.d/fr-utf8.conf
+%%DATADIR%%/locales.d/fr.conf
+%%DATADIR%%/locales.d/hu-utf8.conf
+%%DATADIR%%/locales.d/hu.conf
+%%DATADIR%%/locales.d/id.conf
+%%DATADIR%%/locales.d/it-utf8.conf
+%%DATADIR%%/locales.d/it.conf
+%%DATADIR%%/locales.d/ko-utf8.conf
+%%DATADIR%%/locales.d/ko.conf
+%%DATADIR%%/locales.d/ko_abbrev-utf8.conf
+%%DATADIR%%/locales.d/ko_abbrev.conf
+%%DATADIR%%/locales.d/la.conf
+%%DATADIR%%/locales.d/lt-utf8.conf
+%%DATADIR%%/locales.d/nl.conf
+%%DATADIR%%/locales.d/no-utf8.conf
+%%DATADIR%%/locales.d/no.conf
+%%DATADIR%%/locales.d/pl-utf8.conf
+%%DATADIR%%/locales.d/pl.conf
+%%DATADIR%%/locales.d/pt-utf8.conf
+%%DATADIR%%/locales.d/pt.conf
+%%DATADIR%%/locales.d/pt_BR-utf8.conf
+%%DATADIR%%/locales.d/pt_BR.conf
+%%DATADIR%%/locales.d/ro.conf
+%%DATADIR%%/locales.d/ru_RU-cp1251.conf
+%%DATADIR%%/locales.d/ru_RU-koi8-r.conf
+%%DATADIR%%/locales.d/ru_RU-utf8.conf
+%%DATADIR%%/locales.d/sk-utf8.conf
+%%DATADIR%%/locales.d/sk.conf
+%%DATADIR%%/locales.d/sl.conf
+%%DATADIR%%/locales.d/sv-utf8.conf
+%%DATADIR%%/locales.d/sv.conf
+%%DATADIR%%/locales.d/uk_UA-cp1251.conf
+%%DATADIR%%/locales.d/uk_UA-koi8-u.conf
+%%DATADIR%%/locales.d/uk_UA-utf8.conf
+@dirrm %%DATADIR%%/mods.d
+@dirrm %%DATADIR%%/locales.d
+@dirrm %%DATADIR%%
+@dirrm share/nls/en_US.US-ASCII
+@dirrm share/nls/POSIX
@dirrm lib/sword
@dirrm include/sword
diff --git a/misc/sword15/Makefile b/misc/sword15/Makefile
index 65cace6b5623..3a64eff493b9 100644
--- a/misc/sword15/Makefile
+++ b/misc/sword15/Makefile
@@ -6,17 +6,12 @@
#
PORTNAME= sword
-PORTVERSION= 1.5.7
+PORTVERSION= 1.5.8
CATEGORIES= misc
MASTER_SITES= ftp://ftp.crosswire.org/pub/sword/source/v1.5/ \
- ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-# 1.5.7a version fixes some build problems. Since there was no FreeBSD
-# version of 1.5.7 it's really no problem to put the a here. WRKSRC is also
-# just work/sword-1.5.7
-DISTFILES= ${DISTNAME}a${EXTRACT_SUFX}
-
-MAINTAINER= ports@FreeBSD.org
+ http://www.goodking.ca/pub/files/
+
+MAINTAINER= thomas@goodking.ca
COMMENT= A project framework for manipulating Bible texts
USE_GNOME= pkgconfig
@@ -45,7 +40,7 @@ post-patch:
${WRKSRC}/Makefile.in
post-install:
- @${MKDIR} -p ${PREFIX}/share/sword/mods.d
+ @${MKDIR} ${PREFIX}/share/sword/mods.d
.if !exists(${PREFIX}/etc/sword.conf)
@(cd ${WRKSRC} && make install_config)
.else
diff --git a/misc/sword15/distinfo b/misc/sword15/distinfo
index 5bb6f42c7935..a2f49f6af447 100644
--- a/misc/sword15/distinfo
+++ b/misc/sword15/distinfo
@@ -1,3 +1,3 @@
-MD5 (sword-1.5.7a.tar.gz) = e77801ac7abb7a940eb8a75d725e346f
-SHA256 (sword-1.5.7a.tar.gz) = 37f9e3e231f7ce65f9d0e6d8e9fee5467e632b1834c62327db5420fc14e50246
-SIZE (sword-1.5.7a.tar.gz) = 1535217
+MD5 (sword-1.5.8.tar.gz) = c36398c84bfb044c0c66ef3ffcf29400
+SHA256 (sword-1.5.8.tar.gz) = aeb57fe89716807f331eb17fcf23ef1ba3ad3e7018cd2d32560677ffe6937ce9
+SIZE (sword-1.5.8.tar.gz) = 1714799
diff --git a/misc/sword15/files/patch-configure b/misc/sword15/files/patch-configure
index aa6514ab106b..8ff7c16b76b2 100644
--- a/misc/sword15/files/patch-configure
+++ b/misc/sword15/files/patch-configure
@@ -1,13 +1,13 @@
---- configure.orig Tue Aug 17 13:48:32 2004
-+++ configure Tue Aug 17 13:49:13 2004
-@@ -20183,8 +20183,8 @@
+--- configure.orig Sun May 29 00:59:43 2005
++++ configure Mon Jul 10 14:10:06 2006
+@@ -20481,8 +20481,8 @@
echo "curl found - remote install options available"
- CURL_CFLAGS=`$CURL_CONFIG --cflags`
+ CURL_AM_CFLAGS=`$CURL_CONFIG --cflags`
CURL_LIBS=`$CURL_CONFIG --libs`
-- CXXFLAGS="$CXXFLAGS -DCURLAVAILABLE"
-- CFLAGS="$CFLAGS -DCURLAVAILABLE"
-+ CXXFLAGS="$CXXFLAGS -DCURLAVAILABLE $CURL_CFLAGS"
-+ CFLAGS="$CFLAGS -DCURLAVAILABLE $CURL_CFLAGS"
+- AM_CXXFLAGS="$AM_CXXFLAGS -DCURLAVAILABLE"
+- AM_CFLAGS="$AM_CFLAGS -DCURLAVAILABLE"
++ AM_CXXFLAGS="$AM_CXXFLAGS -DCURLAVAILABLE $CURL_AM_CFLAGS"
++ AM_CFLAGS="$AM_CFLAGS -DCURLAVAILABLE $CURL_AM_CFLAGS"
fi
fi
diff --git a/misc/sword15/files/patch-configure.ac b/misc/sword15/files/patch-configure.ac
index 64a367923b83..f461d8952bcf 100644
--- a/misc/sword15/files/patch-configure.ac
+++ b/misc/sword15/files/patch-configure.ac
@@ -1,13 +1,13 @@
---- configure.ac.orig Tue Aug 17 13:48:26 2004
-+++ configure.ac Tue Aug 17 13:48:53 2004
-@@ -151,8 +151,8 @@
+--- configure.ac.orig Mon Jul 10 18:22:50 2006
++++ configure.ac Mon Jul 10 18:23:13 2006
+@@ -187,8 +187,8 @@
echo "curl found - remote install options available"
- CURL_CFLAGS=`$CURL_CONFIG --cflags`
+ CURL_AM_CFLAGS=`$CURL_CONFIG --cflags`
CURL_LIBS=`$CURL_CONFIG --libs`
-- CXXFLAGS="$CXXFLAGS -DCURLAVAILABLE"
-- CFLAGS="$CFLAGS -DCURLAVAILABLE"
-+ CXXFLAGS="$CXXFLAGS -DCURLAVAILABLE $CURL_CFLAGS"
-+ CFLAGS="$CFLAGS -DCURLAVAILABLE $CURL_CFLAGS"
+- AM_CXXFLAGS="$AM_CXXFLAGS -DCURLAVAILABLE"
+- AM_CFLAGS="$AM_CFLAGS -DCURLAVAILABLE"
++ AM_CXXFLAGS="$AM_CXXFLAGS -DCURLAVAILABLE $CURL_AM_CFLAGS"
++ AM_CFLAGS="$AM_CFLAGS -DCURLAVAILABLE $CURL_AM_CFLAGS"
fi
fi
diff --git a/misc/sword15/pkg-descr b/misc/sword15/pkg-descr
index 288424dfcb59..4fb7725c1fc8 100644
--- a/misc/sword15/pkg-descr
+++ b/misc/sword15/pkg-descr
@@ -1,9 +1,8 @@
-The SWORD Project is an effort to create an ever expanding software package
-for research and study of God and His Word. The SWORD Bible Framework allows
-easy manipulation of Bible texts, commentaries, lexicons, dictionaries, etc.
-Many frontends are build using this framework. An installed module set may be
-shared between any frontend using the framework.
+The SWORD Project is an effort to create an ever expanding software
+package for research and study of God and His Word. The SWORD Bible
+Framework allows easy manipulation of Bible texts, commentaries,
+lexicons, dictionaries, etc. Many frontends are build using this
+framework. An installed module set may be shared between any frontend
+using the framework.
-WWW: http://www.crosswire.org/
-
-- Willem van Engen <wvengen@stack.nl>
+WWW: http://www.crosswire.org/sword
diff --git a/misc/sword15/pkg-plist b/misc/sword15/pkg-plist
index a236dc5b2e96..4d6129aa89dd 100644
--- a/misc/sword15/pkg-plist
+++ b/misc/sword15/pkg-plist
@@ -1,9 +1,9 @@
-etc/sword.conf
bin/addld
bin/diatheke
bin/imp2ld
bin/imp2vs
bin/installmgr
+bin/mkfastmod
bin/mod2imp
bin/mod2osis
bin/mod2vpl
@@ -11,10 +11,12 @@ bin/mod2zmod
bin/osis2mod
bin/vpl2mod
bin/vs2osisref
+etc/sword.conf
include/sword/Greek2Greek.h
include/sword/GreekChars.h
include/sword/canon.h
include/sword/cipherfil.h
+include/sword/curlftpt.h
include/sword/defs.h
include/sword/echomod.h
include/sword/encfiltmgr.h
@@ -22,7 +24,10 @@ include/sword/entriesblk.h
include/sword/femain.h
include/sword/filemgr.h
include/sword/flatapi.h
+include/sword/ftplib.h
+include/sword/ftplibftpt.h
include/sword/ftpparse.h
+include/sword/ftptrans.h
include/sword/gbffootnotes.h
include/sword/gbfheadings.h
include/sword/gbfhtml.h
@@ -52,17 +57,18 @@ include/sword/osisheadings.h
include/sword/osishtmlhref.h
include/sword/osislemma.h
include/sword/osismorph.h
+include/sword/osisosis.h
include/sword/osisplain.h
include/sword/osisredletterwords.h
include/sword/osisrtf.h
include/sword/osisscripref.h
include/sword/osisstrongs.h
include/sword/osiswebif.h
+include/sword/osiswordjs.h
include/sword/plainfootnotes.h
include/sword/plainhtml.h
include/sword/rawcom.h
include/sword/rawfiles.h
-include/sword/rawgbf.h
include/sword/rawgenbook.h
include/sword/rawld.h
include/sword/rawld4.h
@@ -75,6 +81,7 @@ include/sword/roman.h
include/sword/rtfhtml.h
include/sword/sapphire.h
include/sword/scsuutf8.h
+include/sword/stringmgr.h
include/sword/strkey.h
include/sword/swbasicfilter.h
include/sword/swbuf.h
@@ -84,13 +91,10 @@ include/sword/swcom.h
include/sword/swcomprs.h
include/sword/swconfig.h
include/sword/swdisp.h
-include/sword/swdisprtf.h
-include/sword/swdisprtfchap.h
include/sword/swfilter.h
include/sword/swfiltermgr.h
include/sword/swgenbook.h
include/sword/swinputmeth.h
-%%INSTALLMGR%%include/sword/swinstallmgr.h
include/sword/swkey.h
include/sword/swld.h
include/sword/swlocale.h
@@ -100,14 +104,11 @@ include/sword/swmgr.h
include/sword/swmodule.h
include/sword/swobject.h
include/sword/swoptfilter.h
-%%INSTALLMGR%%include/sword/swremotemgr.h
include/sword/swsearchable.h
include/sword/swtext.h
include/sword/swunicod.h
include/sword/swversion.h
-include/sword/swwinlog.h
include/sword/sysdata.h
-include/sword/tbdisp.h
include/sword/thmlfootnotes.h
include/sword/thmlgbf.h
include/sword/thmlheadings.h
@@ -122,11 +123,12 @@ include/sword/thmlscripref.h
include/sword/thmlstrongs.h
include/sword/thmlvariants.h
include/sword/thmlwebif.h
+include/sword/thmlwordjs.h
include/sword/treekey.h
include/sword/treekeyidx.h
include/sword/unicodertf.h
-include/sword/unixstr.h
include/sword/untgz.h
+include/sword/url.h
include/sword/utf16utf8.h
include/sword/utf8arshaping.h
include/sword/utf8bidireorder.h
@@ -139,10 +141,7 @@ include/sword/utf8nfc.h
include/sword/utf8nfkd.h
include/sword/utf8transliterator.h
include/sword/utf8utf16.h
-include/sword/utilconf.h
-include/sword/utilfuns.h
include/sword/utilstr.h
-include/sword/utilweb.h
include/sword/utilxml.h
include/sword/versekey.h
include/sword/zcom.h
@@ -153,39 +152,71 @@ include/sword/zlib.h
include/sword/zstr.h
include/sword/ztext.h
include/sword/zverse.h
+lib/libsword-1.5.8.so
lib/libsword.a
lib/libsword.la
lib/libsword.so
-lib/libsword.so.4
libdata/pkgconfig/sword.pc
-share/sword/locales.d/abbr.conf
-share/sword/locales.d/bg_BG-cp1251.conf
-share/sword/locales.d/cs.conf
-share/sword/locales.d/da.conf
-share/sword/locales.d/de.conf
-share/sword/locales.d/de_abbrev.conf
-share/sword/locales.d/en_GB.conf
-share/sword/locales.d/es.conf
-share/sword/locales.d/et.conf
-share/sword/locales.d/et_abbr.conf
-share/sword/locales.d/fi.conf
-share/sword/locales.d/fr.conf
-share/sword/locales.d/id.conf
-share/sword/locales.d/it.conf
-share/sword/locales.d/la.conf
-share/sword/locales.d/nl.conf
-share/sword/locales.d/no.conf
-share/sword/locales.d/pl.conf
-share/sword/locales.d/pt.conf
-share/sword/locales.d/pt_BR.conf
-share/sword/locales.d/ro.conf
-share/sword/locales.d/ru_RU-cp1251.conf
-share/sword/locales.d/ru_RU-koi8-r.conf
-share/sword/locales.d/sk.conf
-share/sword/locales.d/uk_UA-cp1251.conf
-share/sword/locales.d/uk_UA-koi8-u.conf
-@dirrm share/sword/locales.d
-@dirrm share/sword/mods.d
-@dirrm share/sword
+%%DATADIR%%/locales.d/abbr.conf
+%%DATADIR%%/locales.d/af-utf8.conf
+%%DATADIR%%/locales.d/af.conf
+%%DATADIR%%/locales.d/bg_BG-cp1251.conf
+%%DATADIR%%/locales.d/bg_BG-utf8.conf
+%%DATADIR%%/locales.d/cs-utf8.conf
+%%DATADIR%%/locales.d/cs.conf
+%%DATADIR%%/locales.d/da-utf8.conf
+%%DATADIR%%/locales.d/da.conf
+%%DATADIR%%/locales.d/de-utf8.conf
+%%DATADIR%%/locales.d/de.conf
+%%DATADIR%%/locales.d/de_abbrev-utf8.conf
+%%DATADIR%%/locales.d/de_abbrev.conf
+%%DATADIR%%/locales.d/en_GB.conf
+%%DATADIR%%/locales.d/es-utf8.conf
+%%DATADIR%%/locales.d/es.conf
+%%DATADIR%%/locales.d/et-utf8.conf
+%%DATADIR%%/locales.d/et.conf
+%%DATADIR%%/locales.d/et_abbr-utf8.conf
+%%DATADIR%%/locales.d/et_abbr.conf
+%%DATADIR%%/locales.d/fi-utf8.conf
+%%DATADIR%%/locales.d/fi.conf
+%%DATADIR%%/locales.d/fr-utf8.conf
+%%DATADIR%%/locales.d/fr.conf
+%%DATADIR%%/locales.d/hu-utf8.conf
+%%DATADIR%%/locales.d/hu.conf
+%%DATADIR%%/locales.d/id.conf
+%%DATADIR%%/locales.d/it-utf8.conf
+%%DATADIR%%/locales.d/it.conf
+%%DATADIR%%/locales.d/ko-utf8.conf
+%%DATADIR%%/locales.d/ko.conf
+%%DATADIR%%/locales.d/ko_abbrev-utf8.conf
+%%DATADIR%%/locales.d/ko_abbrev.conf
+%%DATADIR%%/locales.d/la.conf
+%%DATADIR%%/locales.d/lt-utf8.conf
+%%DATADIR%%/locales.d/nl.conf
+%%DATADIR%%/locales.d/no-utf8.conf
+%%DATADIR%%/locales.d/no.conf
+%%DATADIR%%/locales.d/pl-utf8.conf
+%%DATADIR%%/locales.d/pl.conf
+%%DATADIR%%/locales.d/pt-utf8.conf
+%%DATADIR%%/locales.d/pt.conf
+%%DATADIR%%/locales.d/pt_BR-utf8.conf
+%%DATADIR%%/locales.d/pt_BR.conf
+%%DATADIR%%/locales.d/ro.conf
+%%DATADIR%%/locales.d/ru_RU-cp1251.conf
+%%DATADIR%%/locales.d/ru_RU-koi8-r.conf
+%%DATADIR%%/locales.d/ru_RU-utf8.conf
+%%DATADIR%%/locales.d/sk-utf8.conf
+%%DATADIR%%/locales.d/sk.conf
+%%DATADIR%%/locales.d/sl.conf
+%%DATADIR%%/locales.d/sv-utf8.conf
+%%DATADIR%%/locales.d/sv.conf
+%%DATADIR%%/locales.d/uk_UA-cp1251.conf
+%%DATADIR%%/locales.d/uk_UA-koi8-u.conf
+%%DATADIR%%/locales.d/uk_UA-utf8.conf
+@dirrm %%DATADIR%%/mods.d
+@dirrm %%DATADIR%%/locales.d
+@dirrm %%DATADIR%%
+@dirrm share/nls/en_US.US-ASCII
+@dirrm share/nls/POSIX
@dirrm lib/sword
@dirrm include/sword